]> git.pld-linux.org Git - packages/vim.git/commitdiff
Up to 8.2.3570. auto/th/vim-8.2.3570-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Nov 2021 19:30:02 +0000 (20:30 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Nov 2021 19:30:02 +0000 (20:30 +0100)
desktop.patch
vim-man_installation.patch
vim-modprobe.patch
vim-tutor-lessdeps.patch
vim.spec

index dfd7cf000c989ccd033cc9d716db63ad021bedc8..53aca05e45a400366da8f9ffc5975ad57b64e302 100644 (file)
@@ -49,16 +49,14 @@ diff --color -ur vim-8.2.2529.orig/gvim-motif.desktop vim-8.2.2529/gvim-motif.de
  # Translators: This is the Generic Application Name used in the Vim desktop file
  GenericName[de]=Texteditor
  GenericName[eo]=Tekstoredaktilo
-Only in vim-8.2.2529: gvim-motif.desktop.orig
-diff --color -ur vim-8.2.2529.orig/runtime/vim.desktop vim-8.2.2529/runtime/vim.desktop
---- vim-8.2.2529.orig/runtime/vim.desktop      2021-02-17 21:57:03.000000000 +0100
-+++ vim-8.2.2529/runtime/vim.desktop   2021-03-02 14:24:51.273731018 +0100
-@@ -113,6 +113,6 @@
- Icon[fr]=gvim
- Icon[ru]=gvim
+--- vim-8.2.3570/runtime/vim.desktop~  2021-11-01 23:58:43.000000000 +0100
++++ vim-8.2.3570/runtime/vim.desktop   2021-11-02 20:11:30.533015830 +0100
+@@ -112,6 +112,6 @@ Keywords[tr]=Metin;düzenleyici;
+ Keywords=Text;editor;
+ # Translators: This is the Icon file name. Do NOT translate
  Icon=gvim
 -Categories=Utility;TextEditor;
 +Categories=ConsoleOnly;TextEditor;
  StartupNotify=false
  MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
-Only in vim-8.2.2529/runtime: vim.desktop.orig
+
index a4d615db1a6fda0a222112e9e03f3ddc12b0ef36..a631c0472149b7e5f0d689dfeedf386e7787d9cc 100644 (file)
                $(DEST_MAN_TR_I) $(INSTALLMLARGS)
        -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
                $(DEST_MAN_TR_U) $(INSTALLMLARGS)
-@@ -2875,7 +2883,7 @@
+@@ -2895,7 +2895,7 @@
        -rm -f $(DEST_MAN_IT)/xxd.1 $(DEST_MAN_IT_I)/xxd.1 $(DEST_MAN_IT_U)/xxd.1
        -rm -f $(DEST_MAN_JA_U)/xxd.1
        -rm -f $(DEST_MAN_PL)/xxd.1 $(DEST_MAN_PL_I)/xxd.1 $(DEST_MAN_PL_U)/xxd.1
 +      -rm -f $(DEST_MAN_RU)/xxd.1 $(DEST_MAN_RU_U)/xxd.1 $(DEST_MAN_RU_K)/xxd.1
        -rm -f $(DEST_HELP)/*.txt $(DEST_HELP)/tags $(DEST_HELP)/*.pl
        -rm -f $(DEST_HELP)/*.??x $(DEST_HELP)/tags-??
-       -rm -f $(SYS_RGB_FILE)
+       -rm -f $(SYS_MENU_FILE) $(SYS_SYNMENU_FILE) $(SYS_DELMENU_FILE)
+
index 5d8f3cd2f26538e39d70d1aacaff9541486c9fac..9a0574fbbbb6764815179ccc7cfc7013eaa45265 100644 (file)
@@ -7,6 +7,6 @@
 -au BufNewFile,BufRead */etc/modules.conf,*/etc/modules,*/etc/conf.modules setf modconf
 +au BufNewFile,BufRead */etc/modules.conf,*/etc/modules,*/etc/conf.modules,*/etc/modprobe.conf setf modconf
  
- " Mplayer config
- au BufNewFile,BufRead mplayer.conf,*/.mplayer/config  setf mplayerconf
+ " MPD is based on XML
+ au BufNewFile,BufRead *.mpd                   setf xml
 
index 5ba844272bd4f79942505414c2930e4f2568232a..7adebd8bd91739ea19389ed3a48b8dc8cc64da5d 100644 (file)
@@ -1,5 +1,5 @@
---- vim71/src/vimtutor~        2008-05-29 22:14:57.000000000 +0300
-+++ vim71/src/vimtutor 2008-05-29 22:24:29.118736307 +0300
+--- vim-8.2.3570/src/vimtutor.orig     2021-11-02 20:05:13.183015908 +0100
++++ vim-8.2.3570/src/vimtutor  2021-11-02 20:07:12.539682552 +0100
 @@ -9,14 +9,12 @@
  # When this fails or no argument was given, it tries using 'v:lang'
  # When that also fails, it uses the English version.
 -seq="vim vim81 vim80 vim8 vim74 vim73 vim72 vim71 vim70 vim7 vim6 vi"
 +# Vim could be called "vim" or "vi".
 +seq="/usr/bin/vim.heavy /usr/bin/vim /bin/vi"
- if test "$1" = "-g"; then 
-   # Try to use the GUI version of Vim if possible, it will fall back
-   # on Vim if Gvim is not installed.
--  seq="gvim gvim81 gvim80 gvim8 gvim74 gvim73 gvim72 gvim71 gvim70 gvim7 gvim6 $seq"
-+  seq="/usr/bin/gvim /usr/bin/gvim.heavy /usr/bin/gvim.athena /usr/bin/gvim.gnome /usr/bin/gvim.gtk /usr/bin/gvim.motif $seq"
-   shift
+ if test "$1" = "-g"; then
+     # Try to use the GUI version of Vim if possible, it will fall back
+     # on Vim if Gvim is not installed.
+-    seq="gvim gvim81 gvim80 gvim8 gvim74 gvim73 gvim72 gvim71 gvim70 gvim7 gvim6 $seq"
++    seq="/usr/bin/gvim /usr/bin/gvim.heavy /usr/bin/gvim.athena /usr/bin/gvim.gnome /usr/bin/gvim.gtk /usr/bin/gvim.motif $seq"
+     shift
  fi
  
-@@ -53,8 +51,7 @@
+@@ -53,8 +51,7 @@ export TUTORCOPY
  trap "rm -rf $TODELETE" 0 1 2 3 9 11 13 15
  
  for i in $seq; do
--      testvim=`which $i 2>/dev/null`
--      if test -f "$testvim"; then
-+      if test -x "$i"; then
-               VIM=$i
-               break
-       fi
+-    testvim=$(which $i 2>/dev/null)
+-    if test -f "$testvim"; then
++    if test -x "$i"; then
+         VIM=$i
+         break
+     fi
index 5fa92f21938bbfc65f10922a3c8bf189bdbe9f8f..b7b4afc9331956e33145a56ebcc4090d4c0b1aa8 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -31,8 +31,8 @@
 # wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.2.2976
-%define                rel             2
+%define                ver             8.2.3570
+%define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -52,7 +52,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: 7f4423540a6e9bc17612ac846190a7c9
+# Source0-md5: 50cbcd6e830061176ab268fdedd4690a
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -1265,8 +1265,6 @@ rm -rf $RPM_BUILD_ROOT
 %verify(not md5 mtime size) %{_datadir}/vim/doc/tags
 %lang(pl) %verify(not md5 mtime size) %{_datadir}/vim/doc/tags-pl
 %verify(not md5 mtime size) %{_datadir}/vim/vimfiles/doc/tags
-# X11 colours definition for colour name lookup
-%{_datadir}/vim/rgb.txt
 
 %dir %{_datadir}/vim/vimfiles
 %dir %{_datadir}/vim/vimfiles/doc
@@ -1321,6 +1319,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/colors
 %doc %{_datadir}/vim/colors/README.txt
 %{_datadir}/vim/colors/*.vim
+%dir %{_datadir}/vim/colors/lists
+%{_datadir}/vim/colors/lists/*.vim
 %dir %{_datadir}/vim/colors/tools
 %{_datadir}/vim/colors/tools/check_colors.vim
 
This page took 0.215459 seconds and 4 git commands to generate.