]> git.pld-linux.org Git - packages/vim.git/commitdiff
- up to 8.2.1524 auto/th/vim-8.2.1524-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Aug 2020 07:49:12 +0000 (09:49 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Aug 2020 07:49:12 +0000 (09:49 +0200)
027_all_vim-7.0-automake-substitutions-93378.patch
vim-home_etc.patch
vim-localedir.patch
vim-man_installation.patch
vim-pam.patch
vim.spec

index e6849f5d2933a99d61e91ce0388459040ce189cd..ae73eb864f9da7edb43142fa56fc1e203d47139d 100644 (file)
@@ -1,33 +1,39 @@
-Index: runtime/syntax/automake.vim
-===================================================================
-RCS file: /cvsroot/vim/vim/runtime/syntax/automake.vim,v
-retrieving revision 1.5
-diff -u -r1.5 automake.vim
---- runtime/syntax/automake.vim        13 May 2001 20:01:37 -0000      1.5
-+++ runtime/syntax/automake.vim        23 May 2005 09:57:19 -0000
-@@ -44,6 +44,8 @@
- syn region  automakeMakeSString start=+'+  skip=+\\'+  end=+'+  contains=makeIdent,automakeSubstitution
+---
+ runtime/syntax/automake.vim | 3 +++
+ runtime/syntax/make.vim     | 6 ++----
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/runtime/syntax/automake.vim b/runtime/syntax/automake.vim
+index 8a7db7c..cb2b82f 100644
+--- a/runtime/syntax/automake.vim
++++ b/runtime/syntax/automake.vim
+@@ -53,6 +53,9 @@ syn region  automakeMakeSString start=+'+  skip=+\\'+  end=+'+  contains=makeIde
  syn region  automakeMakeBString start=+`+  skip=+\\`+  end=+`+  contains=makeIdent,makeSString,makeDString,makeNextLine,automakeSubstitution
  
+ " Define the default highlighting.
++
 +syn cluster makeCommandsContains add=autoMakeSubst,automakeMakeError,automakeBadSubst
 +
- " Define the default highlighting.
- " For version 5.7 and earlier: only when not done already
- " For version 5.8 and later: only when an item doesn't have highlighting yet
-Index: runtime/syntax/make.vim
-===================================================================
-RCS file: /cvsroot/vim/vim/runtime/syntax/make.vim,v
-retrieving revision 1.15
-diff -u -r1.15 make.vim
---- runtime/syntax/make.vim    8 May 2004 00:02:43 -0000       1.15
-+++ runtime/syntax/make.vim    23 May 2005 09:57:19 -0000
-@@ -58,7 +58,8 @@
- syn match makeSpecTarget              "^\.\(SUFFIXES\|PHONY\|DEFAULT\|PRECIOUS\|IGNORE\|SILENT\|EXPORT_ALL_VARIABLES\|KEEP_STATE\|LIBPATTERNS\|NOTPARALLEL\|DELETE_ON_ERROR\|INTERMEDIATE\|POSIX\|SECONDARY\)\>::\=\s*$" contains=makeIdent skipnl nextgroup=makeCommands,makeCommandError
+ " Only when an item doesn't have highlighting yet
+ hi def link automakePrimary     Statement
+diff --git a/runtime/syntax/make.vim b/runtime/syntax/make.vim
+index 2a64dcd..7325db1 100644
+--- a/runtime/syntax/make.vim
++++ b/runtime/syntax/make.vim
+@@ -62,10 +62,8 @@ syn match makeSpecTarget    "^\.\(SUFFIXES\|PHONY\|DEFAULT\|PRECIOUS\|IGNORE\|SILEN
+       \ skipnl nextgroup=makeCommands,makeCommandError
  
  syn match makeCommandError "^\s\+\S.*" contained
--syn region makeCommands start=";"hs=s+1 start="^\t" end="^[^\t#]"me=e-1,re=e-1 end="^$" contained contains=makeCmdNextLine,makeSpecial,makeComment,makeIdent,makePreCondit,makeDefine,makeDString,makeSString nextgroup=makeCommandError
+-syn region makeCommands contained start=";"hs=s+1 start="^\t"
+-      \ end="^[^\t#]"me=e-1,re=e-1 end="^$"
+-      \ contains=makeCmdNextLine,makeSpecial,makeComment,makeIdent,makePreCondit,makeDefine,makeDString,makeSString
+-      \ nextgroup=makeCommandError
 +syn region makeCommands start=";"hs=s+1 start="^\t" end="^[^\t#]"me=e-1,re=e-1 end="^$" contained contains=@makeCommandsContains nextgroup=makeCommandError
 +syn cluster makeCommandsContains add=makeCmdNextLine,makeSpecial,makeComment,makeIdent,makePreCondit,makeDefine,makeDString,makeSString
  syn match makeCmdNextLine     "\\\n."he=e-1 contained
  
+ " some directives
+-- 
+2.24.1
+
index d8ce61297304bf458083ebbe96fa9e46e5a2baeb..faf93c9e79701fb87b7b766cc4f52a5885af2917 100644 (file)
@@ -1,7 +1,7 @@
 diff -Nru vim62.orig/src/misc1.c vim62/src/misc1.c
 --- vim62.orig/src/misc1.c     2003-11-11 18:53:52.000000000 +0100
 +++ vim62/src/misc1.c  2003-11-11 19:29:32.000000000 +0100
-@@ -2220,12 +2220,19 @@
+@@ -1660,6 +1660,7 @@ vim_getenv(char_u *name, int *mustfree)
        return p;
      }
  #else
@@ -9,18 +9,18 @@ diff -Nru vim62.orig/src/misc1.c vim62/src/misc1.c
      p = mch_getenv(name);
      if (p != NULL && *p == NUL)           // empty is the same as not set
        p = NULL;
+@@ -1667,6 +1668,11 @@ vim_getenv(char_u *name, int *mustfree)
      if (p != NULL)
        return p;
-+
 +    if (strcmp(name, "HOME_ETC") == 0) {
 +      name = "HOME";
 +      goto first_test;
 +    }
 +
- #endif
-     // handling $VIMRUNTIME and $VIM is below, bail out if it's another name.
+ # ifdef __HAIKU__
+     // special handling for user settings directory...
+     if (STRCMP(name, "BE_USER_SETTINGS") == 0)
 --- vim62.orig/src/os_unix.h   2003-11-11 18:53:52.000000000 +0100
 +++ vim62/src/os_unix.h        2003-11-11 19:53:54.000000000 +0100
 @@ -264,7 +264,7 @@
@@ -69,20 +69,20 @@ diff -Nru vim62.orig/src/misc1.c vim62/src/misc1.c
  #endif
  
 @@ -371,14 +371,14 @@
- # ifdef RUNTIME_GLOBAL
- #  ifdef RUNTIME_GLOBAL_AFTER
- #   define DFLT_RUNTIMEPATH   "~/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER ",~/.vim/after"
--#   define CLEAN_RUNTIMEPATH  RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER
-+#   define CLEAN_RUNTIMEPATH  "$HOME_ETC/.vim/after," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER
+ #  ifdef RUNTIME_GLOBAL
+ #   ifdef RUNTIME_GLOBAL_AFTER
+ #    define DFLT_RUNTIMEPATH  "~/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER ",~/.vim/after"
+-#    define CLEAN_RUNTIMEPATH RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER
++#    define CLEAN_RUNTIMEPATH "$HOME_ETC/.vim/after," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL_AFTER
+ #   else
+ #    define DFLT_RUNTIMEPATH  "~/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after,~/.vim/after"
+-#    define CLEAN_RUNTIMEPATH RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after"
++#    define CLEAN_RUNTIMEPATH "$HOME_ETC/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after"
+ #   endif
  #  else
- #   define DFLT_RUNTIMEPATH   "~/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after,~/.vim/after"
--#   define CLEAN_RUNTIMEPATH  RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after"
-+#   define CLEAN_RUNTIMEPATH  "$HOME_ETC/.vim," RUNTIME_GLOBAL ",$VIMRUNTIME," RUNTIME_GLOBAL "/after"
+ #   define DFLT_RUNTIMEPATH   "~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after"
+-#   define CLEAN_RUNTIMEPATH  "$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after"
++#   define CLEAN_RUNTIMEPATH  "$HOME_ETC/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after"
  #  endif
- # else
- #  define DFLT_RUNTIMEPATH    "~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after"
--#  define CLEAN_RUNTIMEPATH   "$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after"
-+#  define CLEAN_RUNTIMEPATH   "$HOME_ETC/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after"
  # endif
- #endif
  
index 18b4a4cbf1e46140a448ff46a1e5f5ce06c3448d..5a4c8e0ab5baac22caa1d13a344cc67985227aad 100644 (file)
@@ -1,5 +1,5 @@
---- vim72/src/main.c~  2009-04-15 01:00:47.000000000 +0300
-+++ vim72/src/main.c   2009-04-15 01:11:33.555899981 +0300
+--- vim72/src/locale.c~        2009-04-15 01:00:47.000000000 +0300
++++ vim72/src/locale.c 2009-04-15 01:11:33.555899981 +0300
 @@ -1741,17 +1741,6 @@ init_locale(void)
        // Initialize the gettext library
        dyn_libintl_init();
index f40acb7ba8038593e3380c642f23c5a3c51c7092..eed368f067ce7f19deee66f32f881e27813eae67 100644 (file)
        -$(SHELL) ./installman.sh uninstall $(DEST_MAN_RU_U) "" $(INSTALLMANARGS)
        -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
                $(DEST_MAN) $(INSTALLMLARGS)
-@@ -2672,6 +2672,8 @@ uninstall_runtime:
-               $(DEST_MAN_RU) $(INSTALLMLARGS)
+@@ -2660,6 +2660,8 @@ uninstall_runtime:
+       -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
+               $(DEST_MAN_TR) $(INSTALLMLARGS)
        -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
-               $(DEST_MAN_RU_U) $(INSTALLMLARGS)
-+      -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
 +              $(DEST_MAN_RU_K) $(INSTALLMLARGS)
-       -rm -f $(DEST_MAN)/xxd.1
-       -rm -f $(DEST_MAN_DA)/xxd.1 $(DEST_MAN_DA_I)/xxd.1 $(DEST_MAN_DA_U)/xxd.1
-       -rm -f $(DEST_MAN_DE)/xxd.1 $(DEST_MAN_DE_I)/xxd.1 $(DEST_MAN_DE_U)/xxd.1
++      -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
+               $(DEST_MAN_TR_I) $(INSTALLMLARGS)
+       -$(SHELL) ./installml.sh uninstall "$(GUI_MAN_TARGETS)" \
+               $(DEST_MAN_TR_U) $(INSTALLMLARGS)
 @@ -2679,7 +2681,7 @@ uninstall_runtime:
        -rm -f $(DEST_MAN_IT)/xxd.1 $(DEST_MAN_IT_I)/xxd.1 $(DEST_MAN_IT_U)/xxd.1
        -rm -f $(DEST_MAN_JA_U)/xxd.1
index f954cd741bf8dc620cdf4d0168b81623c02e5b87..4077b66dfbfb010b3f9b2eb39fefb923d2e1590b 100644 (file)
@@ -1,11 +1,14 @@
 --- vim74/runtime/filetype.vim~        2013-09-06 00:12:00.000000000 +0300
 +++ vim74/runtime/filetype.vim 2013-09-06 00:12:35.086158130 +0300
-@@ -1330,7 +1330,7 @@
- au BufNewFile,BufRead pf.conf                 setf pf
+--- vim-8.2.1524/runtime/filetype.vim~ 2020-08-26 09:16:25.000000000 +0200
++++ vim-8.2.1524/runtime/filetype.vim  2020-08-26 09:17:06.450765953 +0200
+@@ -1153,7 +1153,7 @@ au BufNewFile,BufRead *.hook
+       \ endif
  
  " Pam conf
--au BufNewFile,BufRead */etc/pam.conf          setf pamconf
-+au BufNewFile,BufRead */etc/pam.conf,*.pam,*.pamd     setf pamconf
+-au BufNewFile,BufRead */etc/pam.conf                  setf pamconf
++au BufNewFile,BufRead */etc/pam.conf,*.pam,*.pamd                     setf pamconf
  
- " PApp
- au BufNewFile,BufRead *.papp,*.pxml,*.pxsl    setf papp
+ " Pam environment
+ au BufNewFile,BufRead pam_env.conf,.pam_environment   setf pamenv
+
index b586fa9a133e332ef6c1685b74f3aecd9c9ca749..b095226b3ec53559ac2f8ba3975a822844d34433 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -31,7 +31,7 @@
 # wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.2.0241
+%define                ver             8.2.1524
 %define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
@@ -52,7 +52,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: a69b492a02dfd671fc70af2e212355bc
+# Source0-md5: 00e6782f70651a49b976c85ec0ab1895
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -784,7 +784,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 %patch12 -p1
 %patch14 -p1
 %patch15 -p1
-%patch17 -p0
+%patch17 -p1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
This page took 0.212223 seconds and 4 git commands to generate.