]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- rebuild with ruby 2.4
[packages/vim.git] / vim.spec
index c235fc22b1568f05cdda44ee6062299a18aa0124..ed449b107ca8591980eabfad4da88ee30c8b1d1d 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -4,10 +4,12 @@
 %bcond_without athena          # don't build Athena Widgets-based gvim
 %bcond_without motif           # don't build Motif-based gvim
 %bcond_without gtk             # don't build GTK+-based gvim support
+%bcond_with    gtk3            # use GTK+ 3.x instead of 2.x
 %bcond_without gnome           # don't build GNOME-based gvim support
 %bcond_without heavy           # don't build heavy (full-featured GNOME-based gvim/vim)
 %bcond_without gui             # don't build any GUI
 %bcond_without light           # don't build light (minimal, ncurses, but not static)
+%bcond_without x11             # don't build vimx (non-GUI with X11 clipboard support)
 %bcond_with    lua             # with Lua interp in vim package
 %bcond_with    perl            # with Perl interp in vim package
 %bcond_with    python          # with Python interp in vim package
 %endif
 
 # Command to check for latest patch:
-# wget ftp://ftp.vim.org/pub/editors/vim/patches/7.4/MD5SUMS -O sources
-# tail -n1 sources | awk '{print $2}'
+# wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             7.4.1943
-%define                rel             1
+%define                ver             8.1.0005
+%define                rel             2
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -49,7 +50,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: 0ea9464041fe4b1f09e760c8ab6687ec
+# Source0-md5: b758c94c83c3fe9de2f2361be429c941
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -73,7 +74,7 @@ Patch0:               %{name}-sysconfdir.patch
 
 Patch2:                %{name}-paths.patch
 Patch3:                %{name}-no_libelf.patch
-Patch4:                %{name}-egrep.patch
+
 Patch5:                %{name}-awk.patch
 Patch6:                %{name}-filetype_vim-perl_tests.patch
 Patch7:                %{name}-apache.patch
@@ -99,7 +100,7 @@ Patch28:     %{name}-ft-cron.patch
 Patch29:       %{name}-phpscript.patch
 Patch30:       %{name}-pam.patch
 Patch32:       %{name}-localedir.patch
-Patch33:       %{name}-locales.patch
+
 Patch34:       %{name}-rtdir.patch
 Patch35:       %{name}-ft-mib.patch
 Patch36:       %{name}-ft-lib-udevrules.patch
@@ -110,24 +111,38 @@ Patch40:  desktop.patch
 Patch41:       %{name}-lua.patch
 URL:           http://www.vim.org/
 BuildRequires: acl-devel
-BuildRequires: autoconf
+BuildRequires: attr-devel
+BuildRequires: autoconf >= 2.12
 BuildRequires: gpm-devel
 %if "%{pld_release}" == "ac"
-%{?with_athena:BuildRequires:  XFree86-devel}
+%if %{with athena} || %{with x11}
+BuildRequires: XFree86-devel
+%endif
 BuildRequires: gettext-devel
 %else
 BuildRequires: gettext-tools
 %{?with_athena:BuildRequires:  xorg-lib-libXaw-devel}
+%if %{with x11} || %{with gui}
+BuildRequires: xorg-lib-libICE-devel
+BuildRequires: xorg-lib-libSM-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXt-devel
 %endif
+%endif
+BuildRequires: grep
 %if %{with gtk} || %{with heavy}
+%if %{with gtk3}
+BuildRequires: gtk+3-devel >= 3.0
+%else
 BuildRequires: gtk+2-devel >= 2:2.6.0
 %endif
+%endif
 %{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0.1}
 %if %{with selinux} || %{with heavy}
 BuildRequires: libselinux-devel
 %endif
 %if %{with lua} || %{with heavy}
-BuildRequires: lua52-devel
+BuildRequires: lua52-devel >= 5.2
 %endif
 %{?with_motif:BuildRequires:   motif-devel}
 BuildRequires: ncurses-devel
@@ -136,16 +151,16 @@ BuildRequires:    pkgconfig
 BuildRequires: perl-devel
 %endif
 %if %{with python} || %{with heavy}
-BuildRequires: python-devel
+BuildRequires: python-devel >= 2.3
 BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.426
+BuildRequires: rpmbuild(macros) >= 1.718
 %if %{with ruby} || %{with heavy}
-BuildRequires: ruby-devel
+BuildRequires: ruby-devel >= 1.6.0
 %endif
 %if %{with tcl} || %{with heavy}
-BuildRequires: tcl-devel
+BuildRequires: tcl-devel >= 8.0
 %endif
 Obsoletes:     kvim
 %if %{with static}
@@ -429,10 +444,10 @@ Requires: rpm-whiteout >= 1.3
 Requires:      vim-plugin-securemodelines
 Obsoletes:     gvim-bonobo
 Obsoletes:     vim-common
+Obsoletes:     vim-syntax-docker < 1.10.1
 Obsoletes:     vim-syntax-gitcommit
 Obsoletes:     vim-syntax-golang <= 1.3.3-1
 Obsoletes:     vim-syntax-lxc-docker <= 0.9.0-1
-Obsoletes:     vim-syntax-docker < 1.10.1
 Obsoletes:     vim-syntax-upstart
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
@@ -520,8 +535,8 @@ zainstalować ten pakiet.
 Summary:       Context Vim documentation
 Summary(pl.UTF-8):     Dokumentacja kontekstowa do Vima
 Group:         Applications/Editors/Vim
+Requires(post,postun): /usr/bin/vim
 Requires:      %{name}-rt = %{epoch}:%{version}-%{release}
-Requires:      gzip
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
 %endif
@@ -715,7 +730,8 @@ Summary:    Full featured build of Vim with X Window support
 Summary(hu.UTF-8):     A gvim legteljesebb verziója
 Summary(pl.UTF-8):     W pełni funkcjonalna wersja Vima z interfejsem dla X Window
 Group:         Applications/Editors/Vim
-Requires(post,postun): gtk+2
+Requires(post,postun): gtk-update-icon-cache
+Requires(post,postun): hicolor-icon-theme
 Requires:      %{name}-rt = %{epoch}:%{version}-%{release}
 Requires:      %{name}-rt-extras = %{epoch}:%{version}-%{release}
 Requires:      iconv
@@ -749,7 +765,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
+
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
@@ -778,7 +794,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 %patch29 -p1
 %patch30 -p1
 %patch32 -p1
-%patch33 -p1
+
 %patch34 -p1
 %patch35 -p1
 %patch36 -p1
@@ -796,19 +812,6 @@ cp -p %{SOURCE32} runtime/colors
 
 %{__unzip} -qd runtime/doc %{SOURCE2}
 
-# remove unsupported locales
-%{__rm} src/po/zh_{CN,TW}.UTF-8.po
-%{__rm} runtime/lang/menu_zh_{cn,tw}.utf-8.vim
-
-# fix nb/no
-%{__mv} src/po/n{o,b}.po
-%{__mv} runtime/tutor/tutor.n{o,b}
-%{__mv} runtime/tutor/tutor.n{o,b}.utf-8
-%{__mv} runtime/lang/menu_n{o,b}.latin1.vim
-%{__mv} runtime/lang/menu_n{o,b}.utf-8.vim
-%{__mv} runtime/lang/menu_n{o,b}_no.latin1.vim
-%{__mv} runtime/lang/menu_n{o,b}_no.utf-8.vim
-
 # not info files but some binary files for Amiga:
 # Amiga Workbench drawer icon
 # Amiga Workbench project icon
@@ -899,10 +902,12 @@ build vim.ncurses \
        --without-x \
        --with-features=huge
 
+%if %{with x11}
 build vimx \
        --disable-gui \
        --with-x \
        --with-features=huge
+%endif
 
 %if %{with athena}
 build gvim.athena \
@@ -930,8 +935,13 @@ build gvim.motif \
 %if %{with gtk}
 build gvim.gtk \
        --with-features=huge \
+%if %{with gtk3}
+       --enable-gui=gtk3 \
+       --enable-gtk3-check \
+%else
        --enable-gui=gtk2 \
        --enable-gtk2-check \
+%endif
        --with-x \
        --disable-gpm
 
@@ -973,7 +983,6 @@ build gvim.heavy \
        --enable-rubyinterp \
        --enable-tclinterp \
        --disable-gpm
-
 %endif
 
 %{__make} xxd/xxd languages
@@ -991,7 +1000,19 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
 # generic gvim from upstream, but we have bunch of subpackages
 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/gvim.desktop
 
-# not supported locales added by 7.3.764 or later
+# fix nb/no
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/tutor/tutor.n{o,b}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/tutor/tutor.n{o,b}.utf-8
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}.latin1.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}.utf-8.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}_no.latin1.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}_no.utf-8.vim
+
+# remove unsupported locales
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.sjis
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
@@ -1001,16 +1022,10 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk.cp1251
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.cp936
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_zh_{cn,tw}.utf-8.vim
 
 %find_lang %{name}
 
-# use compressed docs, see :help gzip-helpfile
-%{__gzip} -9 $RPM_BUILD_ROOT%{_datadir}/vim/doc/*.txt
-%{__sed} -i -e 's=\(\t.*\.txt\)\t=\1.gz\t=' $RPM_BUILD_ROOT%{_datadir}/vim/doc/tags
-
-%{__gzip} -9 $RPM_BUILD_ROOT%{_datadir}/vim/doc/*.??x
-%{__sed} -i -e 's=\(\t.*\.plx\)\t=\1.gz\t=' $RPM_BUILD_ROOT%{_datadir}/vim/doc/tags-pl
-
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*
 
 %if %{with static}
@@ -1020,7 +1035,9 @@ install -p src/bin/vim.static     $RPM_BUILD_ROOT/bin/vi
 install -p src/bin/vim.ncurses $RPM_BUILD_ROOT/bin/vi
 ln -sf /bin/vi         $RPM_BUILD_ROOT%{_bindir}/vim
 %endif
+%if %{with x11}
 install -p src/bin/vimx        $RPM_BUILD_ROOT%{_bindir}/vimx
+%endif
 install -p src/xxd/xxd $RPM_BUILD_ROOT%{_bindir}/xxd
 install -p src/vimtutor        $RPM_BUILD_ROOT%{_bindir}/vimtutor
 
@@ -1071,7 +1088,10 @@ install -p src/bin/vim.light     $RPM_BUILD_ROOT%{_bindir}
 %endif
 
 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
-cp -p runtime/vim48x48.png $RPM_BUILD_ROOT%{_pixmapsdir}/vim.png
+mv $RPM_BUILD_ROOT{%{_iconsdir}/hicolor/48x48/apps,%{_pixmapsdir}}/gvim.png
+
+# locolor scheme no longer supported
+%{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/locolor
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
@@ -1098,6 +1118,12 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database
 
+%post doc
+%vim_doc_helptags
+
+%postun doc
+%vim_doc_helptags
+
 %post -n gvim-athena
 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database
 
@@ -1126,6 +1152,12 @@ rm -rf $RPM_BUILD_ROOT
 %update_desktop_database_postun
 %update_icon_cache hicolor
 
+%post -n gvim-heavy
+%update_icon_cache hicolor
+
+%postun -n gvim-heavy
+%update_icon_cache hicolor
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/rvim
@@ -1239,6 +1271,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/autoload
 %{_datadir}/vim/autoload/*complete.vim
 %doc %{_datadir}/vim/autoload/README.txt
+%dir %{_datadir}/vim/autoload/dist
+%{_datadir}/vim/autoload/dist/ft.vim
 
 %dir %{_datadir}/vim/ftdetect
 
@@ -1267,6 +1301,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/colors
 %doc %{_datadir}/vim/colors/README.txt
 %{_datadir}/vim/colors/*.vim
+%dir %{_datadir}/vim/colors/tools
+%{_datadir}/vim/colors/tools/check_colors.vim
 
 %dir %{_datadir}/vim/lang
 %doc %{_datadir}/vim/lang/README*
@@ -1324,7 +1360,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/vim.1*
 %lang(fi) %{_mandir}/fi/man1/vim.1*
 %lang(fr) %{_mandir}/fr/man1/vim.1*
-%{_pixmapsdir}/vim.png
+%{_pixmapsdir}/gvim.png
 
 # plugins in base -rt package
 %{_datadir}/vim/autoload/gzip.vim
@@ -1349,10 +1385,10 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 # English
-%{_datadir}/vim/doc/*.txt.gz
+%{_datadir}/vim/doc/*.txt
 
 # Polish
-%lang(pl) %{_datadir}/vim/doc/*.plx.gz
+%lang(pl) %{_datadir}/vim/doc/*.plx
 
 %files tutor
 %defattr(644,root,root,755)
@@ -1368,6 +1404,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %lang(de) %{_datadir}/vim/tutor/tutor.bar
 %lang(de) %{_datadir}/vim/tutor/tutor.bar.utf-8
+%lang(bg) %{_datadir}/vim/tutor/tutor.bg.utf-8
 %lang(ca) %{_datadir}/vim/tutor/tutor.ca
 %lang(ca) %{_datadir}/vim/tutor/tutor.ca.utf-8
 %lang(cs) %{_datadir}/vim/tutor/tutor.cs
@@ -1397,6 +1434,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_datadir}/vim/tutor/tutor.ja.utf-8
 %lang(ko) %{_datadir}/vim/tutor/tutor.ko.euc
 %lang(ko) %{_datadir}/vim/tutor/tutor.ko.utf-8
+%lang(lv) %{_datadir}/vim/tutor/tutor.lv
 %lang(nl) %{_datadir}/vim/tutor/tutor.nl
 %lang(nl) %{_datadir}/vim/tutor/tutor.nl.utf-8
 %lang(nb) %{_datadir}/vim/tutor/tutor.nb
@@ -1433,9 +1471,11 @@ rm -rf $RPM_BUILD_ROOT
 %lang(pl) %{_mandir}/pl/man1/vimtutor.1*
 %lang(ru) %{_mandir}/ru/man1/vimtutor.1*
 
+%if %{with x11}
 %files -n vimx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/vimx
+%endif
 
 %if %{with heavy}
 %files heavy
This page took 0.151951 seconds and 4 git commands to generate.