]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- rebuild with perl 5.30.0
[packages/vim.git] / vim.spec
index 3fc54a4b1ea37e3965e6f414e88a0370ebd93573..b2bdfd640d243de0a2615063c93219cc0536744a 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -4,7 +4,7 @@
 %bcond_without athena          # don't build Athena Widgets-based gvim
 %bcond_without motif           # don't build Motif-based gvim
 %bcond_without gtk             # don't build GTK+-based gvim support
-%bcond_with    gtk3            # use GTK+ 3.x instead of 2.x
+%bcond_without gtk3            # use GTK+ 2.x instead of 3.x
 %bcond_without gnome           # don't build GNOME-based gvim support
 %bcond_without heavy           # don't build heavy (full-featured GNOME-based gvim/vim)
 %bcond_without gui             # don't build any GUI
 %endif
 
 # Command to check for latest patch:
-# wget ftp://ftp.vim.org/pub/editors/vim/patches/7.4/MD5SUMS -O sources
-# tail -n1 sources | awk '{print $2}'
+# wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.0.0095
-%define                rel             1
+%define                ver             8.1.2352
+%define                rel             2
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -51,7 +50,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: d59dcdd985dfe4fffc6be6c20dd45ef1
+# Source0-md5: 92ca078a1472b7d7875a4eba35ee4a50
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -75,7 +74,7 @@ Patch0:               %{name}-sysconfdir.patch
 
 Patch2:                %{name}-paths.patch
 Patch3:                %{name}-no_libelf.patch
-Patch4:                %{name}-egrep.patch
+
 Patch5:                %{name}-awk.patch
 Patch6:                %{name}-filetype_vim-perl_tests.patch
 Patch7:                %{name}-apache.patch
@@ -101,7 +100,7 @@ Patch28:    %{name}-ft-cron.patch
 Patch29:       %{name}-phpscript.patch
 Patch30:       %{name}-pam.patch
 Patch32:       %{name}-localedir.patch
-Patch33:       %{name}-locales.patch
+
 Patch34:       %{name}-rtdir.patch
 Patch35:       %{name}-ft-mib.patch
 Patch36:       %{name}-ft-lib-udevrules.patch
@@ -130,6 +129,7 @@ BuildRequires:      xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXt-devel
 %endif
 %endif
+BuildRequires: grep
 %if %{with gtk} || %{with heavy}
 %if %{with gtk3}
 BuildRequires: gtk+3-devel >= 3.0
@@ -137,6 +137,7 @@ BuildRequires:      gtk+3-devel >= 3.0
 BuildRequires: gtk+2-devel >= 2:2.6.0
 %endif
 %endif
+BuildRequires: libcanberra-devel
 %{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0.1}
 %if %{with selinux} || %{with heavy}
 BuildRequires: libselinux-devel
@@ -444,10 +445,10 @@ Requires: rpm-whiteout >= 1.3
 Requires:      vim-plugin-securemodelines
 Obsoletes:     gvim-bonobo
 Obsoletes:     vim-common
+Obsoletes:     vim-syntax-docker < 1.10.1
 Obsoletes:     vim-syntax-gitcommit
 Obsoletes:     vim-syntax-golang <= 1.3.3-1
 Obsoletes:     vim-syntax-lxc-docker <= 0.9.0-1
-Obsoletes:     vim-syntax-docker < 1.10.1
 Obsoletes:     vim-syntax-upstart
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
@@ -765,7 +766,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
+
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
@@ -794,7 +795,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 %patch29 -p1
 %patch30 -p1
 %patch32 -p1
-%patch33 -p1
+
 %patch34 -p1
 %patch35 -p1
 %patch36 -p1
@@ -812,19 +813,6 @@ cp -p %{SOURCE32} runtime/colors
 
 %{__unzip} -qd runtime/doc %{SOURCE2}
 
-# remove unsupported locales
-%{__rm} src/po/zh_{CN,TW}.UTF-8.po
-%{__rm} runtime/lang/menu_zh_{cn,tw}.utf-8.vim
-
-# fix nb/no
-%{__mv} src/po/n{o,b}.po
-%{__mv} runtime/tutor/tutor.n{o,b}
-%{__mv} runtime/tutor/tutor.n{o,b}.utf-8
-%{__mv} runtime/lang/menu_n{o,b}.latin1.vim
-%{__mv} runtime/lang/menu_n{o,b}.utf-8.vim
-%{__mv} runtime/lang/menu_n{o,b}_no.latin1.vim
-%{__mv} runtime/lang/menu_n{o,b}_no.utf-8.vim
-
 # not info files but some binary files for Amiga:
 # Amiga Workbench drawer icon
 # Amiga Workbench project icon
@@ -882,6 +870,7 @@ build vim.static \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -889,7 +878,7 @@ build vim.static \
        --disable-tclinterp \
        --disable-cscope \
        --disable-gpm \
-       --disable-multibyte \
+       --enable-multibyte \
        --disable-nls
 
 LDFLAGS="%{rpmldflags}"
@@ -900,6 +889,7 @@ build vim.light \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -913,12 +903,14 @@ build vim.light \
 build vim.ncurses \
        --disable-gui \
        --without-x \
+       --disable-canberra \
        --with-features=huge
 
 %if %{with x11}
 build vimx \
        --disable-gui \
        --with-x \
+       --disable-canberra \
        --with-features=huge
 %endif
 
@@ -928,6 +920,7 @@ build gvim.athena \
        --enable-gui=athena \
        --with-x \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -940,6 +933,7 @@ build gvim.motif \
        --with-x \
        --enable-multibyte \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -956,6 +950,7 @@ build gvim.gtk \
        --enable-gtk2-check \
 %endif
        --with-x \
+       --disable-canberra \
        --disable-gpm
 
 %endif
@@ -982,6 +977,7 @@ build vim.heavy \
        --enable-pythoninterp \
        --enable-rubyinterp \
        --enable-tclinterp \
+       --disable-canberra \
        --disable-gpm
 
 build gvim.heavy \
@@ -1013,7 +1009,19 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
 # generic gvim from upstream, but we have bunch of subpackages
 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/gvim.desktop
 
-# not supported locales added by 7.3.764 or later
+# fix nb/no
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/tutor/tutor.n{o,b}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/tutor/tutor.n{o,b}.utf-8
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}.latin1.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}.utf-8.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}_no.latin1.vim
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_n{o,b}_no.utf-8.vim
+
+# remove unsupported locales
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.sjis
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
@@ -1023,6 +1031,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk.cp1251
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.cp936
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/vim/lang/menu_zh_{cn,tw}.utf-8.vim
 
 %find_lang %{name}
 
@@ -1271,6 +1280,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/autoload
 %{_datadir}/vim/autoload/*complete.vim
 %doc %{_datadir}/vim/autoload/README.txt
+%dir %{_datadir}/vim/autoload/dist
+%{_datadir}/vim/autoload/dist/ft.vim
 
 %dir %{_datadir}/vim/ftdetect
 
@@ -1299,6 +1310,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/colors
 %doc %{_datadir}/vim/colors/README.txt
 %{_datadir}/vim/colors/*.vim
+%dir %{_datadir}/vim/colors/tools
+%{_datadir}/vim/colors/tools/check_colors.vim
 
 %dir %{_datadir}/vim/lang
 %doc %{_datadir}/vim/lang/README*
This page took 0.258484 seconds and 4 git commands to generate.