]> git.pld-linux.org Git - packages/vde2.git/commitdiff
- added format patch to fix build with -Werror=format-security auto/th/vde2-2.3.2-1 auto/ti/vde2-2.3.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 21:59:31 +0000 (23:59 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Oct 2012 21:59:31 +0000 (23:59 +0200)
- make -j1 (there is race between building libvdesnmp and libvdemgmt)

vde2-format.patch [new file with mode: 0644]
vde2.spec

diff --git a/vde2-format.patch b/vde2-format.patch
new file mode 100644 (file)
index 0000000..5603468
--- /dev/null
@@ -0,0 +1,18 @@
+--- vde2-2.3.2/src/common/cmdparse.c.orig      2011-11-23 17:41:14.000000000 +0100
++++ vde2-2.3.2/src/common/cmdparse.c   2012-10-26 23:25:47.215786024 +0200
+@@ -284,13 +284,13 @@
+                                                               int i;
+                                                               for (i=0;i<argc;i++) {
+                                                                       if (i) fprintf(mf," ");
+-                                                                      fprintf(mf,argv[i]);
++                                                                      fprintf(mf,"%s",argv[i]);
+                                                               }
+                                                       } else {
+                                                               int num=atoi(t);
+                                                               while (*t >='0' && *t <= '9') t++;
+                                                               if (num < argc) 
+-                                                                      fprintf(mf,argv[num]);
++                                                                      fprintf(mf,"%s",argv[num]);
+                                                       }
+                                               } else
+                                                       fprintf(mf,"%c",*t);
index eafda40f8f8e8f39cc17250c4e43cb684c2ebfe8..79690f2c38cc68a93ffbe99944ae7c048bb1b626 100644 (file)
--- a/vde2.spec
+++ b/vde2.spec
@@ -8,6 +8,7 @@ Group:          Networking/Utilities
 Source0:       http://downloads.sourceforge.net/vde/%{name}-%{version}.tar.bz2
 # Source0-md5: 46fbc5f97f03dc517aa3b2c9d9ea6628
 Patch0:                %{name}-pathmax.patch
+Patch1:                %{name}-format.patch
 URL:           http://sourceforge.net/projects/vde/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -85,6 +86,7 @@ Pythonowy interfejs do VDE2.
 %prep
 %setup -q 
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -96,7 +98,7 @@ Pythonowy interfejs do VDE2.
        --disable-silent-rules \
        --enable-kernel-switch
 
-%{__make} \
+%{__make} -j1 \
        pythondir=%{py_sitedir}
 
 %install
This page took 0.130654 seconds and 4 git commands to generate.