]> git.pld-linux.org Git - packages/vcmi.git/commitdiff
- rebuild with boost 1.61 auto/th/vcmi-0.98-4
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 28 May 2016 18:12:29 +0000 (18:12 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 28 May 2016 18:12:29 +0000 (18:12 +0000)
- fix building with modern libstdc++
- rel 4

cxx.patch [new file with mode: 0644]
vcmi.spec

diff --git a/cxx.patch b/cxx.patch
new file mode 100644 (file)
index 0000000..aeed7b6
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,67 @@
+--- vcmi-0.98/lib/Connection.cpp~      2015-04-01 07:34:22.000000000 +0000
++++ vcmi-0.98/lib/Connection.cpp       2016-05-28 17:54:42.579831336 +0000
+@@ -440,7 +440,7 @@
+               return typeDescr;  //type found, return ptr to structure\r
\r
+       //type not found - add it to the list and return given ID\r
+-      auto newType = make_shared<TypeDescriptor>();\r
++      auto newType = std::make_shared<TypeDescriptor>();\r
+       newType->typeID = typeInfos.size() + 1;\r
+       newType->name = type->name();\r
+       typeInfos[type] = newType;\r
+--- vcmi-0.98/client/Client.cpp~       2015-04-01 07:34:22.000000000 +0000
++++ vcmi-0.98/client/Client.cpp        2016-05-28 18:01:35.421105201 +0000
+@@ -451,7 +451,7 @@
+                       }\r
+                       else \r
+                       {\r
+-                              installNewPlayerInterface(make_shared<CPlayerInterface>(color), color);\r
++                              installNewPlayerInterface(std::make_shared<CPlayerInterface>(color), color);\r
+                               humanPlayers++;\r
+                       }\r
+               }\r
+@@ -467,7 +467,7 @@
+               if(!gNoGUI)\r
+               {\r
+                       boost::unique_lock<boost::recursive_mutex> un(*LOCPLINT->pim);\r
+-                      auto p = make_shared<CPlayerInterface>(PlayerColor::NEUTRAL);\r
++                      auto p = std::make_shared<CPlayerInterface>(PlayerColor::NEUTRAL);\r
+                       p->observerInDuelMode = true;\r
+                       installNewPlayerInterface(p, boost::none);\r
+                       GH.curInt = p.get();\r
+@@ -550,7 +550,7 @@
+                       else\r
+                       {\r
+                               assert(isHuman);\r
+-                              nInt = make_shared<CPlayerInterface>(pid);\r
++                              nInt = std::make_shared<CPlayerInterface>(pid);\r
+                       }\r
\r
+                       nInt->dllName = dllname;\r
+@@ -620,7 +620,7 @@
+                       else\r
+                       {\r
+                               assert(isHuman);\r
+-                              nInt = make_shared<CPlayerInterface>(pid);\r
++                              nInt = std::make_shared<CPlayerInterface>(pid);\r
+                       }\r
\r
+                       nInt->dllName = dllname;\r
+@@ -866,7 +866,7 @@
+       playerint[colorUsed] = gameInterface;\r
\r
+       logGlobal->traceStream() << boost::format("\tInitializing the interface for player %s") % colorUsed;\r
+-      auto cb = make_shared<CCallback>(gs, color, this);\r
++      auto cb = std::make_shared<CCallback>(gs, color, this);\r
+       callbacks[colorUsed] = cb;\r
+       battleCallbacks[colorUsed] = cb;\r
+       gameInterface->init(cb);\r
+@@ -887,7 +887,7 @@
+       if(needCallback)\r
+       {\r
+               logGlobal->traceStream() << boost::format("\tInitializing the battle interface for player %s") % *color;\r
+-              auto cbc = make_shared<CBattleCallback>(gs, color, this);\r
++              auto cbc = std::make_shared<CBattleCallback>(gs, color, this);\r
+               battleCallbacks[colorUsed] = cbc;\r
+               battleInterface->init(cbc);\r
+       }\r
index 5f8640bd51bc0ba2ca523b8961b2d1919211ffb7..afc3a3c34b8d49cbb228a065c58dc9187a1a91df 100644 (file)
--- a/vcmi.spec
+++ b/vcmi.spec
@@ -1,7 +1,7 @@
 Summary:       Heroes 3: WoG recreated
 Name:          vcmi
 Version:       0.98
 Summary:       Heroes 3: WoG recreated
 Name:          vcmi
 Version:       0.98
-Release:       3
+Release:       4
 License:       GPL v2+
 Group:         X11/Applications/Games
 Source0:       https://github.com/vcmi/vcmi/archive/%{version}/%{name}-%{version}.tar.gz
 License:       GPL v2+
 Group:         X11/Applications/Games
 Source0:       https://github.com/vcmi/vcmi/archive/%{version}/%{name}-%{version}.tar.gz
@@ -10,6 +10,7 @@ Source1:      http://download.vcmi.eu/core.zip
 # Source1-md5: 5cf75d588cc53b93aceb809a6068ae37
 Patch0:                boost-1.58.patch
 Patch1:                ffmpeg3.patch
 # Source1-md5: 5cf75d588cc53b93aceb809a6068ae37
 Patch0:                boost-1.58.patch
 Patch1:                ffmpeg3.patch
+Patch2:                cxx.patch
 URL:           http://www.vcmi.eu/
 BuildRequires: Qt5Network-devel
 BuildRequires: qt5-build
 URL:           http://www.vcmi.eu/
 BuildRequires: Qt5Network-devel
 BuildRequires: qt5-build
@@ -38,6 +39,7 @@ H3 engine rewrie (not another mod) with new possibilities.
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
 
 %build
 install -d build
This page took 0.133399 seconds and 4 git commands to generate.