]> git.pld-linux.org Git - packages/vcmi.git/commitdiff
- updated to 0.98 auto/th/vcmi-0.98-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Jun 2015 06:15:56 +0000 (08:15 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 24 Jun 2015 06:15:56 +0000 (08:15 +0200)
- fixed building qith boost 1.58

boost-1.58.patch [new file with mode: 0644]
vcmi.spec

diff --git a/boost-1.58.patch b/boost-1.58.patch
new file mode 100644 (file)
index 0000000..854e505
--- /dev/null
@@ -0,0 +1,50 @@
+From aa00fdbd0e99b2beec382c7677a64d962b748dcb Mon Sep 17 00:00:00 2001
+From: Rohit Nirmal <rohitnirmal9@gmail.com>
+Date: Wed, 6 May 2015 19:16:51 -0500
+Subject: [PATCH] Fix building with Boost 1.58.
+
+---
+ CCallback.cpp             | 2 +-
+ lib/CArtHandler.cpp       | 2 +-
+ lib/CGameInfoCallback.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CCallback.cpp b/CCallback.cpp
+index 8009bc7..da280db 100644
+--- a/CCallback.cpp
++++ b/CCallback.cpp
+@@ -80,7 +80,7 @@ void CCallback::recruitCreatures(const CGDwelling *obj, const CArmedInstance * d
\r
+ bool CCallback::dismissCreature(const CArmedInstance *obj, SlotID stackPos)\r
+ {\r
+-      if(((player>=0)  &&  obj->tempOwner != player) || (obj->stacksCount()<2  && obj->needsLastStack()))\r
++      if((player && obj->tempOwner != player) || (obj->stacksCount()<2  && obj->needsLastStack()))\r
+               return false;\r
\r
+       DisbandCreature pack(stackPos,obj->id);\r
+diff --git a/lib/CArtHandler.cpp b/lib/CArtHandler.cpp
+index 2d9dd01..0026a66 100644
+--- a/lib/CArtHandler.cpp
++++ b/lib/CArtHandler.cpp
+@@ -671,7 +671,7 @@ boost::optional<std::vector<CArtifact*>&> CArtHandler::listFromClass( CArtifact:
+       case CArtifact::ART_RELIC:\r
+               return relics;\r
+       default: //special artifacts should not be erased\r
+-              return nullptr;\r
++              return boost::optional<std::vector<CArtifact*>&>();\r
+       }\r
+ }\r
\r
+diff --git a/lib/CGameInfoCallback.cpp b/lib/CGameInfoCallback.cpp
+index 051bb9c..2a59b96 100644
+--- a/lib/CGameInfoCallback.cpp
++++ b/lib/CGameInfoCallback.cpp
+@@ -403,7 +403,7 @@ std::vector <const CGObjectInstance * > CGameInfoCallback::getVisitableObjs(int3
+       for(const CGObjectInstance * obj : t->visitableObjects)
+       {
+-              if(player < nullptr || obj->ID != Obj::EVENT) //hide events from players
++              if(player || obj->ID != Obj::EVENT) //hide events from players
+                       ret.push_back(obj);
+       }
index 1b939fd11a72dd00a5eb3c943cb74e05d795dc29..604641cd0551cfbdfe6387a4204b58a23e69a275 100644 (file)
--- a/vcmi.spec
+++ b/vcmi.spec
@@ -1,13 +1,14 @@
 Summary:       Heroes 3: WoG recreated
 Name:          vcmi
-Version:       0.97
-Release:       2
+Version:       0.98
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Games
-Source0:       https://github.com/vcmi/vcmi/archive/%{version}.tar.gz
-# Source0-md5: 11f2000244622706773ce37ca2366ebb
+Source0:       https://github.com/vcmi/vcmi/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 6a69e52a3380358220eba67332b097c6
 Source1:       http://download.vcmi.eu/core.zip
 # Source1-md5: 5cf75d588cc53b93aceb809a6068ae37
+Patch0:                boost-1.58.patch
 URL:           http://www.vcmi.eu/
 BuildRequires: Qt5Network-devel
 BuildRequires: qt5-build
@@ -34,6 +35,7 @@ H3 engine rewrie (not another mod) with new possibilities.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d build
This page took 0.104049 seconds and 4 git commands to generate.