]> git.pld-linux.org Git - packages/valgrind.git/commitdiff
- new spec valgrind-1_0_0-1
authorJacek Konieczny <jajcus@pld-linux.org>
Thu, 1 Aug 2002 10:25:15 +0000 (10:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    valgrind.spec -> 1.1

valgrind.spec [new file with mode: 0644]

diff --git a/valgrind.spec b/valgrind.spec
new file mode 100644 (file)
index 0000000..17c9fe8
--- /dev/null
@@ -0,0 +1,60 @@
+Summary:       An open-source memory debugger for x86-GNU/Linux
+Name:          valgrind
+Version:       1.0.0
+Release:       1
+License:       GPL
+ExclusiveArch: %{ix86}
+Group:         Networking/Utilities
+Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
+URL:           http://developer.kde.org/~sewardj/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# valgrind binaries should _never_ be stripped
+# anyone knows better solution?
+%define                debug   1
+
+%description
+Valgrind is a GPL'd tool to help you find memory-management problems
+in your programs. When a program is run under Valgrind's supervision,
+all reads and writes of memory are checked, and calls to
+malloc/new/free/delete are intercepted. As a result, Valgrind can
+detect problems such as:
+
+- Use of uninitialised memory
+- Reading/writing memory after it has been free'd
+- Reading/writing off the end of malloc'd blocks
+- Reading/writing inappropriate areas on the stack
+- Memory leaks -- where pointers to malloc'd blocks are lost forever
+- Passing of uninitialised and/or unaddressible memory to system calls
+- Mismatched use of malloc/new/new [] vs free/delete/delete []
+- Some misuses of the POSIX pthreads API
+
+%prep
+%setup -q
+
+%build
+rm -f missing
+aclocal
+%{__autoconf}
+%{__automake}
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
+%doc README README_MISSING_SYSCALL_OR_IOCTL TODO
+%doc docs/*.html
+%attr(755,root,root) %{_bindir}/*
+%{_includedir}/*
+%{_libdir}/%{name}
This page took 0.036828 seconds and 4 git commands to generate.