]> git.pld-linux.org Git - packages/valgrind.git/commitdiff
- up to final 3.6.0 (includes support for build-id) auto/th/valgrind-3_6_0-1
authorJan Palus <jan.palus@gmail.com>
Thu, 21 Oct 2010 12:13:26 +0000 (12:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    valgrind-debuginfo.patch -> 1.2
    valgrind.spec -> 1.77

valgrind-debuginfo.patch
valgrind.spec

index 64bf4db6650a7e9fd537a39e75f80f56a9b644cf..19b1b248782efe02dd7473706d383302647d9a7d 100644 (file)
@@ -1,14 +1,13 @@
-diff -ruN valgrind-3.2.3./coregrind/m_debuginfo/readelf.c valgrind-3.2.3/coregrind/m_debuginfo/readelf.c
---- valgrind-3.2.3./coregrind/m_debuginfo/readelf.c    2007-01-13 00:19:50.000000000 +0100
-+++ valgrind-3.2.3/coregrind/m_debuginfo/readelf.c     2007-04-21 14:34:39.564762671 +0200
-@@ -790,7 +790,9 @@
-       VG_(sprintf)(debugpath, "%s/.debug/%s", objdir, debugname);
-       if ((addr = open_debug_file(debugpath, crc, size)) == 0) {
-          VG_(sprintf)(debugpath, "/usr/lib/debug%s/%s", objdir, debugname);
--         addr = open_debug_file(debugpath, crc, size);
-+         if ((addr = open_debug_file(debugpath, crc, size)) == 0) {
-+            addr = open_debug_file(debugname, crc, size);
-+       }
+--- coregrind/m_debuginfo/readelf.c.orig       2010-10-18 12:58:07.000000000 +0200
++++ coregrind/m_debuginfo/readelf.c    2010-10-18 13:00:53.366691751 +0200
+@@ -1080,7 +1080,9 @@
+          VG_(sprintf)(debugpath, "%s/.debug/%s", objdir, debugname);
+          if ((addr = open_debug_file(debugpath, NULL, crc, size)) == 0) {
+             VG_(sprintf)(debugpath, "/usr/lib/debug%s/%s", objdir, debugname);
+-            addr = open_debug_file(debugpath, NULL, crc, size);
++            if ((addr = open_debug_file(debugpath, NULL, crc, size)) == 0) {
++              addr = open_debug_file(debugname, NULL, crc, size);
++          }
+          }
        }
-    }
  
index 0ad5eb99d3f1ac3374349d1dd5727915d9e2376b..18b6ad607e37bf672b1183be535665fc0d667dbd 100644 (file)
@@ -1,15 +1,12 @@
-#
-%define                _rel    test2
-#
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
 Version:       3.6.0
-Release:       0.%{_rel}.1
+Release:       1
 License:       GPL
 Group:         Development/Tools
-Source0:       http://valgrind.org/downloads/%{name}-%{version}-%{_rel}.tar.bz2
-# Source0-md5: 49b94fcba8d653da21601f0ad87c014e
+Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
+# Source0-md5: b289c5f4ab8e39741602445f1dd09b34
 Patch0:                %{name}-debuginfo.patch
 URL:           http://valgrind.org/
 BuildRequires: autoconf
@@ -43,8 +40,8 @@ również dokładne profilowanie, dzięki któremu programy zaczną szybciej
 pracować.
 
 %prep
-%setup -q -n %{name}-%{version}-%{_rel}
-%patch0 -p1
+%setup -q
+%patch0
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
This page took 0.055173 seconds and 4 git commands to generate.