]> git.pld-linux.org Git - packages/valgrind.git/commitdiff
- up to 3.7.0 auto/th/valgrind-3_7_0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 10 Dec 2011 15:11:07 +0000 (15:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    valgrind-debuginfo.patch -> 1.3
    valgrind-glibc214.patch -> 1.2
    valgrind-opge.patch -> 1.2
    valgrind.spec -> 1.83

valgrind-debuginfo.patch
valgrind-glibc214.patch [deleted file]
valgrind-opge.patch [deleted file]
valgrind.spec

index 19b1b248782efe02dd7473706d383302647d9a7d..bab4da9191aa7824935c454288214187e6369e0b 100644 (file)
@@ -1,13 +1,13 @@
---- coregrind/m_debuginfo/readelf.c.orig       2010-10-18 12:58:07.000000000 +0200
-+++ coregrind/m_debuginfo/readelf.c    2010-10-18 13:00:53.366691751 +0200
-@@ -1080,7 +1080,9 @@
+--- coregrind/m_debuginfo/readelf.c~   2011-10-26 23:24:44.000000000 +0200
++++ coregrind/m_debuginfo/readelf.c    2011-12-10 16:02:00.557983343 +0100
+@@ -1198,7 +1198,9 @@
           VG_(sprintf)(debugpath, "%s/.debug/%s", objdir, debugname);
           VG_(sprintf)(debugpath, "%s/.debug/%s", objdir, debugname);
-          if ((addr = open_debug_file(debugpath, NULL, crc, size)) == 0) {
+          if ((addr = open_debug_file(debugpath, NULL, crc, &size)) == 0) {
              VG_(sprintf)(debugpath, "/usr/lib/debug%s/%s", objdir, debugname);
              VG_(sprintf)(debugpath, "/usr/lib/debug%s/%s", objdir, debugname);
--            addr = open_debug_file(debugpath, NULL, crc, size);
-+            if ((addr = open_debug_file(debugpath, NULL, crc, size)) == 0) {
-+              addr = open_debug_file(debugname, NULL, crc, size);
-+          }
+-            addr = open_debug_file(debugpath, NULL, crc, &size);
++            if ((addr = open_debug_file(debugpath, NULL, crc, &size)) == 0) {
++                addr = open_debug_file(debugname, NULL, crc, size);
++            }
           }
        }
  
           }
        }
  
diff --git a/valgrind-glibc214.patch b/valgrind-glibc214.patch
deleted file mode 100644 (file)
index 2246f7c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- valgrind-3.6.1/configure.in.orig   2011-02-15 18:31:17.000000000 +0100
-+++ valgrind-3.6.1/configure.in        2011-08-05 21:04:39.269462335 +0200
-@@ -756,6 +756,13 @@
-       DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-       DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-       ;;
-+     2.14)
-+      AC_MSG_RESULT(2.14 family)
-+      AC_DEFINE([GLIBC_2_14], 1, [Define to 1 if you're using glibc 2.14.x])
-+      DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
-+      DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-+      DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-+      ;;
-      aix5)
-       AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
-       AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
-@@ -769,7 +776,7 @@
-      *)
-       AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
--      AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.13])
-+      AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.14])
-       AC_MSG_ERROR([or AIX 5.1 or 5.2 or 5.3 GLIBC_VERSION])
-       AC_MSG_ERROR([or Darwin libc])
-       ;;
diff --git a/valgrind-opge.patch b/valgrind-opge.patch
deleted file mode 100644 (file)
index 331025a..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
---- valgrind-3.6.1/coregrind/m_debuginfo/debuginfo.c.orig   2010-10-20 22:19:43.000000000 +0200
-+++ valgrind-3.6.1/coregrind/m_debuginfo/debuginfo.c   2011-08-03 01:18:33.724000500 +0200
-@@ -1958,6 +1958,14 @@
-             case Cop_Sub: return wL - wR;
-             case Cop_And: return wL & wR;
-             case Cop_Mul: return wL * wR;
-+            case Cop_Shl: return wL << wR;
-+            case Cop_Shr: return wL >> wR;
-+            case Cop_Eq: return wL == wR ? 1 : 0;
-+            case Cop_Ge: return (Word) wL >= (Word) wR ? 1 : 0;
-+            case Cop_Gt: return (Word) wL > (Word) wR ? 1 : 0;
-+            case Cop_Le: return (Word) wL <= (Word) wR ? 1 : 0;
-+            case Cop_Lt: return (Word) wL < (Word) wR ? 1 : 0;
-+            case Cop_Ne: return wL != wR ? 1 : 0;
-             default: goto unhandled;
-          }
-          /*NOTREACHED*/
---- valgrind-3.6.1/coregrind/m_debuginfo/priv_storage.h.orig   2010-10-20 22:19:43.000000000 +0200
-+++ valgrind-3.6.1/coregrind/m_debuginfo/priv_storage.h        2011-08-03 01:09:29.536000499 +0200
-@@ -218,7 +218,15 @@
-       Cop_Add=0x321,
-       Cop_Sub,
-       Cop_And,
--      Cop_Mul
-+      Cop_Mul,
-+      Cop_Shl,
-+      Cop_Shr,
-+      Cop_Eq,
-+      Cop_Ge,
-+      Cop_Gt,
-+      Cop_Le,
-+      Cop_Lt,
-+      Cop_Ne
-    }
-    CfiOp;
---- valgrind-3.6.1/coregrind/m_debuginfo/readdwarf.c.orig      2010-10-20 22:19:43.000000000 +0200
-+++ valgrind-3.6.1/coregrind/m_debuginfo/readdwarf.c   2011-08-03 01:09:29.533000512 +0200
-@@ -2831,6 +2831,22 @@
-             op = Cop_And; opname = "and"; goto binop;
-          case DW_OP_mul:
-             op = Cop_Mul; opname = "mul"; goto binop;
-+         case DW_OP_shl:
-+            op = Cop_Shl; opname = "shl"; goto binop;
-+         case DW_OP_shr:
-+            op = Cop_Shr; opname = "shr"; goto binop;
-+         case DW_OP_eq:
-+            op = Cop_Eq; opname = "eq"; goto binop;
-+         case DW_OP_ge:
-+            op = Cop_Ge; opname = "ge"; goto binop;
-+         case DW_OP_gt:
-+            op = Cop_Gt; opname = "gt"; goto binop;
-+         case DW_OP_le:
-+            op = Cop_Le; opname = "le"; goto binop;
-+         case DW_OP_lt:
-+            op = Cop_Lt; opname = "lt"; goto binop;
-+         case DW_OP_ne:
-+            op = Cop_Ne; opname = "ne"; goto binop;
-          binop:
-             POP( ix );
-             POP( ix2 );
---- valgrind-3.6.1/coregrind/m_debuginfo/storage.c.orig        2010-10-20 22:19:43.000000000 +0200
-+++ valgrind-3.6.1/coregrind/m_debuginfo/storage.c     2011-08-03 01:09:29.535000503 +0200
-@@ -595,6 +595,14 @@
-       case Cop_Sub: VG_(printf)("-"); break;
-       case Cop_And: VG_(printf)("&"); break;
-       case Cop_Mul: VG_(printf)("*"); break;
-+      case Cop_Shl: VG_(printf)("<<"); break;
-+      case Cop_Shr: VG_(printf)(">>"); break;
-+      case Cop_Eq: VG_(printf)("=="); break;
-+      case Cop_Ge: VG_(printf)(">="); break;
-+      case Cop_Gt: VG_(printf)(">"); break;
-+      case Cop_Le: VG_(printf)("<="); break;
-+      case Cop_Lt: VG_(printf)("<"); break;
-+      case Cop_Ne: VG_(printf)("!="); break;
-       default:      vg_assert(0);
-    }
- }
index 5b8ea808c4c94f2be7ba693da31526d73ea6f5db..0530e9fce80b6e2ea05f1a4c39d891c65fe689a2 100644 (file)
@@ -1,16 +1,16 @@
+# TODO:
+# - fix CC detection in configure, so CC=gcc won't be needed
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       3.6.1
-Release:       2
+Version:       3.7.0
+Release:       1
 License:       GPL
 Group:         Development/Tools
 Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
 License:       GPL
 Group:         Development/Tools
 Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 2c3aa122498baecc9d69194057ca88f5
+# Source0-md5: a855fda56edf05614f099dca316d1775
 Patch0:                %{name}-debuginfo.patch
 Patch1:                %{name}-native-cpuid.patch
 Patch0:                %{name}-debuginfo.patch
 Patch1:                %{name}-native-cpuid.patch
-Patch2:                %{name}-opge.patch
-Patch3:                %{name}-glibc214.patch
 URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
 URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -46,8 +46,6 @@ pracować.
 %setup -q
 %patch0
 %patch1 -p1
 %setup -q
 %patch0
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
@@ -59,6 +57,7 @@ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configur
 
 ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
 
 ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
+       CC=gcc \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
@@ -91,5 +90,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/*.a
 %attr(755,root,root) %{_libdir}/%{name}/*.so
 %{_libdir}/%{name}/*.supp
 %{_libdir}/%{name}/*.a
 %attr(755,root,root) %{_libdir}/%{name}/*.so
 %{_libdir}/%{name}/*.supp
+%{_libdir}/%{name}/*.xml
 %{_mandir}/man1/*.1*
 %{_pkgconfigdir}/*.pc
 %{_mandir}/man1/*.1*
 %{_pkgconfigdir}/*.pc
This page took 0.048439 seconds and 4 git commands to generate.