]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- up to 3.14.0; enabled lto (wchich usually makes gdb unusable on binary but binary...
[packages/valgrind.git] / valgrind.spec
index f4468a202783bd0c4b22264874a49e1df1d06bfd..e94237df53c94cdb277674026e2b6e152c01c726 100644 (file)
@@ -1,31 +1,39 @@
 # TODO:
 # - fix CC detection in configure, so CC=gcc won't be needed
+#
+# Conditional build:
+%bcond_with    mpi     # MPI wrapper module
+#
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamiÄ™ci
 Name:          valgrind
-Version:       3.10.1
+Version:       3.14.0
 Release:       1
-License:       GPL
+License:       GPL v2+
 Group:         Development/Tools
-Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 60ddae962bc79e7c95cfc4667245707f
+Source0:       https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
+# Source0-md5: 74175426afa280184b62591b58c671b3
 Patch0:                %{name}-native-cpuid.patch
 Patch1:                %{name}-ld_linux_strlen.patch
 URL:           http://valgrind.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.10
 BuildRequires: gcc >= 5:3.0
+%ifarch x32
+BuildRequires: gcc-multilib-64 >= 5:3.0
+%endif
 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
 BuildRequires: glibc-devel >= 6:2.2
-BuildRequires: glibc-devel <= 6:2.19
 BuildRequires: libgomp-devel
 BuildRequires: libstdc++-devel
+%{?with_mpi:BuildRequires:     mpi-devel}
 Obsoletes:     valgrind-callgrind
 Obsoletes:     valgrind-calltree
-ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
+ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x x32
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautostrip    .*/vgpreload.*\\.so
+%define                filterout_c     -fstack-protector-strong
 # ld portion broken
 %undefine      with_ccache
 
@@ -54,8 +62,8 @@ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configur
 
 %build
 %{__aclocal}
-%{__autoheader}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 
 ac_cv_path_GDB=/usr/bin/gdb \
@@ -64,7 +72,8 @@ ac_cv_path_GDB=/usr/bin/gdb \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
-%endif
+%endif \
+       --enable-lto=yes \
        LDFLAGS="" # no strip!
 
 %{__make}
@@ -99,6 +108,10 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-linux
 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%if %{with mpi}
+# TODO: subpackage?
+%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
+%endif
 %{_libdir}/%{name}/*.xml
 %{_libdir}/%{name}/default.supp
 %{_libdir}/%{name}/lib*-linux.a
This page took 0.071589 seconds and 4 git commands to generate.