]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- up to 3.14.0; enabled lto (wchich usually makes gdb unusable on binary but binary...
[packages/valgrind.git] / valgrind.spec
index 7911f50ff475c5eca6f078bc8643ee467efa01b1..e94237df53c94cdb277674026e2b6e152c01c726 100644 (file)
@@ -1,34 +1,39 @@
 # TODO:
 # - fix CC detection in configure, so CC=gcc won't be needed
+#
+# Conditional build:
+%bcond_with    mpi     # MPI wrapper module
+#
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       3.7.0
-Release:       3
-License:       GPL
+Version:       3.14.0
+Release:       1
+License:       GPL v2+
 Group:         Development/Tools
-Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: a855fda56edf05614f099dca316d1775
-Patch0:                %{name}-debuginfo.patch
-Patch1:                %{name}-native-cpuid.patch
-Patch2:                %{name}-automake-1.11.2.patch
-Patch3:                %{name}-ld_linux_strlen.patch
+Source0:       https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
+# Source0-md5: 74175426afa280184b62591b58c671b3
+Patch0:                %{name}-native-cpuid.patch
+Patch1:                %{name}-ld_linux_strlen.patch
 URL:           http://valgrind.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.10
 BuildRequires: gcc >= 5:3.0
-# Needs libc.a
+%ifarch x32
+BuildRequires: gcc-multilib-64 >= 5:3.0
+%endif
+# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
 BuildRequires: glibc-devel >= 6:2.2
-BuildRequires: glibc-devel < 6:2.15
-BuildRequires: glibc-static
 BuildRequires: libgomp-devel
 BuildRequires: libstdc++-devel
+%{?with_mpi:BuildRequires:     mpi-devel}
 Obsoletes:     valgrind-callgrind
 Obsoletes:     valgrind-calltree
-ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
+ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x x32
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautostrip    .*/vgpreload.*\\.so
+%define                filterout_c     -fstack-protector-strong
 # ld portion broken
 %undefine      with_ccache
 
@@ -50,17 +55,15 @@ pracować.
 
 %prep
 %setup -q
-%patch0
+%patch0 -p1
 %patch1 -p1
-%patch2 -p0
-%patch3 -p1
 
-sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
+sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
 
 %build
 %{__aclocal}
-%{__autoheader}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 
 ac_cv_path_GDB=/usr/bin/gdb \
@@ -69,7 +72,8 @@ ac_cv_path_GDB=/usr/bin/gdb \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
-%endif
+%endif \
+       --enable-lto=yes \
        LDFLAGS="" # no strip!
 
 %{__make}
@@ -81,8 +85,8 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
-mv docs/index.pdf docs/valgrind_manual.pdf
-mv docs/index.ps docs/valgrind_manual.ps
+cp -p docs/index.pdf docs/valgrind_manual.pdf
+cp -p docs/index.ps docs/valgrind_manual.ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -98,11 +102,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/cg_merge
 %attr(755,root,root) %{_bindir}/ms_print
 %attr(755,root,root) %{_bindir}/valgrind
+%attr(755,root,root) %{_bindir}/valgrind-di-server
 %attr(755,root,root) %{_bindir}/valgrind-listener
 %attr(755,root,root) %{_bindir}/vgdb
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-linux
 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%if %{with mpi}
+# TODO: subpackage?
+%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
+%endif
 %{_libdir}/%{name}/*.xml
 %{_libdir}/%{name}/default.supp
 %{_libdir}/%{name}/lib*-linux.a
@@ -110,6 +119,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/callgrind_annotate.1*
 %{_mandir}/man1/callgrind_control.1*
 %{_mandir}/man1/cg_annotate.1*
+%{_mandir}/man1/cg_diff.1*
+%{_mandir}/man1/cg_merge.1*
 %{_mandir}/man1/ms_print.1*
 %{_mandir}/man1/valgrind.1*
+%{_mandir}/man1/valgrind-listener.1*
+%{_mandir}/man1/vgdb.1*
 %{_pkgconfigdir}/valgrind.pc
This page took 0.038871 seconds and 4 git commands to generate.