]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- up to 3.14.0; enabled lto (wchich usually makes gdb unusable on binary but binary...
[packages/valgrind.git] / valgrind.spec
index 4457af7e5dbfa747746bf0f8ec85de6067e0f669..e94237df53c94cdb277674026e2b6e152c01c726 100644 (file)
@@ -1,55 +1,81 @@
-%define                _snap   20040612
-Summary:       An open-source memory debugger for x86-GNU/Linux
-Summary(pl):   Otwarty odpluskwiacz pamiêci dla Linuksa x86
+# TODO:
+# - fix CC detection in configure, so CC=gcc won't be needed
+#
+# Conditional build:
+%bcond_with    mpi     # MPI wrapper module
+#
+Summary:       An open-source memory debugger
+Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       2.1.2
-Release:       0.%{_snap}.1
-License:       GPL
+Version:       3.14.0
+Release:       1
+License:       GPL v2+
 Group:         Development/Tools
-#Source0:      http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
-Source0:       %{name}-%{_snap}.tar.bz2
-# Source0-md5: 33551ee2808fa5f63a30f2dee952a3dc
-URL:           http://valgrind.kde.org/
-# Needs libc.a
-BuildRequires: glibc-static  
-BuildRequires: autoconf
-BuildRequires: automake
-ExclusiveArch: %{ix86}
+Source0:       https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
+# Source0-md5: 74175426afa280184b62591b58c671b3
+Patch0:                %{name}-native-cpuid.patch
+Patch1:                %{name}-ld_linux_strlen.patch
+URL:           http://valgrind.org/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.10
+BuildRequires: gcc >= 5:3.0
+%ifarch x32
+BuildRequires: gcc-multilib-64 >= 5:3.0
+%endif
+# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
+BuildRequires: glibc-devel >= 6:2.2
+BuildRequires: libgomp-devel
+BuildRequires: libstdc++-devel
+%{?with_mpi:BuildRequires:     mpi-devel}
+Obsoletes:     valgrind-callgrind
+Obsoletes:     valgrind-calltree
+ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x x32
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# Valgrind binaries should _never_ be stripped
-%define                no_install_post_strip   1
-
-# Same name as libpthread
-%define                _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
+%define                _noautostrip    .*/vgpreload.*\\.so
+%define                filterout_c     -fstack-protector-strong
+# ld portion broken
+%undefine      with_ccache
 
 %description
-Valgrind is a GPL'd system for debugging and profiling x86-Linux
-programs. With the tools that come with Valgrind, you can
-automatically detect many memory management and threading bugs,
-avoiding hours of frustrating bug-hunting, making your programs more
-stable. You can also perform detailed profiling to help speed up your
-programs.
+Valgrind is a GPL'd system for debugging and profiling Linux programs.
+With the tools that come with Valgrind, you can automatically detect
+many memory management and threading bugs, avoiding hours of
+frustrating bug-hunting, making your programs more stable. You can
+also perform detailed profiling to help speed up your programs.
 
-%description -l pl
-Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
-programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
-dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
-b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
-czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
-siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
-profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
+%description -l pl.UTF-8
+Valgrind jest systemem służącym do odpluskwiania i profilowania
+programów na Linuksie. Używając dostarczanych z nim narzędzi można
+automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
+i wątkowaniem, dzięki czemu unika się frustrującego polowania na
+błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
+również dokładne profilowanie, dzięki któremu programy zaczną szybciej
+pracować.
 
 %prep
-%setup -q -n %{name}-%{_snap}
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
 
 %build
 %{__aclocal}
-%{__autoheader}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
+
+ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
+       CC=gcc \
+       --enable-tls \
+%if %{_lib} != "lib"
+       --enable-only64bit \
+%endif \
+       --enable-lto=yes \
        LDFLAGS="" # no strip!
+
 %{__make}
 
 %install
@@ -58,21 +84,45 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
+cp -p docs/index.pdf docs/valgrind_manual.pdf
+cp -p docs/index.ps docs/valgrind_manual.ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL TODO
-%doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
+%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
+%attr(755,root,root) %{_bindir}/callgrind_annotate
+%attr(755,root,root) %{_bindir}/callgrind_control
+%attr(755,root,root) %{_bindir}/cg_annotate
+%attr(755,root,root) %{_bindir}/cg_diff
+%attr(755,root,root) %{_bindir}/cg_merge
+%attr(755,root,root) %{_bindir}/ms_print
+%attr(755,root,root) %{_bindir}/valgrind
+%attr(755,root,root) %{_bindir}/valgrind-di-server
+%attr(755,root,root) %{_bindir}/valgrind-listener
+%attr(755,root,root) %{_bindir}/vgdb
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*.so
-%{_libdir}/%{name}/*.so.*
-%attr(755,root,root) %{_libdir}/%{name}/hp2ps
-%attr(755,root,root) %{_libdir}/%{name}/stage2
-%{_libdir}/%{name}/*.supp
-%{_includedir}/*
-%{_pkgconfigdir}/*.pc
+%attr(755,root,root) %{_libdir}/%{name}/*-linux
+%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%if %{with mpi}
+# TODO: subpackage?
+%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
+%endif
+%{_libdir}/%{name}/*.xml
+%{_libdir}/%{name}/default.supp
+%{_libdir}/%{name}/lib*-linux.a
+%{_includedir}/valgrind
+%{_mandir}/man1/callgrind_annotate.1*
+%{_mandir}/man1/callgrind_control.1*
+%{_mandir}/man1/cg_annotate.1*
+%{_mandir}/man1/cg_diff.1*
+%{_mandir}/man1/cg_merge.1*
+%{_mandir}/man1/ms_print.1*
+%{_mandir}/man1/valgrind.1*
+%{_mandir}/man1/valgrind-listener.1*
+%{_mandir}/man1/vgdb.1*
+%{_pkgconfigdir}/valgrind.pc
This page took 0.042254 seconds and 4 git commands to generate.