]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- no %files from $RPM_BUILD_ROOT (confuses check-files)
[packages/valgrind.git] / valgrind.spec
index 17c9fe8defeb4a52aac85e69dbb7b135a8b0c0d0..d62800146ca7dd63930068d28a8b7aa8593016d5 100644 (file)
@@ -1,60 +1,81 @@
-Summary:       An open-source memory debugger for x86-GNU/Linux
+# Conditional build:
+%bcond_with    multilib        # enable multilib on amd64
+#
+Summary:       An open-source memory debugger
+Summary(pl):   Otwarty odpluskwiacz pamiêci
 Name:          valgrind
-Version:       1.0.0
-Release:       1
+Version:       3.1.1
+Release:       2
 License:       GPL
-ExclusiveArch: %{ix86}
-Group:         Networking/Utilities
-Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
-URL:           http://developer.kde.org/~sewardj/
+Group:         Development/Tools
+Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
+# Source0-md5: 3bbfafedb59c19bf75977381ce2eb6d7
+Patch0:                %{name}-amd64.patch
+URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
+# Needs libc.a
+BuildRequires: glibc-static
+Conflicts:     valgrind-calltree
+ExclusiveArch: %{ix86} ppc %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# valgrind binaries should _never_ be stripped
-# anyone knows better solution?
-%define                debug   1
+%define                _noautostrip    .*/vgpreload.*\\.so
+# ld portion broken
+%undefine      with_ccache
 
 %description
-Valgrind is a GPL'd tool to help you find memory-management problems
-in your programs. When a program is run under Valgrind's supervision,
-all reads and writes of memory are checked, and calls to
-malloc/new/free/delete are intercepted. As a result, Valgrind can
-detect problems such as:
-
-- Use of uninitialised memory
-- Reading/writing memory after it has been free'd
-- Reading/writing off the end of malloc'd blocks
-- Reading/writing inappropriate areas on the stack
-- Memory leaks -- where pointers to malloc'd blocks are lost forever
-- Passing of uninitialised and/or unaddressible memory to system calls
-- Mismatched use of malloc/new/new [] vs free/delete/delete []
-- Some misuses of the POSIX pthreads API
+Valgrind is a GPL'd system for debugging and profiling Linux programs.
+With the tools that come with Valgrind, you can automatically detect
+many memory management and threading bugs, avoiding hours of frustrating
+bug-hunting, making your programs more stable. You can also perform
+detailed profiling to help speed up your programs.
+
+%description -l pl
+Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
+programów na Linuksie. U¿ywaj±c dostarczanych z nim narzêdzi mo¿na
+automatycznie wykrywaæ wiele b³êdów zwi±zanych z zarz±dzaniem pamiêci± i
+w±tkowaniem, dziêki czemu unika siê frustruj±cego polowania na b³êdy, a
+tak¿e czyni siê programy bardziej stabilnymi. Mo¿liwe jest równie¿
+dok³adne profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
 
 %prep
 %setup -q
+%{!?with_multilib:%patch0 -p1}
 
 %build
-rm -f missing
-aclocal
+%{__aclocal}
+%{__autoheader}
 %{__autoconf}
 %{__automake}
-%configure
+%configure \
+       LDFLAGS="" # no strip!
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
+rm -rf _docs
+mv $RPM_BUILD_ROOT%{_docdir}/valgrind _docs
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
-%doc README README_MISSING_SYSCALL_OR_IOCTL TODO
-%doc docs/*.html
+%doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL
+%doc _docs/html
+%doc _docs/valgrind_manual.pdf
 %attr(755,root,root) %{_bindir}/*
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/*-linux
+%attr(755,root,root) %{_libdir}/%{name}/*-linux/*
+%attr(755,root,root) %{_libdir}/%{name}/hp2ps
+%{_libdir}/%{name}/*.supp
 %{_includedir}/*
-%{_libdir}/%{name}
+%{_pkgconfigdir}/*.pc
+%{_mandir}/man1/*.1*
This page took 0.059063 seconds and 4 git commands to generate.