]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- md5
[packages/valgrind.git] / valgrind.spec
index 17c9fe8defeb4a52aac85e69dbb7b135a8b0c0d0..8ce1a5f2f85885e1f3ef9462f75ce410f3159171 100644 (file)
@@ -1,60 +1,78 @@
+%define                snap    20040229
 Summary:       An open-source memory debugger for x86-GNU/Linux
+Summary(pl):   Otwarty odpluskwiacz pamiêci dla Linuksa x86
 Name:          valgrind
-Version:       1.0.0
-Release:       1
+Version:       2.1.0
+Release:       1.%{snap}.1
 License:       GPL
-ExclusiveArch: %{ix86}
-Group:         Networking/Utilities
-Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
-URL:           http://developer.kde.org/~sewardj/
+Group:         Development/Tools
+#Source0:      http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
+Source0:       %{name}-%{snap}.tar.bz2
+# Source0-md5: 1a12c4a131531023f4c0bfc62f6ff744
+Patch0:                %{name}-gcc34.patch
+URL:           http://valgrind.kde.org/
 BuildRequires: autoconf
 BuildRequires: automake
+ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# valgrind binaries should _never_ be stripped
-# anyone knows better solution?
-%define                debug   1
+# Valgrind binaries should _never_ be stripped
+%define                no_install_post_strip   1
+
+# Same name as libpthread
+%define                _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
 
 %description
-Valgrind is a GPL'd tool to help you find memory-management problems
-in your programs. When a program is run under Valgrind's supervision,
-all reads and writes of memory are checked, and calls to
-malloc/new/free/delete are intercepted. As a result, Valgrind can
-detect problems such as:
-
-- Use of uninitialised memory
-- Reading/writing memory after it has been free'd
-- Reading/writing off the end of malloc'd blocks
-- Reading/writing inappropriate areas on the stack
-- Memory leaks -- where pointers to malloc'd blocks are lost forever
-- Passing of uninitialised and/or unaddressible memory to system calls
-- Mismatched use of malloc/new/new [] vs free/delete/delete []
-- Some misuses of the POSIX pthreads API
+Valgrind is a GPL'd system for debugging and profiling x86-Linux
+programs. With the tools that come with Valgrind, you can
+automatically detect many memory management and threading bugs,
+avoiding hours of frustrating bug-hunting, making your programs more
+stable. You can also perform detailed profiling to help speed up your
+programs.
+
+%description -l pl
+Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
+programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
+dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
+b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
+czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
+siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
+profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
 
 %prep
-%setup -q
+%setup -q -n %{name}
+%patch0 -p1
 
 %build
-rm -f missing
-aclocal
+%{__aclocal}
+%{__autoheader}
 %{__autoconf}
 %{__automake}
-%configure
+%configure \
+       LDFLAGS="" # no strip!
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
-%doc README README_MISSING_SYSCALL_OR_IOCTL TODO
-%doc docs/*.html
+%doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL TODO
+%doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
 %attr(755,root,root) %{_bindir}/*
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/*.so
+%{_libdir}/%{name}/*.so.*
+%attr(755,root,root) %{_libdir}/%{name}/hp2ps
+%attr(755,root,root) %{_libdir}/%{name}/stage2
+%{_libdir}/%{name}/*.supp
 %{_includedir}/*
-%{_libdir}/%{name}
+%{_pkgconfigdir}/*.pc
This page took 0.036156 seconds and 4 git commands to generate.