]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- rel 2; support ld -z separate-code generated binaries
[packages/valgrind.git] / valgrind.spec
index 535315a47bc60b89d1c99a4e2453e3bedd0c6db8..81e5d03d0c355f805c5b075f57fa105f72a3ad16 100644 (file)
@@ -1,27 +1,40 @@
+# TODO:
+# - fix CC detection in configure, so CC=gcc won't be needed
+#
+# Conditional build:
+%bcond_with    mpi     # MPI wrapper module
+#
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       3.6.0
-Release:       3
-License:       GPL
+Version:       3.13.0
+Release:       2
+License:       GPL v2+
 Group:         Development/Tools
-Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: b289c5f4ab8e39741602445f1dd09b34
-Patch0:                %{name}-debuginfo.patch
-Patch1:                %{name}-pr262995.patch
-Patch2:                %{name}-native-cpuid.patch
+Source0:       ftp://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
+# Source0-md5: 817dd08f1e8a66336b9ff206400a5369
+Patch0:                %{name}-native-cpuid.patch
+Patch1:                %{name}-ld_linux_strlen.patch
+Patch2:                valgrind-3.13.0-ld-separate-code.patch
 URL:           http://valgrind.org/
-BuildRequires: autoconf
-BuildRequires: automake
-# Needs libc.a
-BuildRequires: glibc-static
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.10
+BuildRequires: gcc >= 5:3.0
+%ifarch x32
+BuildRequires: gcc-multilib-64 >= 5:3.0
+%endif
+# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
+BuildRequires: glibc-devel >= 6:2.2
 BuildRequires: libgomp-devel
+BuildRequires: libstdc++-devel
+%{?with_mpi:BuildRequires:     mpi-devel}
 Obsoletes:     valgrind-callgrind
 Obsoletes:     valgrind-calltree
-ExclusiveArch: %{ix86} %{x8664} ppc ppc64
+ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x x32
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautostrip    .*/vgpreload.*\\.so
+%define                filterout_c     -fstack-protector-strong
 # ld portion broken
 %undefine      with_ccache
 
@@ -43,20 +56,21 @@ pracować.
 
 %prep
 %setup -q
-%patch0
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 
-sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
+sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
 
 %build
 %{__aclocal}
-%{__autoheader}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 
 ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
+       CC=gcc \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
@@ -71,9 +85,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc
-mv docs/index.pdf docs/valgrind_manual.pdf
-mv docs/index.ps docs/valgrind_manual.ps
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
+cp -p docs/index.pdf docs/valgrind_manual.pdf
+cp -p docs/index.ps docs/valgrind_manual.ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -82,12 +96,34 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
-%attr(755,root,root) %{_bindir}/*
-%{_includedir}/*
+%attr(755,root,root) %{_bindir}/callgrind_annotate
+%attr(755,root,root) %{_bindir}/callgrind_control
+%attr(755,root,root) %{_bindir}/cg_annotate
+%attr(755,root,root) %{_bindir}/cg_diff
+%attr(755,root,root) %{_bindir}/cg_merge
+%attr(755,root,root) %{_bindir}/ms_print
+%attr(755,root,root) %{_bindir}/valgrind
+%attr(755,root,root) %{_bindir}/valgrind-di-server
+%attr(755,root,root) %{_bindir}/valgrind-listener
+%attr(755,root,root) %{_bindir}/vgdb
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-linux
-%{_libdir}/%{name}/*.a
-%attr(755,root,root) %{_libdir}/%{name}/*.so
-%{_libdir}/%{name}/*.supp
-%{_mandir}/man1/*.1*
-%{_pkgconfigdir}/*.pc
+%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%if %{with mpi}
+# TODO: subpackage?
+%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
+%endif
+%{_libdir}/%{name}/*.xml
+%{_libdir}/%{name}/default.supp
+%{_libdir}/%{name}/lib*-linux.a
+%{_includedir}/valgrind
+%{_mandir}/man1/callgrind_annotate.1*
+%{_mandir}/man1/callgrind_control.1*
+%{_mandir}/man1/cg_annotate.1*
+%{_mandir}/man1/cg_diff.1*
+%{_mandir}/man1/cg_merge.1*
+%{_mandir}/man1/ms_print.1*
+%{_mandir}/man1/valgrind.1*
+%{_mandir}/man1/valgrind-listener.1*
+%{_mandir}/man1/vgdb.1*
+%{_pkgconfigdir}/valgrind.pc
This page took 0.076375 seconds and 4 git commands to generate.