]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- Valgrind insisted on redirecting the 'strlen' symbol in /lib/ld-linux.so.2,
[packages/valgrind.git] / valgrind.spec
index 230c829e7dbb8537455d79f93df25e4d022fd49d..75e9bb3a311e9de055ca03d0f2f6b852cde468af 100644 (file)
@@ -1,23 +1,31 @@
+# TODO:
+# - fix CC detection in configure, so CC=gcc won't be needed
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       3.5.0
+Version:       3.7.0
 Release:       2
 License:       GPL
 Group:         Development/Tools
 Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: f03522a4687cf76c676c9494fcc0a517
+# Source0-md5: a855fda56edf05614f099dca316d1775
 Patch0:                %{name}-debuginfo.patch
-Patch1:                %{name}-glibc211.patch
+Patch1:                %{name}-native-cpuid.patch
+Patch2:                %{name}-automake-1.11.2.patch
+Patch3:                %{name}-ld_linux_strlen.patch
 URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: gcc >= 5:3.0
 # Needs libc.a
+BuildRequires: glibc-devel >= 6:2.2
+BuildRequires: glibc-devel < 6:2.15
 BuildRequires: glibc-static
 BuildRequires: libgomp-devel
+BuildRequires: libstdc++-devel
 Obsoletes:     valgrind-callgrind
 Obsoletes:     valgrind-calltree
-ExclusiveArch: %{ix86} %{x8664} ppc ppc64
+ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautostrip    .*/vgpreload.*\\.so
@@ -27,22 +35,25 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Valgrind is a GPL'd system for debugging and profiling Linux programs.
 With the tools that come with Valgrind, you can automatically detect
-many memory management and threading bugs, avoiding hours of frustrating
-bug-hunting, making your programs more stable. You can also perform
-detailed profiling to help speed up your programs.
+many memory management and threading bugs, avoiding hours of
+frustrating bug-hunting, making your programs more stable. You can
+also perform detailed profiling to help speed up your programs.
 
 %description -l pl.UTF-8
 Valgrind jest systemem służącym do odpluskwiania i profilowania
 programów na Linuksie. Używając dostarczanych z nim narzędzi można
-automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią i
-wątkowaniem, dzięki czemu unika się frustrującego polowania na błędy, a
-także czyni się programy bardziej stabilnymi. Możliwe jest również
-dokładne profilowanie, dzięki któremu programy zaczną szybciej pracować.
+automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
+i wątkowaniem, dzięki czemu unika się frustrującego polowania na
+błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
+również dokładne profilowanie, dzięki któremu programy zaczną szybciej
+pracować.
 
 %prep
 %setup -q
-%patch0 -p1
+%patch0
 %patch1 -p1
+%patch2 -p0
+%patch3 -p1
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
@@ -51,12 +62,16 @@ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configur
 %{__autoheader}
 %{__autoconf}
 %{__automake}
+
+ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
+       CC=gcc \
        --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
 %endif
        LDFLAGS="" # no strip!
+
 %{__make}
 
 %install
@@ -65,23 +80,36 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf _docs
-mv $RPM_BUILD_ROOT%{_docdir}/valgrind _docs
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
+mv docs/index.pdf docs/valgrind_manual.pdf
+mv docs/index.ps docs/valgrind_manual.ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL
-%doc _docs/html
-%doc _docs/valgrind_manual.pdf
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
+%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
+%attr(755,root,root) %{_bindir}/callgrind_annotate
+%attr(755,root,root) %{_bindir}/callgrind_control
+%attr(755,root,root) %{_bindir}/cg_annotate
+%attr(755,root,root) %{_bindir}/cg_diff
+%attr(755,root,root) %{_bindir}/cg_merge
+%attr(755,root,root) %{_bindir}/ms_print
+%attr(755,root,root) %{_bindir}/valgrind
+%attr(755,root,root) %{_bindir}/valgrind-listener
+%attr(755,root,root) %{_bindir}/vgdb
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-linux
-%attr(755,root,root) %{_libdir}/%{name}/*.so
-%{_libdir}/%{name}/*.supp
-%{_libdir}/%{name}/*.a
-%{_includedir}/*
-%{_pkgconfigdir}/*.pc
-%{_mandir}/man1/*.1*
+%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%{_libdir}/%{name}/*.xml
+%{_libdir}/%{name}/default.supp
+%{_libdir}/%{name}/lib*-linux.a
+%{_includedir}/valgrind
+%{_mandir}/man1/callgrind_annotate.1*
+%{_mandir}/man1/callgrind_control.1*
+%{_mandir}/man1/cg_annotate.1*
+%{_mandir}/man1/ms_print.1*
+%{_mandir}/man1/valgrind.1*
+%{_pkgconfigdir}/valgrind.pc
This page took 0.069896 seconds and 4 git commands to generate.