]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- add unofficial support for --vex-native-cpuid=yes|no.
[packages/valgrind.git] / valgrind.spec
index bb076539bc716e7485f9e3a4aa175255d13fc712..535315a47bc60b89d1c99a4e2453e3bedd0c6db8 100644 (file)
@@ -1,18 +1,21 @@
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamięci
 Name:          valgrind
-Version:       3.4.0
-Release:       1
+Version:       3.6.0
+Release:       3
 License:       GPL
 Group:         Development/Tools
 Source0:       http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 1b0fe1219e1a583ff8c2db54ed2265e6
+# Source0-md5: b289c5f4ab8e39741602445f1dd09b34
 Patch0:                %{name}-debuginfo.patch
+Patch1:                %{name}-pr262995.patch
+Patch2:                %{name}-native-cpuid.patch
 URL:           http://valgrind.org/
 BuildRequires: autoconf
 BuildRequires: automake
 # Needs libc.a
 BuildRequires: glibc-static
+BuildRequires: libgomp-devel
 Obsoletes:     valgrind-callgrind
 Obsoletes:     valgrind-calltree
 ExclusiveArch: %{ix86} %{x8664} ppc ppc64
@@ -25,21 +28,24 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Valgrind is a GPL'd system for debugging and profiling Linux programs.
 With the tools that come with Valgrind, you can automatically detect
-many memory management and threading bugs, avoiding hours of frustrating
-bug-hunting, making your programs more stable. You can also perform
-detailed profiling to help speed up your programs.
+many memory management and threading bugs, avoiding hours of
+frustrating bug-hunting, making your programs more stable. You can
+also perform detailed profiling to help speed up your programs.
 
 %description -l pl.UTF-8
 Valgrind jest systemem służącym do odpluskwiania i profilowania
 programów na Linuksie. Używając dostarczanych z nim narzędzi można
-automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią i
-wątkowaniem, dzięki czemu unika się frustrującego polowania na błędy, a
-także czyni się programy bardziej stabilnymi. Możliwe jest również
-dokładne profilowanie, dzięki któremu programy zaczną szybciej pracować.
+automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
+i wątkowaniem, dzięki czemu unika się frustrującego polowania na
+błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
+również dokładne profilowanie, dzięki któremu programy zaczną szybciej
+pracować.
 
 %prep
 %setup -q
-%patch0 -p1
+%patch0
+%patch1 -p1
+%patch2 -p1
 
 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
 
@@ -48,11 +54,15 @@ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configur
 %{__autoheader}
 %{__autoconf}
 %{__automake}
+
+ac_cv_path_GDB=/usr/bin/gdb \
 %configure \
+       --enable-tls \
 %if %{_lib} != "lib"
        --enable-only64bit \
 %endif
        LDFLAGS="" # no strip!
+
 %{__make}
 
 %install
@@ -61,22 +71,23 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf _docs
-mv $RPM_BUILD_ROOT%{_docdir}/valgrind _docs
+rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc
+mv docs/index.pdf docs/valgrind_manual.pdf
+mv docs/index.ps docs/valgrind_manual.ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL
-%doc _docs/html
-%doc _docs/valgrind_manual.pdf
+%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
+%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
 %attr(755,root,root) %{_bindir}/*
+%{_includedir}/*
 %dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/*-linux
-%attr(755,root,root) %{_libdir}/%{name}/*-linux/*
+%attr(755,root,root) %{_libdir}/%{name}/*-linux
+%{_libdir}/%{name}/*.a
+%attr(755,root,root) %{_libdir}/%{name}/*.so
 %{_libdir}/%{name}/*.supp
-%{_includedir}/*
-%{_pkgconfigdir}/*.pc
 %{_mandir}/man1/*.1*
+%{_pkgconfigdir}/*.pc
This page took 0.036471 seconds and 4 git commands to generate.