]> git.pld-linux.org Git - packages/valgrind.git/blobdiff - valgrind.spec
- cleanups
[packages/valgrind.git] / valgrind.spec
index 700033a44348e870c1954aada3bc266a452d2a34..103db65c9a58962d2206a5ca0530444254293cf6 100644 (file)
@@ -1,17 +1,20 @@
-%define                snap    20030329
+#%define               _snap   20040612
 Summary:       An open-source memory debugger for x86-GNU/Linux
 Summary(pl):   Otwarty odpluskwiacz pamiêci dla Linuksa x86
 Name:          valgrind
-Version:       1.9.5
+Version:       2.2.0
 Release:       1
 License:       GPL
-ExclusiveArch: %{ix86}
-Group:         Networking/Utilities
-Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
-#Source0:      %{name}-%{snap}.tar.bz2
-URL:           http://developer.kde.org/~sewardj/
+Group:         Development/Tools
+Source0:       http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
+# Source0-md5: 30dc51f6fc94751b90b04af9c2e2c656
+URL:           http://valgrind.kde.org/
 BuildRequires: autoconf
 BuildRequires: automake
+# Needs libc.a
+BuildRequires: glibc-static
+Conflicts:     valgrind-calltree
+ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # Valgrind binaries should _never_ be stripped
@@ -21,46 +24,26 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
 
 %description
-Valgrind is a flexible tool for debugging and profiling Linux-x86
-executables. The tool consists of a core, which provides a synthetic
-x86 CPU in software, and a series of "skins", each of which is a
-debugging or profiling tool. The architecture is modular, so that new
-skins can be created easily and without disturbing the existing
-structure.
-
-A number of useful skins are supplied as standard. In summary, these
-are:
-- The memcheck skin detects memory-management problems in your
-  programs,
-- cachegrind performs detailed simulation of the I1, D1 and L2 caches
-  in your CPU and so can accurately pinpoint the sources of cache misses
-  in your code,
-- addrcheck skin is a lightweight version of memcheck,
-- helgrind is designed to find data races in multithreaded programs.
+Valgrind is a GPL'd system for debugging and profiling x86-Linux
+programs. With the tools that come with Valgrind, you can
+automatically detect many memory management and threading bugs,
+avoiding hours of frustrating bug-hunting, making your programs more
+stable. You can also perform detailed profiling to help speed up your
+programs.
 
 %description -l pl
-Valgrind jest elastycznym narzêdziem s³u¿±cym do odpluskwiania i
-profilowania programów pod Linuksem. Sk³ada siê z rdzenia
-dostarczaj±cego syntetyczny emulowany procesor zgodny z x86 i ze
-"skórek" bêd±cych narzêdziami o ró¿nych zastosowaniach. Architektura
-programu jest modularna, wobec czego ³atwo mo¿na stworzyæ nowe skórki
-nie ryzykuj±c popsucia reszty.
-
-Standardowo dostarczone jest kilka u¿ytecznych skórek:
-- memcheck wykrywa problemy z zarz±dzaniem pamiêci± w programach,
-- cachegrind przeprowadza symulacjê pamiêci cache procesora w celu
-  znalezienia miejsc, w których cache zawodzi,
-- addrcheck jest lekk± wersj± memchecka,
-- helgrind wykrywa konflikty dostêpu w wielow±tkowych programach.
+Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
+programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
+dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
+b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
+czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
+siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
+profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
 
 %prep
 %setup -q
 
-# pthread_atfork() not found (?)
-echo "main(){}" > corecheck/tests/pth_atfork1.c
-
 %build
-rm -f missing
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
@@ -72,16 +55,24 @@ rm -f missing
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
-%doc README README_MISSING_SYSCALL_OR_IOCTL TODO
+%doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL TODO
 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
 %attr(755,root,root) %{_bindir}/*
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/*.so
+%{_libdir}/%{name}/*.so.*
+%attr(755,root,root) %{_libdir}/%{name}/hp2ps
+%attr(755,root,root) %{_libdir}/%{name}/stage2
+%{_libdir}/%{name}/*.supp
 %{_includedir}/*
-%{_libdir}/%{name}
+%{_pkgconfigdir}/*.pc
This page took 0.043119 seconds and 4 git commands to generate.