]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- release 2.
[packages/valgrind.git] / valgrind.spec
1 Summary:        An open-source memory debugger for x86-GNU/Linux
2 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
3 Name:           valgrind
4 Version:        1.0.0
5 Release:        2
6 License:        GPL
7 ExclusiveArch:  %{ix86}
8 Group:          Networking/Utilities
9 Source0:        http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
10 URL:            http://developer.kde.org/~sewardj/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 # Valgrind binaries should _never_ be stripped
16 %define         no_install_post_strip   1
17
18 %description
19 Valgrind is a GPL'd tool to help you find memory-management problems
20 in your programs. When a program is run under Valgrind's supervision,
21 all reads and writes of memory are checked, and calls to
22 malloc/new/free/delete are intercepted. As a result, Valgrind can
23 detect problems such as:
24
25 - Use of uninitialised memory
26 - Reading/writing memory after it has been free'd
27 - Reading/writing off the end of malloc'd blocks
28 - Reading/writing inappropriate areas on the stack
29 - Memory leaks -- where pointers to malloc'd blocks are lost forever
30 - Passing of uninitialised and/or unaddressible memory to system calls
31 - Mismatched use of malloc/new/new [] vs free/delete/delete []
32 - Some misuses of the POSIX pthreads API
33
34 %description -l pl
35 Valgrind jest narzêdziem rozwi±zuj±cym problemy zwi±zane z zarz±dzaniem
36 pamiêci± w programach. Gdy program zostaje uruchomiony pod nadzorem
37 Valgrinda wszystkie odczyty i zapisy do pamiêci s± sprawdzane.
38 Przechwytywane s± te¿ odwo³ania do malloc/new/free/delete. Dziêki temu
39 mo¿na wykryæ nastêpuj±ce problemy:
40
41 - U¿ycie niezainicjalizowanej pamiêci
42 - Odczytywanie/zapisywanie do obszaru pamiêci, który zosta³ zwolniony
43 - Odczytywanie/zapisywanie na koñcach zaalokowanych bloków
44 - Odczytywanie/zapisywanie niew³a¶ciwych obszarów na stosie
45 - Wycieki pamiêci -- gdy wska¼niki do zaalokowanych bloków s± stracone na
46   zawsze
47 - Przekazywanie niezainicjalizowanej i/lub nieadresowalnej pamiêci do
48   odwo³añ systemowych
49 - Niekonsekwencja w u¿ywaniu malloc/new/new [] kontra free/delete/delete []
50 - Niektóre nadu¿ycia API POSIX pthreads
51
52 %prep
53 %setup -q
54
55 %build
56 rm -f missing
57 aclocal
58 %{__autoconf}
59 %{__automake}
60 %configure \
61         LDFLAGS="" # no strip!
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
75 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
76 %doc docs/*.html
77 %attr(755,root,root) %{_bindir}/*
78 %{_includedir}/*
79 %{_libdir}/%{name}
This page took 0.072761 seconds and 4 git commands to generate.