]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- rel 4; glibc 2.15 support
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 Summary:        An open-source memory debugger
4 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
5 Name:           valgrind
6 Version:        3.7.0
7 Release:        4
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11 # Source0-md5:  a855fda56edf05614f099dca316d1775
12 Patch0:         %{name}-debuginfo.patch
13 Patch1:         %{name}-native-cpuid.patch
14 Patch2:         %{name}-automake-1.11.2.patch
15 Patch3:         %{name}-ld_linux_strlen.patch
16 Patch4:         %{name}-glibc.patch
17 URL:            http://valgrind.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gcc >= 5:3.0
21 # Needs libc.a
22 BuildRequires:  glibc-devel >= 6:2.2
23 BuildRequires:  glibc-devel < 6:2.16
24 BuildRequires:  glibc-static
25 BuildRequires:  libgomp-devel
26 BuildRequires:  libstdc++-devel
27 Obsoletes:      valgrind-callgrind
28 Obsoletes:      valgrind-calltree
29 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautostrip    .*/vgpreload.*\\.so
33 # ld portion broken
34 %undefine       with_ccache
35
36 %description
37 Valgrind is a GPL'd system for debugging and profiling Linux programs.
38 With the tools that come with Valgrind, you can automatically detect
39 many memory management and threading bugs, avoiding hours of
40 frustrating bug-hunting, making your programs more stable. You can
41 also perform detailed profiling to help speed up your programs.
42
43 %description -l pl.UTF-8
44 Valgrind jest systemem służącym do odpluskwiania i profilowania
45 programów na Linuksie. Używając dostarczanych z nim narzędzi można
46 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
47 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
48 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
49 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
50 pracować.
51
52 %prep
53 %setup -q
54 %patch0
55 %patch1 -p1
56 %patch2 -p0
57 %patch3 -p1
58 %patch4 -p0
59
60 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
61
62 %build
63 %{__aclocal}
64 %{__autoheader}
65 %{__autoconf}
66 %{__automake}
67
68 ac_cv_path_GDB=/usr/bin/gdb \
69 %configure \
70         CC=gcc \
71         --enable-tls \
72 %if %{_lib} != "lib"
73         --enable-only64bit \
74 %endif
75         LDFLAGS="" # no strip!
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
86 mv docs/index.pdf docs/valgrind_manual.pdf
87 mv docs/index.ps docs/valgrind_manual.ps
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
95 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
96 %attr(755,root,root) %{_bindir}/callgrind_annotate
97 %attr(755,root,root) %{_bindir}/callgrind_control
98 %attr(755,root,root) %{_bindir}/cg_annotate
99 %attr(755,root,root) %{_bindir}/cg_diff
100 %attr(755,root,root) %{_bindir}/cg_merge
101 %attr(755,root,root) %{_bindir}/ms_print
102 %attr(755,root,root) %{_bindir}/valgrind
103 %attr(755,root,root) %{_bindir}/valgrind-listener
104 %attr(755,root,root) %{_bindir}/vgdb
105 %dir %{_libdir}/%{name}
106 %attr(755,root,root) %{_libdir}/%{name}/*-linux
107 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
108 %{_libdir}/%{name}/*.xml
109 %{_libdir}/%{name}/default.supp
110 %{_libdir}/%{name}/lib*-linux.a
111 %{_includedir}/valgrind
112 %{_mandir}/man1/callgrind_annotate.1*
113 %{_mandir}/man1/callgrind_control.1*
114 %{_mandir}/man1/cg_annotate.1*
115 %{_mandir}/man1/ms_print.1*
116 %{_mandir}/man1/valgrind.1*
117 %{_pkgconfigdir}/valgrind.pc
This page took 0.040236 seconds and 4 git commands to generate.