]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- uhm..
[packages/valgrind.git] / valgrind.spec
1 %define         snap    20030329
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        1.9.4
6 Release:        1.%{snap}.1
7 License:        GPL
8 ExclusiveArch:  %{ix86}
9 Group:          Networking/Utilities
10 #Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
11 Source0:        %{name}-%{snap}.tar.bz2
12 URL:            http://developer.kde.org/~sewardj/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # Valgrind binaries should _never_ be stripped
18 %define         no_install_post_strip   1
19
20 # Same name as libpthread
21 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
22
23 %description
24 Valgrind is a flexible tool for debugging and profiling Linux-x86
25 executables. The tool consists of a core, which provides a synthetic
26 x86 CPU in software, and a series of "skins", each of which is a
27 debugging or profiling tool. The architecture is modular, so that new
28 skins can be created easily and without disturbing the existing
29 structure.
30
31 A number of useful skins are supplied as standard. In summary, these
32 are:
33 - The memcheck skin detects memory-management problems in your
34   programs,
35 - cachegrind performs detailed simulation of the I1, D1 and L2 caches
36   in your CPU and so can accurately pinpoint the sources of cache misses
37   in your code,
38 - addrcheck skin is a lightweight version of memcheck,
39 - helgrind is designed to find data races in multithreaded programs.
40
41 %description -l pl
42 Valgrind jest elastycznym narzêdziem s³u¿±cym do odpluskwiania i
43 profilowania programów pod Linuksem. Sk³ada siê z rdzenia
44 dostarczaj±cego syntetyczny emulowany procesor zgodny z x86 i ze
45 "skórek" bêd±cych narzêdziami o ró¿nych zastosowaniach. Architektura
46 programu jest modularna, wobec czego ³atwo mo¿na stworzyæ nowe skórki
47 nie ryzykuj±c popsucia reszty.
48
49 Standardowo dostarczone jest kilka u¿ytecznych skórek:
50 - memcheck wykrywa problemy z zarz±dzaniem pamiêci± w programach,
51 - cachegrind przeprowadza symulacjê pamiêci cache procesora w celu
52   znalezienia miejsc, w których cache zawodzi,
53 - addrcheck jest lekk± wersj± memchecka,
54 - helgrind wykrywa konflikty dostêpu w wielow±tkowych programach.
55
56 %prep
57 %setup -q -n %{name}
58
59 # pthread_atfork() not found (?)
60 echo "main(){}" > corecheck/tests/pth_atfork1.c
61
62 %build
63 rm -f missing
64 %{__aclocal}
65 %{__autoheader}
66 %{__autoconf}
67 %{__automake}
68 %configure \
69         LDFLAGS="" # no strip!
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
83 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
84 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
85 %attr(755,root,root) %{_bindir}/*
86 %{_includedir}/*
87 %{_libdir}/%{name}
This page took 0.070728 seconds and 4 git commands to generate.