]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- rel 2; support ld -z separate-code generated binaries
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 #
4 # Conditional build:
5 %bcond_with     mpi     # MPI wrapper module
6 #
7 Summary:        An open-source memory debugger
8 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
9 Name:           valgrind
10 Version:        3.13.0
11 Release:        2
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        ftp://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
15 # Source0-md5:  817dd08f1e8a66336b9ff206400a5369
16 Patch0:         %{name}-native-cpuid.patch
17 Patch1:         %{name}-ld_linux_strlen.patch
18 Patch2:         valgrind-3.13.0-ld-separate-code.patch
19 URL:            http://valgrind.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gcc >= 5:3.0
23 %ifarch x32
24 BuildRequires:  gcc-multilib-64 >= 5:3.0
25 %endif
26 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
27 BuildRequires:  glibc-devel >= 6:2.2
28 BuildRequires:  libgomp-devel
29 BuildRequires:  libstdc++-devel
30 %{?with_mpi:BuildRequires:      mpi-devel}
31 Obsoletes:      valgrind-callgrind
32 Obsoletes:      valgrind-calltree
33 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x x32
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautostrip    .*/vgpreload.*\\.so
37 %define         filterout_c     -fstack-protector-strong
38 # ld portion broken
39 %undefine       with_ccache
40
41 %description
42 Valgrind is a GPL'd system for debugging and profiling Linux programs.
43 With the tools that come with Valgrind, you can automatically detect
44 many memory management and threading bugs, avoiding hours of
45 frustrating bug-hunting, making your programs more stable. You can
46 also perform detailed profiling to help speed up your programs.
47
48 %description -l pl.UTF-8
49 Valgrind jest systemem służącym do odpluskwiania i profilowania
50 programów na Linuksie. Używając dostarczanych z nim narzędzi można
51 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
52 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
53 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
54 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
55 pracować.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62
63 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
64
65 %build
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70
71 ac_cv_path_GDB=/usr/bin/gdb \
72 %configure \
73         CC=gcc \
74         --enable-tls \
75 %if %{_lib} != "lib"
76         --enable-only64bit \
77 %endif
78         LDFLAGS="" # no strip!
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
89 cp -p docs/index.pdf docs/valgrind_manual.pdf
90 cp -p docs/index.ps docs/valgrind_manual.ps
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
98 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
99 %attr(755,root,root) %{_bindir}/callgrind_annotate
100 %attr(755,root,root) %{_bindir}/callgrind_control
101 %attr(755,root,root) %{_bindir}/cg_annotate
102 %attr(755,root,root) %{_bindir}/cg_diff
103 %attr(755,root,root) %{_bindir}/cg_merge
104 %attr(755,root,root) %{_bindir}/ms_print
105 %attr(755,root,root) %{_bindir}/valgrind
106 %attr(755,root,root) %{_bindir}/valgrind-di-server
107 %attr(755,root,root) %{_bindir}/valgrind-listener
108 %attr(755,root,root) %{_bindir}/vgdb
109 %dir %{_libdir}/%{name}
110 %attr(755,root,root) %{_libdir}/%{name}/*-linux
111 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
112 %if %{with mpi}
113 # TODO: subpackage?
114 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
115 %endif
116 %{_libdir}/%{name}/*.xml
117 %{_libdir}/%{name}/default.supp
118 %{_libdir}/%{name}/lib*-linux.a
119 %{_includedir}/valgrind
120 %{_mandir}/man1/callgrind_annotate.1*
121 %{_mandir}/man1/callgrind_control.1*
122 %{_mandir}/man1/cg_annotate.1*
123 %{_mandir}/man1/cg_diff.1*
124 %{_mandir}/man1/cg_merge.1*
125 %{_mandir}/man1/ms_print.1*
126 %{_mandir}/man1/valgrind.1*
127 %{_mandir}/man1/valgrind-listener.1*
128 %{_mandir}/man1/vgdb.1*
129 %{_pkgconfigdir}/valgrind.pc
This page took 0.036433 seconds and 4 git commands to generate.