]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
Up to 3.8.0
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 Summary:        An open-source memory debugger
4 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
5 Name:           valgrind
6 Version:        3.8.0
7 Release:        0.1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11 # Source0-md5:  ec04dfd1256307432b2a7b520398c526
12 Patch0:         %{name}-native-cpuid.patch
13 Patch1:         %{name}-ld_linux_strlen.patch
14 URL:            http://valgrind.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gcc >= 5:3.0
18 # Needs libc.a
19 BuildRequires:  glibc-devel >= 6:2.2
20 BuildRequires:  glibc-devel < 6:2.17
21 BuildRequires:  glibc-static
22 BuildRequires:  libgomp-devel
23 BuildRequires:  libstdc++-devel
24 Obsoletes:      valgrind-callgrind
25 Obsoletes:      valgrind-calltree
26 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautostrip    .*/vgpreload.*\\.so
30 # ld portion broken
31 %undefine       with_ccache
32
33 %description
34 Valgrind is a GPL'd system for debugging and profiling Linux programs.
35 With the tools that come with Valgrind, you can automatically detect
36 many memory management and threading bugs, avoiding hours of
37 frustrating bug-hunting, making your programs more stable. You can
38 also perform detailed profiling to help speed up your programs.
39
40 %description -l pl.UTF-8
41 Valgrind jest systemem służącym do odpluskwiania i profilowania
42 programów na Linuksie. Używając dostarczanych z nim narzędzi można
43 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
44 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
45 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
46 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
47 pracować.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52 %patch1 -p1
53
54 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
55
56 %build
57 %{__aclocal}
58 %{__autoheader}
59 %{__autoconf}
60 %{__automake}
61
62 ac_cv_path_GDB=/usr/bin/gdb \
63 %configure \
64         CC=gcc \
65         --enable-tls \
66 %if %{_lib} != "lib"
67         --enable-only64bit \
68 %endif
69         LDFLAGS="" # no strip!
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
80 mv docs/index.pdf docs/valgrind_manual.pdf
81 mv docs/index.ps docs/valgrind_manual.ps
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
89 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
90 %attr(755,root,root) %{_bindir}/callgrind_annotate
91 %attr(755,root,root) %{_bindir}/callgrind_control
92 %attr(755,root,root) %{_bindir}/cg_annotate
93 %attr(755,root,root) %{_bindir}/cg_diff
94 %attr(755,root,root) %{_bindir}/cg_merge
95 %attr(755,root,root) %{_bindir}/ms_print
96 %attr(755,root,root) %{_bindir}/valgrind
97 %attr(755,root,root) %{_bindir}/valgrind-listener
98 %attr(755,root,root) %{_bindir}/vgdb
99 %dir %{_libdir}/%{name}
100 %attr(755,root,root) %{_libdir}/%{name}/*-linux
101 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
102 %{_libdir}/%{name}/*.xml
103 %{_libdir}/%{name}/default.supp
104 %{_libdir}/%{name}/lib*-linux.a
105 %{_includedir}/valgrind
106 %{_mandir}/man1/callgrind_annotate.1*
107 %{_mandir}/man1/callgrind_control.1*
108 %{_mandir}/man1/cg_annotate.1*
109 %{_mandir}/man1/ms_print.1*
110 %{_mandir}/man1/valgrind.1*
111 %{_pkgconfigdir}/valgrind.pc
This page took 0.073564 seconds and 4 git commands to generate.