]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- handle REP RET
[packages/valgrind.git] / valgrind.spec
1 #%define                _snap   20040612
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        3.0.0
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
10 # Source0-md5:  e976a343c61d9505162f595a8aeb09c1
11 Patch0:         %{name}-repret.patch
12 URL:            http://valgrind.org/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 # Needs libc.a
16 BuildRequires:  glibc-static
17 Conflicts:      valgrind-calltree
18 ExclusiveArch:  %{ix86} %{x8664}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # Valgrind binaries should _never_ be stripped
22 %define         no_install_post_strip   1
23
24 # Same name as libpthread
25 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
26
27 %description
28 Valgrind is a GPL'd system for debugging and profiling x86-Linux
29 programs. With the tools that come with Valgrind, you can
30 automatically detect many memory management and threading bugs,
31 avoiding hours of frustrating bug-hunting, making your programs more
32 stable. You can also perform detailed profiling to help speed up your
33 programs.
34
35 %description -l pl
36 Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
37 programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
38 dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
39 b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
40 czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
41 siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
42 profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
43
44 %prep
45 %setup -q
46 %patch0 -p0
47
48 %build
49 %{__aclocal}
50 %{__autoheader}
51 %{__autoconf}
52 %{__automake}
53 %configure \
54         LDFLAGS="" # no strip!
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL
71 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/html
72 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/valgrind_manual.pdf
73 %attr(755,root,root) %{_bindir}/*
74 %dir %{_libdir}/%{name}
75 %attr(755,root,root) %{_libdir}/%{name}/*.so
76 #%{_libdir}/%{name}/*.so.*
77 %attr(755,root,root) %{_libdir}/%{name}/hp2ps
78 %attr(755,root,root) %{_libdir}/%{name}/stage2
79 %{_libdir}/%{name}/*.supp
80 %{_includedir}/*
81 %{_pkgconfigdir}/*.pc
82 %{_mandir}/man1/*.1*
This page took 0.065419 seconds and 4 git commands to generate.