]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
update to 3.10.1, correct glibc version
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 Summary:        An open-source memory debugger
4 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
5 Name:           valgrind
6 Version:        3.10.1
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11 # Source0-md5:  60ddae962bc79e7c95cfc4667245707f
12 Patch0:         %{name}-native-cpuid.patch
13 Patch1:         %{name}-ld_linux_strlen.patch
14 URL:            http://valgrind.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gcc >= 5:3.0
18 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
19 BuildRequires:  glibc-devel >= 6:2.2
20 BuildRequires:  glibc-devel <= 6:2.19
21 BuildRequires:  libgomp-devel
22 BuildRequires:  libstdc++-devel
23 Obsoletes:      valgrind-callgrind
24 Obsoletes:      valgrind-calltree
25 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautostrip    .*/vgpreload.*\\.so
29 # ld portion broken
30 %undefine       with_ccache
31
32 %description
33 Valgrind is a GPL'd system for debugging and profiling Linux programs.
34 With the tools that come with Valgrind, you can automatically detect
35 many memory management and threading bugs, avoiding hours of
36 frustrating bug-hunting, making your programs more stable. You can
37 also perform detailed profiling to help speed up your programs.
38
39 %description -l pl.UTF-8
40 Valgrind jest systemem służącym do odpluskwiania i profilowania
41 programów na Linuksie. Używając dostarczanych z nim narzędzi można
42 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
43 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
44 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
45 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
46 pracować.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52
53 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
54
55 %build
56 %{__aclocal}
57 %{__autoheader}
58 %{__autoconf}
59 %{__automake}
60
61 ac_cv_path_GDB=/usr/bin/gdb \
62 %configure \
63         CC=gcc \
64         --enable-tls \
65 %if %{_lib} != "lib"
66         --enable-only64bit \
67 %endif
68         LDFLAGS="" # no strip!
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
79 cp -p docs/index.pdf docs/valgrind_manual.pdf
80 cp -p docs/index.ps docs/valgrind_manual.ps
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
88 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
89 %attr(755,root,root) %{_bindir}/callgrind_annotate
90 %attr(755,root,root) %{_bindir}/callgrind_control
91 %attr(755,root,root) %{_bindir}/cg_annotate
92 %attr(755,root,root) %{_bindir}/cg_diff
93 %attr(755,root,root) %{_bindir}/cg_merge
94 %attr(755,root,root) %{_bindir}/ms_print
95 %attr(755,root,root) %{_bindir}/valgrind
96 %attr(755,root,root) %{_bindir}/valgrind-di-server
97 %attr(755,root,root) %{_bindir}/valgrind-listener
98 %attr(755,root,root) %{_bindir}/vgdb
99 %dir %{_libdir}/%{name}
100 %attr(755,root,root) %{_libdir}/%{name}/*-linux
101 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
102 %{_libdir}/%{name}/*.xml
103 %{_libdir}/%{name}/default.supp
104 %{_libdir}/%{name}/lib*-linux.a
105 %{_includedir}/valgrind
106 %{_mandir}/man1/callgrind_annotate.1*
107 %{_mandir}/man1/callgrind_control.1*
108 %{_mandir}/man1/cg_annotate.1*
109 %{_mandir}/man1/cg_diff.1*
110 %{_mandir}/man1/cg_merge.1*
111 %{_mandir}/man1/ms_print.1*
112 %{_mandir}/man1/valgrind.1*
113 %{_mandir}/man1/valgrind-listener.1*
114 %{_mandir}/man1/vgdb.1*
115 %{_pkgconfigdir}/valgrind.pc
This page took 0.030921 seconds and 3 git commands to generate.