]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
ec5338b8804e56b379a2a97315fb19d52ce2251d
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 #
4 # Conditional build:
5 %bcond_with     mpi     # MPI wrapper module
6 #
7 Summary:        An open-source memory debugger
8 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
9 Name:           valgrind
10 Version:        3.15.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
15 # Source0-md5:  46e5fbdcbc3502a5976a317a0860a975
16 Patch0:         %{name}-native-cpuid.patch
17 Patch1:         %{name}-ld_linux_strlen.patch
18 URL:            http://valgrind.org/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  gcc >= 5:3.0
22 %ifarch x32
23 BuildRequires:  gcc-multilib-64 >= 5:3.0
24 %endif
25 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
26 BuildRequires:  glibc-devel >= 6:2.2
27 BuildRequires:  libgomp-devel
28 BuildRequires:  libstdc++-devel
29 %{?with_mpi:BuildRequires:      mpi-devel}
30 Obsoletes:      valgrind-callgrind
31 Obsoletes:      valgrind-calltree
32 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x x32
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautostrip    .*/vgpreload.*\\.so
36 %define         filterout_c     -fstack-protector-strong
37 # ld portion broken
38 %undefine       with_ccache
39
40 %description
41 Valgrind is a GPL'd system for debugging and profiling Linux programs.
42 With the tools that come with Valgrind, you can automatically detect
43 many memory management and threading bugs, avoiding hours of
44 frustrating bug-hunting, making your programs more stable. You can
45 also perform detailed profiling to help speed up your programs.
46
47 %description -l pl.UTF-8
48 Valgrind jest systemem służącym do odpluskwiania i profilowania
49 programów na Linuksie. Używając dostarczanych z nim narzędzi można
50 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
51 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
52 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
53 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
54 pracować.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
62
63 %build
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68
69 ac_cv_path_GDB=/usr/bin/gdb \
70 %configure \
71         CC=gcc \
72         --enable-tls \
73         %{!?with_mpi:--with-mpicc=/bin/false} \
74 %if %{_lib} != "lib"
75         --enable-only64bit \
76 %endif \
77         --enable-lto=yes \
78         LDFLAGS="" # no strip!
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
89 cp -p docs/index.pdf docs/valgrind_manual.pdf
90 cp -p docs/index.ps docs/valgrind_manual.ps
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
98 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
99 %attr(755,root,root) %{_bindir}/callgrind_annotate
100 %attr(755,root,root) %{_bindir}/callgrind_control
101 %attr(755,root,root) %{_bindir}/cg_annotate
102 %attr(755,root,root) %{_bindir}/cg_diff
103 %attr(755,root,root) %{_bindir}/cg_merge
104 %attr(755,root,root) %{_bindir}/ms_print
105 %attr(755,root,root) %{_bindir}/valgrind
106 %attr(755,root,root) %{_bindir}/valgrind-di-server
107 %attr(755,root,root) %{_bindir}/valgrind-listener
108 %attr(755,root,root) %{_bindir}/vgdb
109 %dir %{_libdir}/%{name}
110 %attr(755,root,root) %{_libdir}/%{name}/*-linux
111 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
112 %if %{with mpi}
113 # TODO: subpackage?
114 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
115 %endif
116 %{_libdir}/%{name}/*.xml
117 %{_libdir}/%{name}/default.supp
118 %{_libdir}/%{name}/lib*-linux.a
119 %{_libexecdir}/%{name}
120 %{_includedir}/valgrind
121 %{_mandir}/man1/callgrind_annotate.1*
122 %{_mandir}/man1/callgrind_control.1*
123 %{_mandir}/man1/cg_annotate.1*
124 %{_mandir}/man1/cg_diff.1*
125 %{_mandir}/man1/cg_merge.1*
126 %{_mandir}/man1/ms_print.1*
127 %{_mandir}/man1/valgrind.1*
128 %{_mandir}/man1/valgrind-di-server.1*
129 %{_mandir}/man1/valgrind-listener.1*
130 %{_mandir}/man1/vgdb.1*
131 %{_pkgconfigdir}/valgrind.pc
This page took 0.044978 seconds and 2 git commands to generate.