]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- new desc
[packages/valgrind.git] / valgrind.spec
1 #%define                snap    20031012
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        2.1.0
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
10 # Source0-md5:  3e4056dd45163a5f555a23ced2f95191
11 #Source0:       %{name}-%{snap}.tar.bz2
12 Patch0:         %{name}-include_fs.patch
13 URL:            http://valgrind.kde.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 ExclusiveArch:  %{ix86}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 # Valgrind binaries should _never_ be stripped
20 %define         no_install_post_strip   1
21
22 # Same name as libpthread
23 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
24
25 %description
26 Valgrind is a GPL'd system for debugging and profiling x86-Linux
27 programs. With the tools that come with Valgrind, you can
28 automatically detect many memory management and threading bugs,
29 avoiding hours of frustrating bug-hunting, making your programs more
30 stable. You can also perform detailed profiling to help speed up your
31 programs.
32
33 %description -l pl
34 Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
35 programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
36 dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
37 b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
38 czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
39 siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
40 profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__aclocal}
48 %{__autoheader}
49 %{__autoconf}
50 %{__automake}
51 %configure \
52         LDFLAGS="" # no strip!
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS PATCHES_APPLIED
67 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
68 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
69 %attr(755,root,root) %{_bindir}/*
70 %{_libdir}/%{name}
71 %{_includedir}/*
72 %{_pkgconfigdir}/*.pc
This page took 0.035664 seconds and 3 git commands to generate.