]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
d421e88b34a2ab00e3f16928900ef364e40a1cb0
[packages/valgrind.git] / valgrind.spec
1 #%define                snap    20031012
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        2.1.0
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
10 # Source0-md5:  3e4056dd45163a5f555a23ced2f95191
11 #Source0:       %{name}-%{snap}.tar.bz2
12 Patch0:         %{name}-sockios.patch
13 URL:            http://valgrind.kde.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 ExclusiveArch:  %{ix86}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 # Valgrind binaries should _never_ be stripped
20 %define         no_install_post_strip   1
21
22 # Same name as libpthread
23 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
24
25 %description
26 Valgrind is a flexible tool for debugging and profiling Linux-x86
27 executables. The tool consists of a core, which provides a synthetic
28 x86 CPU in software, and a series of "skins", each of which is a
29 debugging or profiling tool. The architecture is modular, so that new
30 skins can be created easily and without disturbing the existing
31 structure.
32
33 A number of useful skins are supplied as standard. In summary, these
34 are:
35 - The memcheck skin detects memory-management problems in your
36   programs,
37 - cachegrind performs detailed simulation of the I1, D1 and L2 caches
38   in your CPU and so can accurately pinpoint the sources of cache misses
39   in your code,
40 - addrcheck skin is a lightweight version of memcheck,
41 - helgrind is designed to find data races in multithreaded programs.
42
43 %description -l pl
44 Valgrind jest elastycznym narzêdziem s³u¿±cym do odpluskwiania i
45 profilowania programów pod Linuksem. Sk³ada siê z rdzenia
46 dostarczaj±cego syntetyczny emulowany procesor zgodny z x86 i ze
47 "skórek" bêd±cych narzêdziami o ró¿nych zastosowaniach. Architektura
48 programu jest modularna, wobec czego ³atwo mo¿na stworzyæ nowe skórki
49 nie ryzykuj±c popsucia reszty.
50
51 Standardowo dostarczone jest kilka u¿ytecznych skórek:
52 - memcheck wykrywa problemy z zarz±dzaniem pamiêci± w programach,
53 - cachegrind przeprowadza symulacjê pamiêci cache procesora w celu
54   znalezienia miejsc, w których cache zawodzi,
55 - addrcheck jest lekk± wersj± memchecka,
56 - helgrind wykrywa konflikty dostêpu w wielow±tkowych programach.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 %{__aclocal}
64 %{__autoheader}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         LDFLAGS="" # no strip!
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS PATCHES_APPLIED
83 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
84 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
85 %attr(755,root,root) %{_bindir}/*
86 %{_libdir}/%{name}
87 %{_includedir}/*
88 %{_pkgconfigdir}/*.pc
This page took 0.051944 seconds and 2 git commands to generate.