]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- 1.9.3 (think glibc 2.3.x)
[packages/valgrind.git] / valgrind.spec
1 Summary:        An open-source memory debugger for x86-GNU/Linux
2 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
3 Name:           valgrind
4 Version:        1.9.3
5 Release:        1
6 License:        GPL
7 ExclusiveArch:  %{ix86}
8 Group:          Networking/Utilities
9 Source0:        http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
10 URL:            http://developer.kde.org/~sewardj/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 # Valgrind binaries should _never_ be stripped
16 %define         no_install_post_strip   1
17
18 # Same name as libpthread
19 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
20
21 %description
22 Valgrind is a GPL'd tool to help you find memory-management problems
23 in your programs. When a program is run under Valgrind's supervision,
24 all reads and writes of memory are checked, and calls to
25 malloc/new/free/delete are intercepted. As a result, Valgrind can
26 detect problems such as:
27
28 - Use of uninitialised memory
29 - Reading/writing memory after it has been free'd
30 - Reading/writing off the end of malloc'd blocks
31 - Reading/writing inappropriate areas on the stack
32 - Memory leaks -- where pointers to malloc'd blocks are lost forever
33 - Passing of uninitialised and/or unaddressible memory to system calls
34 - Mismatched use of malloc/new/new [] vs free/delete/delete []
35 - Some misuses of the POSIX pthreads API
36
37 %description -l pl
38 Valgrind jest narzêdziem rozwi±zuj±cym problemy zwi±zane z zarz±dzaniem
39 pamiêci± w programach. Gdy program zostaje uruchomiony pod nadzorem
40 Valgrinda wszystkie odczyty i zapisy do pamiêci s± sprawdzane.
41 Przechwytywane s± te¿ odwo³ania do malloc/new/free/delete. Dziêki temu
42 mo¿na wykryæ nastêpuj±ce problemy:
43
44 - U¿ycie niezainicjalizowanej pamiêci
45 - Odczytywanie/zapisywanie do obszaru pamiêci, który zosta³ zwolniony
46 - Odczytywanie/zapisywanie na koñcach zaalokowanych bloków
47 - Odczytywanie/zapisywanie niew³a¶ciwych obszarów na stosie
48 - Wycieki pamiêci -- gdy wska¼niki do zaalokowanych bloków s± stracone na
49   zawsze
50 - Przekazywanie niezainicjalizowanej i/lub nieadresowalnej pamiêci do
51   odwo³añ systemowych
52 - Niekonsekwencja w u¿ywaniu malloc/new/new [] kontra free/delete/delete []
53 - Niektóre nadu¿ycia API POSIX pthreads
54
55 %prep
56 %setup -q
57
58 %build
59 rm -f missing
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         LDFLAGS="" # no strip!
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
78 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
79 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
80 %attr(755,root,root) %{_bindir}/*
81 %{_includedir}/*
82 %{_libdir}/%{name}
This page took 0.03143 seconds and 3 git commands to generate.