]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- typo
[packages/valgrind.git] / valgrind.spec
1 Summary:        An open-source memory debugger for x86-GNU/Linux
2 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
3 Name:           valgrind
4 Version:        1.0.0
5 Release:        1
6 License:        GPL
7 ExclusiveArch:  %{ix86}
8 Group:          Networking/Utilities
9 Source0:        http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
10 URL:            http://developer.kde.org/~sewardj/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 # valgrind binaries should _never_ be stripped
16 # anyone knows better solution?
17 %define         debug   1
18
19 %description
20 Valgrind is a GPL'd tool to help you find memory-management problems
21 in your programs. When a program is run under Valgrind's supervision,
22 all reads and writes of memory are checked, and calls to
23 malloc/new/free/delete are intercepted. As a result, Valgrind can
24 detect problems such as:
25
26 - Use of uninitialised memory
27 - Reading/writing memory after it has been free'd
28 - Reading/writing off the end of malloc'd blocks
29 - Reading/writing inappropriate areas on the stack
30 - Memory leaks -- where pointers to malloc'd blocks are lost forever
31 - Passing of uninitialised and/or unaddressible memory to system calls
32 - Mismatched use of malloc/new/new [] vs free/delete/delete []
33 - Some misuses of the POSIX pthreads API
34
35 %description -l pl
36 Valgrind jest narzêdziem rozwi±zuj±cym problemy zwi±zane z zarz±dzaniem
37 pamiêci± w programach. Gdy program zostaje uruchomiony pod nadzorem
38 Valgrinda wszystkie odczyty i zapisy do pamiêci s± sprawdzane.
39 Przechwytywane s± te¿ odwo³ania do malloc/new/free/delete. Dziêki temu
40 mo¿na wykryæ nastêpuj±ce problemy:
41
42 - U¿ycie niezainicjalizowanej pamiêci
43 - Odczytywanie/zapisywanie do obszaru pamiêci, który zosta³ zwolniony
44 - Odczytywanie/zapisywanie na koñcach zaalokowanych bloków
45 - Odczytywanie/zapisywanie niew³a¶ciwych obszarów na stosie
46 - Wycieki pamiêci -- gdy wska¼niki do zaalokowanych bloków s± stracone na
47   zawsze
48 - Przekazywanie niezainicjalizowanej i/lub nieadresowalnej pamiêci do
49   odwo³añ systemowych
50 - Niekonsekwencja w u¿ywaniu malloc/new/new [] kontra free/delete/delete []
51 - Niektóre nadu¿ycia API POSIX pthreads
52
53 %prep
54 %setup -q
55
56 %build
57 rm -f missing
58 aclocal
59 %{__autoconf}
60 %{__automake}
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
75 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
76 %doc docs/*.html
77 %attr(755,root,root) %{_bindir}/*
78 %{_includedir}/*
79 %{_libdir}/%{name}
This page took 0.068244 seconds and 3 git commands to generate.