]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
241ca1ac56ac866aa8e4acd074c4eef7798dbccb
[packages/valgrind.git] / valgrind.spec
1 %define         snap    20040220
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        2.1.0
6 Release:        1.%{snap}.1
7 License:        GPL
8 Group:          Development/Tools
9 #Source0:       http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
10 Source0:        %{name}-%{snap}.tar.bz2
11 # Source0-md5:  1363a4e29ee9b698c37a92a6a9b62ed0
12 Patch0:         %{name}-include_fs.patch
13 Patch1:         %{name}-athlon.patch
14 URL:            http://valgrind.kde.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 ExclusiveArch:  %{ix86}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # Valgrind binaries should _never_ be stripped
21 %define         no_install_post_strip   1
22
23 # Same name as libpthread
24 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
25
26 %description
27 Valgrind is a GPL'd system for debugging and profiling x86-Linux
28 programs. With the tools that come with Valgrind, you can
29 automatically detect many memory management and threading bugs,
30 avoiding hours of frustrating bug-hunting, making your programs more
31 stable. You can also perform detailed profiling to help speed up your
32 programs.
33
34 %description -l pl
35 Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
36 programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
37 dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
38 b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
39 czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
40 siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
41 profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
42
43 %prep
44 %setup -q -n %{name}
45 #%patch0 -p1
46 %patch1 -p0
47
48 %build
49 %{__aclocal}
50 %{__autoheader}
51 %{__autoconf}
52 %{__automake}
53 %configure \
54         LDFLAGS="" # no strip!
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL TODO
71 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
72 %attr(755,root,root) %{_bindir}/*
73 %dir %{_libdir}/%{name}
74 %attr(755,root,root) %{_libdir}/%{name}/*.so
75 %attr(755,root,root) %{_libdir}/%{name}/hp2ps
76 %attr(755,root,root) %{_libdir}/%{name}/stage2
77 %{_libdir}/%{name}/*.supp
78 %{_includedir}/*
79 %{_pkgconfigdir}/*.pc
This page took 0.053676 seconds and 2 git commands to generate.