]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
1b437bd81eabc5edd8e276b824e0be1945d1f514
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 Summary:        An open-source memory debugger
4 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
5 Name:           valgrind
6 Version:        3.10.0
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11 # Source0-md5:  7c311a72a20388aceced1aa5573ce970
12 Patch0:         %{name}-native-cpuid.patch
13 Patch1:         %{name}-ld_linux_strlen.patch
14 URL:            http://valgrind.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gcc >= 5:3.0
18 BuildRequires:  glibc-devel >= 6:2.2
19 BuildRequires:  glibc-devel < 6:2.21
20 BuildRequires:  libgomp-devel
21 BuildRequires:  libstdc++-devel
22 Obsoletes:      valgrind-callgrind
23 Obsoletes:      valgrind-calltree
24 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautostrip    .*/vgpreload.*\\.so
28 # ld portion broken
29 %undefine       with_ccache
30
31 %description
32 Valgrind is a GPL'd system for debugging and profiling Linux programs.
33 With the tools that come with Valgrind, you can automatically detect
34 many memory management and threading bugs, avoiding hours of
35 frustrating bug-hunting, making your programs more stable. You can
36 also perform detailed profiling to help speed up your programs.
37
38 %description -l pl.UTF-8
39 Valgrind jest systemem służącym do odpluskwiania i profilowania
40 programów na Linuksie. Używając dostarczanych z nim narzędzi można
41 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
42 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
43 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
44 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
45 pracować.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51
52 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
53
54 %build
55 %{__aclocal}
56 %{__autoheader}
57 %{__autoconf}
58 %{__automake}
59
60 ac_cv_path_GDB=/usr/bin/gdb \
61 %configure \
62         CC=gcc \
63         --enable-tls \
64 %if %{_lib} != "lib"
65         --enable-only64bit \
66 %endif
67         LDFLAGS="" # no strip!
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
78 cp -p docs/index.pdf docs/valgrind_manual.pdf
79 cp -p docs/index.ps docs/valgrind_manual.ps
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
87 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
88 %attr(755,root,root) %{_bindir}/callgrind_annotate
89 %attr(755,root,root) %{_bindir}/callgrind_control
90 %attr(755,root,root) %{_bindir}/cg_annotate
91 %attr(755,root,root) %{_bindir}/cg_diff
92 %attr(755,root,root) %{_bindir}/cg_merge
93 %attr(755,root,root) %{_bindir}/ms_print
94 %attr(755,root,root) %{_bindir}/valgrind
95 %attr(755,root,root) %{_bindir}/valgrind-di-server
96 %attr(755,root,root) %{_bindir}/valgrind-listener
97 %attr(755,root,root) %{_bindir}/vgdb
98 %dir %{_libdir}/%{name}
99 %attr(755,root,root) %{_libdir}/%{name}/*-linux
100 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
101 %{_libdir}/%{name}/*.xml
102 %{_libdir}/%{name}/default.supp
103 %{_libdir}/%{name}/lib*-linux.a
104 %{_includedir}/valgrind
105 %{_mandir}/man1/callgrind_annotate.1*
106 %{_mandir}/man1/callgrind_control.1*
107 %{_mandir}/man1/cg_annotate.1*
108 %{_mandir}/man1/cg_diff.1*
109 %{_mandir}/man1/cg_merge.1*
110 %{_mandir}/man1/ms_print.1*
111 %{_mandir}/man1/valgrind.1*
112 %{_mandir}/man1/valgrind-listener.1*
113 %{_mandir}/man1/vgdb.1*
114 %{_pkgconfigdir}/valgrind.pc
This page took 0.059846 seconds and 2 git commands to generate.