]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
103db65c9a58962d2206a5ca0530444254293cf6
[packages/valgrind.git] / valgrind.spec
1 #%define                _snap   20040612
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        2.2.0
6 Release:        1
7 License:        GPL
8 Group:          Development/Tools
9 Source0:        http://developer.kde.org/~sewardj/valgrind-%{version}.tar.bz2
10 # Source0-md5:  30dc51f6fc94751b90b04af9c2e2c656
11 URL:            http://valgrind.kde.org/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 # Needs libc.a
15 BuildRequires:  glibc-static
16 Conflicts:      valgrind-calltree
17 ExclusiveArch:  %{ix86}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # Valgrind binaries should _never_ be stripped
21 %define         no_install_post_strip   1
22
23 # Same name as libpthread
24 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
25
26 %description
27 Valgrind is a GPL'd system for debugging and profiling x86-Linux
28 programs. With the tools that come with Valgrind, you can
29 automatically detect many memory management and threading bugs,
30 avoiding hours of frustrating bug-hunting, making your programs more
31 stable. You can also perform detailed profiling to help speed up your
32 programs.
33
34 %description -l pl
35 Valgrind jest systemem s³u¿±cym do odpluskwiania i profilowania
36 programów na Linuksie uruchomionym na procesorach x86. U¿ywaj±c
37 dostarczanych z nim narzêdzi mo¿na automatycznie wykrywaæ wiele
38 b³êdów zwi±zanych z zarz±dzaniem pamiêci± i w±tkowaniem, dziêki
39 czemu unika siê frustruj±cego polowania na b³êdy, a tak¿e czyni
40 siê programy bardziej stabilnymi. Mo¿liwe jest równie¿ dok³adne
41 profilowanie, dziêki któremu programy zaczn± szybciej pracowaæ.
42
43 %prep
44 %setup -q
45
46 %build
47 %{__aclocal}
48 %{__autoheader}
49 %{__autoconf}
50 %{__automake}
51 %configure \
52         LDFLAGS="" # no strip!
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 strip $RPM_BUILD_ROOT%{_libdir}/%{name}/hp2ps
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README README_MISSING_SYSCALL_OR_IOCTL TODO
69 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
70 %attr(755,root,root) %{_bindir}/*
71 %dir %{_libdir}/%{name}
72 %attr(755,root,root) %{_libdir}/%{name}/*.so
73 %{_libdir}/%{name}/*.so.*
74 %attr(755,root,root) %{_libdir}/%{name}/hp2ps
75 %attr(755,root,root) %{_libdir}/%{name}/stage2
76 %{_libdir}/%{name}/*.supp
77 %{_includedir}/*
78 %{_pkgconfigdir}/*.pc
This page took 0.067552 seconds and 3 git commands to generate.