]> git.pld-linux.org Git - packages/valgrind.git/blame_incremental - valgrind.spec
- new spec
[packages/valgrind.git] / valgrind.spec
... / ...
CommitLineData
1Summary: An open-source memory debugger for x86-GNU/Linux
2Name: valgrind
3Version: 1.0.0
4Release: 1
5License: GPL
6ExclusiveArch: %{ix86}
7Group: Networking/Utilities
8Source0: http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
9URL: http://developer.kde.org/~sewardj/
10BuildRequires: autoconf
11BuildRequires: automake
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14# valgrind binaries should _never_ be stripped
15# anyone knows better solution?
16%define debug 1
17
18%description
19Valgrind is a GPL'd tool to help you find memory-management problems
20in your programs. When a program is run under Valgrind's supervision,
21all reads and writes of memory are checked, and calls to
22malloc/new/free/delete are intercepted. As a result, Valgrind can
23detect problems such as:
24
25- Use of uninitialised memory
26- Reading/writing memory after it has been free'd
27- Reading/writing off the end of malloc'd blocks
28- Reading/writing inappropriate areas on the stack
29- Memory leaks -- where pointers to malloc'd blocks are lost forever
30- Passing of uninitialised and/or unaddressible memory to system calls
31- Mismatched use of malloc/new/new [] vs free/delete/delete []
32- Some misuses of the POSIX pthreads API
33
34%prep
35%setup -q
36
37%build
38rm -f missing
39aclocal
40%{__autoconf}
41%{__automake}
42%configure
43%{__make}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48%{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
56%doc README README_MISSING_SYSCALL_OR_IOCTL TODO
57%doc docs/*.html
58%attr(755,root,root) %{_bindir}/*
59%{_includedir}/*
60%{_libdir}/%{name}
This page took 0.032264 seconds and 4 git commands to generate.