]> git.pld-linux.org Git - packages/valgrind.git/blame_incremental - valgrind.spec
- automake 1.11.2 compatibility patch
[packages/valgrind.git] / valgrind.spec
... / ...
CommitLineData
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
3Summary: An open-source memory debugger
4Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
5Name: valgrind
6Version: 3.7.0
7Release: 2
8License: GPL
9Group: Development/Tools
10Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11# Source0-md5: a855fda56edf05614f099dca316d1775
12Patch0: %{name}-debuginfo.patch
13Patch1: %{name}-native-cpuid.patch
14Patch2: %{name}-automake-1.11.2.patch
15URL: http://valgrind.org/
16BuildRequires: autoconf
17BuildRequires: automake
18BuildRequires: gcc >= 5:3.0
19# Needs libc.a
20BuildRequires: glibc-devel >= 6:2.2
21BuildRequires: glibc-devel < 6:2.15
22BuildRequires: glibc-static
23BuildRequires: libgomp-devel
24BuildRequires: libstdc++-devel
25Obsoletes: valgrind-callgrind
26Obsoletes: valgrind-calltree
27ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define _noautostrip .*/vgpreload.*\\.so
31# ld portion broken
32%undefine with_ccache
33
34%description
35Valgrind is a GPL'd system for debugging and profiling Linux programs.
36With the tools that come with Valgrind, you can automatically detect
37many memory management and threading bugs, avoiding hours of
38frustrating bug-hunting, making your programs more stable. You can
39also perform detailed profiling to help speed up your programs.
40
41%description -l pl.UTF-8
42Valgrind jest systemem służącym do odpluskwiania i profilowania
43programów na Linuksie. Używając dostarczanych z nim narzędzi można
44automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
45i wątkowaniem, dzięki czemu unika się frustrującego polowania na
46błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
47również dokładne profilowanie, dzięki któremu programy zaczną szybciej
48pracować.
49
50%prep
51%setup -q
52%patch0
53%patch1 -p1
54%patch2 -p0
55
56sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
57
58%build
59%{__aclocal}
60%{__autoheader}
61%{__autoconf}
62%{__automake}
63
64ac_cv_path_GDB=/usr/bin/gdb \
65%configure \
66 CC=gcc \
67 --enable-tls \
68%if %{_lib} != "lib"
69 --enable-only64bit \
70%endif
71 LDFLAGS="" # no strip!
72
73%{__make}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
82mv docs/index.pdf docs/valgrind_manual.pdf
83mv docs/index.ps docs/valgrind_manual.ps
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
91%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
92%attr(755,root,root) %{_bindir}/callgrind_annotate
93%attr(755,root,root) %{_bindir}/callgrind_control
94%attr(755,root,root) %{_bindir}/cg_annotate
95%attr(755,root,root) %{_bindir}/cg_diff
96%attr(755,root,root) %{_bindir}/cg_merge
97%attr(755,root,root) %{_bindir}/ms_print
98%attr(755,root,root) %{_bindir}/valgrind
99%attr(755,root,root) %{_bindir}/valgrind-listener
100%attr(755,root,root) %{_bindir}/vgdb
101%dir %{_libdir}/%{name}
102%attr(755,root,root) %{_libdir}/%{name}/*-linux
103%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
104%{_libdir}/%{name}/*.xml
105%{_libdir}/%{name}/default.supp
106%{_libdir}/%{name}/lib*-linux.a
107%{_includedir}/valgrind
108%{_mandir}/man1/callgrind_annotate.1*
109%{_mandir}/man1/callgrind_control.1*
110%{_mandir}/man1/cg_annotate.1*
111%{_mandir}/man1/ms_print.1*
112%{_mandir}/man1/valgrind.1*
113%{_pkgconfigdir}/valgrind.pc
This page took 0.074309 seconds and 4 git commands to generate.