]> git.pld-linux.org Git - packages/valgrind.git/blame_incremental - valgrind.spec
- Valgrind insisted on redirecting the 'strlen' symbol in /lib/ld-linux.so.2,
[packages/valgrind.git] / valgrind.spec
... / ...
CommitLineData
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
3Summary: An open-source memory debugger
4Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
5Name: valgrind
6Version: 3.7.0
7Release: 2
8License: GPL
9Group: Development/Tools
10Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
11# Source0-md5: a855fda56edf05614f099dca316d1775
12Patch0: %{name}-debuginfo.patch
13Patch1: %{name}-native-cpuid.patch
14Patch2: %{name}-automake-1.11.2.patch
15Patch3: %{name}-ld_linux_strlen.patch
16URL: http://valgrind.org/
17BuildRequires: autoconf
18BuildRequires: automake
19BuildRequires: gcc >= 5:3.0
20# Needs libc.a
21BuildRequires: glibc-devel >= 6:2.2
22BuildRequires: glibc-devel < 6:2.15
23BuildRequires: glibc-static
24BuildRequires: libgomp-devel
25BuildRequires: libstdc++-devel
26Obsoletes: valgrind-callgrind
27Obsoletes: valgrind-calltree
28ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define _noautostrip .*/vgpreload.*\\.so
32# ld portion broken
33%undefine with_ccache
34
35%description
36Valgrind is a GPL'd system for debugging and profiling Linux programs.
37With the tools that come with Valgrind, you can automatically detect
38many memory management and threading bugs, avoiding hours of
39frustrating bug-hunting, making your programs more stable. You can
40also perform detailed profiling to help speed up your programs.
41
42%description -l pl.UTF-8
43Valgrind jest systemem służącym do odpluskwiania i profilowania
44programów na Linuksie. Używając dostarczanych z nim narzędzi można
45automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
46i wątkowaniem, dzięki czemu unika się frustrującego polowania na
47błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
48również dokładne profilowanie, dzięki któremu programy zaczną szybciej
49pracować.
50
51%prep
52%setup -q
53%patch0
54%patch1 -p1
55%patch2 -p0
56%patch3 -p1
57
58sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
59
60%build
61%{__aclocal}
62%{__autoheader}
63%{__autoconf}
64%{__automake}
65
66ac_cv_path_GDB=/usr/bin/gdb \
67%configure \
68 CC=gcc \
69 --enable-tls \
70%if %{_lib} != "lib"
71 --enable-only64bit \
72%endif
73 LDFLAGS="" # no strip!
74
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
84mv docs/index.pdf docs/valgrind_manual.pdf
85mv docs/index.ps docs/valgrind_manual.ps
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
92%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
93%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
94%attr(755,root,root) %{_bindir}/callgrind_annotate
95%attr(755,root,root) %{_bindir}/callgrind_control
96%attr(755,root,root) %{_bindir}/cg_annotate
97%attr(755,root,root) %{_bindir}/cg_diff
98%attr(755,root,root) %{_bindir}/cg_merge
99%attr(755,root,root) %{_bindir}/ms_print
100%attr(755,root,root) %{_bindir}/valgrind
101%attr(755,root,root) %{_bindir}/valgrind-listener
102%attr(755,root,root) %{_bindir}/vgdb
103%dir %{_libdir}/%{name}
104%attr(755,root,root) %{_libdir}/%{name}/*-linux
105%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
106%{_libdir}/%{name}/*.xml
107%{_libdir}/%{name}/default.supp
108%{_libdir}/%{name}/lib*-linux.a
109%{_includedir}/valgrind
110%{_mandir}/man1/callgrind_annotate.1*
111%{_mandir}/man1/callgrind_control.1*
112%{_mandir}/man1/cg_annotate.1*
113%{_mandir}/man1/ms_print.1*
114%{_mandir}/man1/valgrind.1*
115%{_pkgconfigdir}/valgrind.pc
This page took 0.041885 seconds and 4 git commands to generate.