]> git.pld-linux.org Git - packages/valgrind.git/blame_incremental - valgrind.spec
- up to 3.14.0; enabled lto (wchich usually makes gdb unusable on binary but binary...
[packages/valgrind.git] / valgrind.spec
... / ...
CommitLineData
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
3#
4# Conditional build:
5%bcond_with mpi # MPI wrapper module
6#
7Summary: An open-source memory debugger
8Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
9Name: valgrind
10Version: 3.14.0
11Release: 1
12License: GPL v2+
13Group: Development/Tools
14Source0: https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
15# Source0-md5: 74175426afa280184b62591b58c671b3
16Patch0: %{name}-native-cpuid.patch
17Patch1: %{name}-ld_linux_strlen.patch
18URL: http://valgrind.org/
19BuildRequires: autoconf >= 2.50
20BuildRequires: automake >= 1:1.10
21BuildRequires: gcc >= 5:3.0
22%ifarch x32
23BuildRequires: gcc-multilib-64 >= 5:3.0
24%endif
25# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
26BuildRequires: glibc-devel >= 6:2.2
27BuildRequires: libgomp-devel
28BuildRequires: libstdc++-devel
29%{?with_mpi:BuildRequires: mpi-devel}
30Obsoletes: valgrind-callgrind
31Obsoletes: valgrind-calltree
32ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x x32
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define _noautostrip .*/vgpreload.*\\.so
36%define filterout_c -fstack-protector-strong
37# ld portion broken
38%undefine with_ccache
39
40%description
41Valgrind is a GPL'd system for debugging and profiling Linux programs.
42With the tools that come with Valgrind, you can automatically detect
43many memory management and threading bugs, avoiding hours of
44frustrating bug-hunting, making your programs more stable. You can
45also perform detailed profiling to help speed up your programs.
46
47%description -l pl.UTF-8
48Valgrind jest systemem służącym do odpluskwiania i profilowania
49programów na Linuksie. Używając dostarczanych z nim narzędzi można
50automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
51i wątkowaniem, dzięki czemu unika się frustrującego polowania na
52błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
53również dokładne profilowanie, dzięki któremu programy zaczną szybciej
54pracować.
55
56%prep
57%setup -q
58%patch0 -p1
59%patch1 -p1
60
61sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
62
63%build
64%{__aclocal}
65%{__autoconf}
66%{__autoheader}
67%{__automake}
68
69ac_cv_path_GDB=/usr/bin/gdb \
70%configure \
71 CC=gcc \
72 --enable-tls \
73%if %{_lib} != "lib"
74 --enable-only64bit \
75%endif \
76 --enable-lto=yes \
77 LDFLAGS="" # no strip!
78
79%{__make}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84%{__make} install \
85 DESTDIR=$RPM_BUILD_ROOT
86
87%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
88cp -p docs/index.pdf docs/valgrind_manual.pdf
89cp -p docs/index.ps docs/valgrind_manual.ps
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
96%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
97%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
98%attr(755,root,root) %{_bindir}/callgrind_annotate
99%attr(755,root,root) %{_bindir}/callgrind_control
100%attr(755,root,root) %{_bindir}/cg_annotate
101%attr(755,root,root) %{_bindir}/cg_diff
102%attr(755,root,root) %{_bindir}/cg_merge
103%attr(755,root,root) %{_bindir}/ms_print
104%attr(755,root,root) %{_bindir}/valgrind
105%attr(755,root,root) %{_bindir}/valgrind-di-server
106%attr(755,root,root) %{_bindir}/valgrind-listener
107%attr(755,root,root) %{_bindir}/vgdb
108%dir %{_libdir}/%{name}
109%attr(755,root,root) %{_libdir}/%{name}/*-linux
110%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
111%if %{with mpi}
112# TODO: subpackage?
113%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
114%endif
115%{_libdir}/%{name}/*.xml
116%{_libdir}/%{name}/default.supp
117%{_libdir}/%{name}/lib*-linux.a
118%{_includedir}/valgrind
119%{_mandir}/man1/callgrind_annotate.1*
120%{_mandir}/man1/callgrind_control.1*
121%{_mandir}/man1/cg_annotate.1*
122%{_mandir}/man1/cg_diff.1*
123%{_mandir}/man1/cg_merge.1*
124%{_mandir}/man1/ms_print.1*
125%{_mandir}/man1/valgrind.1*
126%{_mandir}/man1/valgrind-listener.1*
127%{_mandir}/man1/vgdb.1*
128%{_pkgconfigdir}/valgrind.pc
This page took 0.022493 seconds and 4 git commands to generate.