]> git.pld-linux.org Git - packages/valgrind.git/blame - valgrind.spec
- rel 4; glibc 2.15 support
[packages/valgrind.git] / valgrind.spec
CommitLineData
23a3ecde
AM
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
9fd66024 3Summary: An open-source memory debugger
81257f7b 4Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
cccdc142 5Name: valgrind
23a3ecde 6Version: 3.7.0
f0ea88bd 7Release: 4
cccdc142 8License: GPL
c5631d09 9Group: Development/Tools
4ff172b5 10Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
23a3ecde 11# Source0-md5: a855fda56edf05614f099dca316d1775
a75fc68f 12Patch0: %{name}-debuginfo.patch
6a71ccd9 13Patch1: %{name}-native-cpuid.patch
3a93a74d 14Patch2: %{name}-automake-1.11.2.patch
24db2994 15Patch3: %{name}-ld_linux_strlen.patch
f0ea88bd 16Patch4: %{name}-glibc.patch
e0752a56 17URL: http://valgrind.org/
cccdc142
JK
18BuildRequires: autoconf
19BuildRequires: automake
54375cc9 20BuildRequires: gcc >= 5:3.0
c3075ce6 21# Needs libc.a
3a93a74d 22BuildRequires: glibc-devel >= 6:2.2
f0ea88bd 23BuildRequires: glibc-devel < 6:2.16
c3075ce6 24BuildRequires: glibc-static
1abb996b 25BuildRequires: libgomp-devel
54375cc9 26BuildRequires: libstdc++-devel
11f54799 27Obsoletes: valgrind-callgrind
28Obsoletes: valgrind-calltree
54375cc9 29ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
cccdc142
JK
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
9fd66024 32%define _noautostrip .*/vgpreload.*\\.so
79e9a7b2
ER
33# ld portion broken
34%undefine with_ccache
a803692b 35
cccdc142 36%description
9fd66024 37Valgrind is a GPL'd system for debugging and profiling Linux programs.
38With the tools that come with Valgrind, you can automatically detect
6b924c54
JP
39many memory management and threading bugs, avoiding hours of
40frustrating bug-hunting, making your programs more stable. You can
41also perform detailed profiling to help speed up your programs.
cccdc142 42
f86a5f7e
JR
43%description -l pl.UTF-8
44Valgrind jest systemem służącym do odpluskwiania i profilowania
45programów na Linuksie. Używając dostarczanych z nim narzędzi można
6b924c54
JP
46automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
47i wątkowaniem, dzięki czemu unika się frustrującego polowania na
48błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
49również dokładne profilowanie, dzięki któremu programy zaczną szybciej
50pracować.
a3b1e5f5 51
cccdc142 52%prep
4ff172b5
JP
53%setup -q
54%patch0
1dc3004f 55%patch1 -p1
3a93a74d 56%patch2 -p0
24db2994 57%patch3 -p1
f0ea88bd 58%patch4 -p0
68bd9ee3
AM
59
60sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
1437dfea 61
cccdc142 62%build
c594fc71 63%{__aclocal}
1437dfea 64%{__autoheader}
cccdc142
JK
65%{__autoconf}
66%{__automake}
e7968d53
PS
67
68ac_cv_path_GDB=/usr/bin/gdb \
9eb4ec2b 69%configure \
23a3ecde 70 CC=gcc \
1abb996b 71 --enable-tls \
68bd9ee3
AM
72%if %{_lib} != "lib"
73 --enable-only64bit \
74%endif
9eb4ec2b 75 LDFLAGS="" # no strip!
e7968d53 76
cccdc142
JK
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
a273c144
JB
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
cccdc142 84
54375cc9 85%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
6b924c54
JP
86mv docs/index.pdf docs/valgrind_manual.pdf
87mv docs/index.ps docs/valgrind_manual.ps
88
cccdc142
JK
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
a15e5165 94%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
6b924c54 95%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
54375cc9
JB
96%attr(755,root,root) %{_bindir}/callgrind_annotate
97%attr(755,root,root) %{_bindir}/callgrind_control
98%attr(755,root,root) %{_bindir}/cg_annotate
99%attr(755,root,root) %{_bindir}/cg_diff
100%attr(755,root,root) %{_bindir}/cg_merge
101%attr(755,root,root) %{_bindir}/ms_print
102%attr(755,root,root) %{_bindir}/valgrind
103%attr(755,root,root) %{_bindir}/valgrind-listener
104%attr(755,root,root) %{_bindir}/vgdb
f1c36ddf 105%dir %{_libdir}/%{name}
1abb996b 106%attr(755,root,root) %{_libdir}/%{name}/*-linux
54375cc9 107%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
23a3ecde 108%{_libdir}/%{name}/*.xml
54375cc9
JB
109%{_libdir}/%{name}/default.supp
110%{_libdir}/%{name}/lib*-linux.a
111%{_includedir}/valgrind
112%{_mandir}/man1/callgrind_annotate.1*
113%{_mandir}/man1/callgrind_control.1*
114%{_mandir}/man1/cg_annotate.1*
115%{_mandir}/man1/ms_print.1*
116%{_mandir}/man1/valgrind.1*
117%{_pkgconfigdir}/valgrind.pc
This page took 0.054802 seconds and 4 git commands to generate.