]> git.pld-linux.org Git - packages/valgrind.git/blame - valgrind.spec
- release 3
[packages/valgrind.git] / valgrind.spec
CommitLineData
23a3ecde
AM
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
9fd66024 3Summary: An open-source memory debugger
81257f7b 4Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
cccdc142 5Name: valgrind
23a3ecde 6Version: 3.7.0
4ed0a079 7Release: 3
cccdc142 8License: GPL
c5631d09 9Group: Development/Tools
4ff172b5 10Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
23a3ecde 11# Source0-md5: a855fda56edf05614f099dca316d1775
a75fc68f 12Patch0: %{name}-debuginfo.patch
6a71ccd9 13Patch1: %{name}-native-cpuid.patch
3a93a74d 14Patch2: %{name}-automake-1.11.2.patch
24db2994 15Patch3: %{name}-ld_linux_strlen.patch
e0752a56 16URL: http://valgrind.org/
cccdc142
JK
17BuildRequires: autoconf
18BuildRequires: automake
54375cc9 19BuildRequires: gcc >= 5:3.0
c3075ce6 20# Needs libc.a
3a93a74d
JK
21BuildRequires: glibc-devel >= 6:2.2
22BuildRequires: glibc-devel < 6:2.15
c3075ce6 23BuildRequires: glibc-static
1abb996b 24BuildRequires: libgomp-devel
54375cc9 25BuildRequires: libstdc++-devel
11f54799 26Obsoletes: valgrind-callgrind
27Obsoletes: valgrind-calltree
54375cc9 28ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
cccdc142
JK
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
9fd66024 31%define _noautostrip .*/vgpreload.*\\.so
79e9a7b2
ER
32# ld portion broken
33%undefine with_ccache
a803692b 34
cccdc142 35%description
9fd66024 36Valgrind is a GPL'd system for debugging and profiling Linux programs.
37With the tools that come with Valgrind, you can automatically detect
6b924c54
JP
38many memory management and threading bugs, avoiding hours of
39frustrating bug-hunting, making your programs more stable. You can
40also perform detailed profiling to help speed up your programs.
cccdc142 41
f86a5f7e
JR
42%description -l pl.UTF-8
43Valgrind jest systemem służącym do odpluskwiania i profilowania
44programów na Linuksie. Używając dostarczanych z nim narzędzi można
6b924c54
JP
45automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
46i wątkowaniem, dzięki czemu unika się frustrującego polowania na
47błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
48również dokładne profilowanie, dzięki któremu programy zaczną szybciej
49pracować.
a3b1e5f5 50
cccdc142 51%prep
4ff172b5
JP
52%setup -q
53%patch0
1dc3004f 54%patch1 -p1
3a93a74d 55%patch2 -p0
24db2994 56%patch3 -p1
68bd9ee3
AM
57
58sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
1437dfea 59
cccdc142 60%build
c594fc71 61%{__aclocal}
1437dfea 62%{__autoheader}
cccdc142
JK
63%{__autoconf}
64%{__automake}
e7968d53
PS
65
66ac_cv_path_GDB=/usr/bin/gdb \
9eb4ec2b 67%configure \
23a3ecde 68 CC=gcc \
1abb996b 69 --enable-tls \
68bd9ee3
AM
70%if %{_lib} != "lib"
71 --enable-only64bit \
72%endif
9eb4ec2b 73 LDFLAGS="" # no strip!
e7968d53 74
cccdc142
JK
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
a273c144
JB
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
cccdc142 82
54375cc9 83%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
6b924c54
JP
84mv docs/index.pdf docs/valgrind_manual.pdf
85mv docs/index.ps docs/valgrind_manual.ps
86
cccdc142
JK
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
a15e5165 92%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
6b924c54 93%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
54375cc9
JB
94%attr(755,root,root) %{_bindir}/callgrind_annotate
95%attr(755,root,root) %{_bindir}/callgrind_control
96%attr(755,root,root) %{_bindir}/cg_annotate
97%attr(755,root,root) %{_bindir}/cg_diff
98%attr(755,root,root) %{_bindir}/cg_merge
99%attr(755,root,root) %{_bindir}/ms_print
100%attr(755,root,root) %{_bindir}/valgrind
101%attr(755,root,root) %{_bindir}/valgrind-listener
102%attr(755,root,root) %{_bindir}/vgdb
f1c36ddf 103%dir %{_libdir}/%{name}
1abb996b 104%attr(755,root,root) %{_libdir}/%{name}/*-linux
54375cc9 105%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
23a3ecde 106%{_libdir}/%{name}/*.xml
54375cc9
JB
107%{_libdir}/%{name}/default.supp
108%{_libdir}/%{name}/lib*-linux.a
109%{_includedir}/valgrind
110%{_mandir}/man1/callgrind_annotate.1*
111%{_mandir}/man1/callgrind_control.1*
112%{_mandir}/man1/cg_annotate.1*
113%{_mandir}/man1/ms_print.1*
114%{_mandir}/man1/valgrind.1*
115%{_pkgconfigdir}/valgrind.pc
This page took 0.105597 seconds and 4 git commands to generate.