]> git.pld-linux.org Git - packages/vacm.git/commitdiff
- rel 6; fixed openssl build but there is jadetex problem auto/th/vacm-2.0.5a-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 16:47:26 +0000 (18:47 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 16:47:26 +0000 (18:47 +0200)
openssl.patch [new file with mode: 0644]
vacm.spec

diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..7d00f0b
--- /dev/null
@@ -0,0 +1,44 @@
+--- vacm-2.0.5a/nexxus/nexxus_modules/sys_stat/vacm_sys_stat_proxy.c~  2001-04-05 18:40:55.000000000 +0200
++++ vacm-2.0.5a/nexxus/nexxus_modules/sys_stat/vacm_sys_stat_proxy.c   2018-09-20 18:37:55.547099196 +0200
+@@ -190,7 +190,7 @@ char       **argv;
+     printf("Private key does not match the certificate public key\n");
+               exit(-1);
+     }
+-  meth = SSLv2_client_method();
++  meth = SSLv23_client_method();
+   client_ctx = SSL_CTX_new(meth);
+   if (!client_ctx)
+     {
+--- vacm-2.0.5a/libvacmclient/connections.c~   2001-10-03 15:36:27.000000000 +0200
++++ vacm-2.0.5a/libvacmclient/connections.c    2018-09-20 18:38:11.114233001 +0200
+@@ -135,7 +135,7 @@ int api_nexxus_connect(char *addr,
+       if (!ctx)
+               {
+               SSLeay_add_ssl_algorithms();
+-              meth = SSLv2_client_method();
++              meth = SSLv23_client_method();
+               SSL_load_error_strings();
+               ctx = SSL_CTX_new(meth);
+               }
+--- vacm-2.0.5a/nexxus/nexxus_modules/sys_stat/sys_stat.c~     2000-09-01 17:36:25.000000000 +0200
++++ vacm-2.0.5a/nexxus/nexxus_modules/sys_stat/sys_stat.c      2018-09-20 18:38:23.084592208 +0200
+@@ -103,7 +103,7 @@ char       **argv;
+ #ifdef OPENSSL
+   SSL_load_error_strings();
+       SSLeay_add_ssl_algorithms();
+-  meth = SSLv2_client_method();
++  meth = SSLv23_client_method();
+   ctx = SSL_CTX_new(meth);
+       if (!ctx)
+               {
+--- vacm-2.0.5a/nexxus/nexxus_modules/user_adm/user_adm.c~     2001-02-28 05:20:55.000000000 +0100
++++ vacm-2.0.5a/nexxus/nexxus_modules/user_adm/user_adm.c      2018-09-20 18:38:33.418235634 +0200
+@@ -94,7 +94,7 @@ char **argv;
+               }
+       SSLeay_add_ssl_algorithms();
+-  meth = SSLv2_client_method();
++  meth = SSLv23_client_method();
+   SSL_load_error_strings();
+   ctx = SSL_CTX_new(meth);
+       if (!ctx)
index 55b127d6fdf91ff8bbdf02a568e7d336bf5c2dae..67cfe018b42ef34eaf5d8d56584cf80ea62e41bc 100644 (file)
--- a/vacm.spec
+++ b/vacm.spec
@@ -11,7 +11,7 @@ Summary:      System for monitoring and management of a cluster of nodes
 Summary(pl.UTF-8):     System do monitorowania i zarządzania klastrem węzłów
 Name:          vacm
 Version:       2.0.5a
-Release:       5
+Release:       6
 License:       LGPL v2.1+ (library), GPL v2+ (the rest)
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/vacm/%{name}-%{version}.tar.gz
@@ -20,6 +20,7 @@ Patch0:               %{name}-build.patch
 Patch1:                %{name}-sh.patch
 Patch2:                %{name}-link.patch
 Patch3:                dvips.patch
+Patch4:                openssl.patch
 URL:           http://vacm.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -194,6 +195,7 @@ Dokumentacja do VACM-a.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %{__sed} -i -e 's/\r//g' nexxus/nexxus_modules/emp/include/iana_list.h
 
This page took 0.193133 seconds and 4 git commands to generate.