]> git.pld-linux.org Git - packages/vacm.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 5 Sep 2013 19:27:10 +0000 (21:27 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 5 Sep 2013 19:27:10 +0000 (21:27 +0200)
- sh patch removed bashisms from configure
- build patch fixes some C/C++ errors detected by modern compilers

vacm-build.patch [new file with mode: 0644]
vacm-sh.patch [new file with mode: 0644]
vacm.spec [new file with mode: 0644]

diff --git a/vacm-build.patch b/vacm-build.patch
new file mode 100644 (file)
index 0000000..dfd2097
--- /dev/null
@@ -0,0 +1,305 @@
+--- vacm-2.0.5a/clients/flim/src/group.c.orig  2000-08-08 00:34:44.000000000 +0200
++++ vacm-2.0.5a/clients/flim/src/group.c       2013-09-03 21:27:20.023310507 +0200
+@@ -55,7 +55,7 @@
+                        }
+                   }
+              }
+-           done:           
++           done: ;
+         }
+       else if (next_nexxus)
+         {
+--- vacm-2.0.5a/clients/flim/plugins/toolbar.p.c.orig  2001-04-20 20:15:01.000000000 +0200
++++ vacm-2.0.5a/clients/flim/plugins/toolbar.p.c       2013-09-04 17:45:31.903576463 +0200
+@@ -395,7 +395,7 @@
+                      FILM_COMMS_GET_REPLY;
+                   }
+                 FILM_COMMS_REPLY_END;
+-                error:
++                error: ;
+              }
+         }
+      }
+@@ -445,7 +445,7 @@
+                      FILM_COMMS_GET_REPLY;
+                   }
+                 FILM_COMMS_REPLY_END;
+-                error:
++                error: ;
+              }
+         }
+      }
+@@ -555,7 +555,7 @@
+                      FILM_COMMS_GET_REPLY;
+                   }
+                 FILM_COMMS_REPLY_END;
+-                error:
++                error: ;
+              }
+         }
+      }
+@@ -601,7 +601,7 @@
+                      FILM_COMMS_GET_REPLY;
+                   }
+                 FILM_COMMS_REPLY_END;
+-                error:
++                error: ;
+              }
+         }
+      }
+--- vacm-2.0.5a/clients/hoover/libgessie/PanelContainer.C.orig 2000-11-28 23:18:14.000000000 +0100
++++ vacm-2.0.5a/clients/hoover/libgessie/PanelContainer.C      2013-09-04 21:08:55.353064333 +0200
+@@ -200,8 +200,8 @@
+         PanelContainer *newRootNotebook = new PanelContainer();
+         gtk_table_attach(GTK_TABLE(rootTable),newRootNotebook->baseWidget(),
+                          0,1,0,1,
+-                         (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                         (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                         (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                         (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+               /*
+                *      Do the movin'
+@@ -253,7 +253,7 @@
+       gtk_drag_source_set(event_box,GDK_BUTTON1_MASK,
+                           panel_container_target_table, 
+                           n_panel_container_targets,
+-                          (enum GdkDragAction) (GDK_ACTION_MOVE | GDK_ACTION_COPY));
++                          (GdkDragAction) (GDK_ACTION_MOVE | GDK_ACTION_COPY));
+       gtk_signal_connect(GTK_OBJECT(event_box), "drag_begin",
+                                  GTK_SIGNAL_FUNC (drag_begin_callback),
+                                  (gpointer) w);
+@@ -272,14 +272,14 @@
+       gtk_widget_show(icon);
+       gtk_table_attach(GTK_TABLE(table),icon,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL),
+-                       (enum GtkAttachOptions)(GTK_FILL),0,0);
++                       (GtkAttachOptions)(GTK_FILL),
++                       (GtkAttachOptions)(GTK_FILL),0,0);
+       GtkWidget *label = gtk_label_new(name);
+       gtk_widget_show(label);
+       gtk_table_attach(GTK_TABLE(table),label,1,2,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL),
+-                       (enum GtkAttachOptions)(GTK_FILL),0,0);
++                       (GtkAttachOptions)(GTK_FILL),
++                       (GtkAttachOptions)(GTK_FILL),0,0);
+       gtk_widget_show(table);
+       gtk_widget_show(toptable);
+@@ -302,8 +302,8 @@
+       gtk_object_set_data((GtkObject *) event_box,    "panel",(gpointer) p);
+         gtk_object_set_data((GtkObject *) w,          "panel",(gpointer) p);
+       gtk_table_attach(GTK_TABLE(toptable),event_box,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL),
+-                       (enum GtkAttachOptions)(GTK_FILL),0,0);
++                       (GtkAttachOptions)(GTK_FILL),
++                       (GtkAttachOptions)(GTK_FILL),0,0);
+       if (pos == -1) {
+               gtk_notebook_append_page((GtkNotebook *) theBaseWidget, w,
+--- vacm-2.0.5a/clients/hoover/libgessie/GenericListPanel.C.orig       2000-08-05 00:14:34.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/libgessie/GenericListPanel.C    2013-09-04 21:09:56.203061780 +0200
+@@ -55,8 +55,8 @@
+                                               theContentWidget);
+         gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+       gtk_widget_show(theContentWidget);
+ }
+--- vacm-2.0.5a/clients/hoover/libgessie/GenericTextPanel.C.orig       2000-09-16 09:39:22.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/libgessie/GenericTextPanel.C    2013-09-04 21:10:26.023060528 +0200
+@@ -53,8 +53,8 @@
+       assert(scrollw != NULL);
+         gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+       /*
+        *      Simple Text File
+--- vacm-2.0.5a/clients/hoover/libgessie/GenericTreePanel.C.orig       2000-08-02 09:19:43.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/libgessie/GenericTreePanel.C    2013-09-04 21:10:52.553059415 +0200
+@@ -59,8 +59,8 @@
+                                             theContentWidget);
+       gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                        0,0);
+ }
+--- vacm-2.0.5a/clients/hoover/hoover.C.orig   2000-09-29 06:57:26.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/hoover.C        2013-09-04 21:13:20.593053202 +0200
+@@ -349,8 +349,8 @@
+       theRootMenuBar = gsInitMainMenus(nHooverMenuItems,HooverMenuItems);
+         gtk_table_attach(GTK_TABLE(theRootTable),theRootMenuBar,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL),0,0);
+       /*------------------------------------------------------*
+@@ -362,8 +362,8 @@
+                                  FALSE);
+       gtk_table_attach(GTK_TABLE(theRootTable),theRootNotebook->baseWidget(),
+                        0,1,1,2,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+       /*------------------------------------------------------*
+        *                   STATUS BAR                         *
+@@ -373,8 +373,8 @@
+         gtk_widget_show(hbox);
+       gtk_table_attach(GTK_TABLE(theRootTable),hbox,0,1,2,3,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL),0,0);
+       theRootProgressBar = gtk_progress_bar_new();
+       gtk_widget_set_usize(theRootProgressBar,100,-1);
+--- vacm-2.0.5a/clients/hoover/node_prop.C.orig        2000-09-05 20:11:57.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/node_prop.C     2013-09-04 21:13:50.143051963 +0200
+@@ -320,7 +320,7 @@
+         gtk_container_set_border_width(GTK_CONTAINER (hbox),0);
+         gtk_widget_show(hbox);
+         gtk_table_attach(GTK_TABLE(table),hbox,0,2,vertPos,vertPos+1,
+-                         (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                         (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                        GTK_SHRINK,0,0);
+       apply = gtk_button_new_with_label("Apply");
+--- vacm-2.0.5a/clients/hoover/MainListPanel.C.orig    2000-10-08 11:12:53.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/MainListPanel.C 2013-09-04 21:14:24.459717188 +0200
+@@ -81,8 +81,8 @@
+                                             theContentWidget);
+       gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                        0,0);
+       /*--------------------------------------------------------------*
+@@ -93,7 +93,7 @@
+       gtk_container_set_border_width (GTK_CONTAINER (hbox), 0);
+       gtk_widget_show (hbox);
+       gtk_table_attach(GTK_TABLE(theBaseWidget),hbox,0,1,1,2,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                        GTK_SHRINK, 0,0);
+ #define BUTTON_PAD      1
+--- vacm-2.0.5a/clients/hoover/SELListPanel.C.orig     2000-10-08 22:13:34.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/SELListPanel.C  2013-09-04 21:14:52.146382694 +0200
+@@ -124,8 +124,8 @@
+       assert(scrollw != NULL);
+         gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+       if (logType == EV_LOG_TEXT) {
+               /*
+--- vacm-2.0.5a/clients/hoover/HooverControl.C.orig    2000-03-31 12:14:08.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/HooverControl.C 2013-09-04 21:15:17.499714962 +0200
+@@ -60,8 +60,8 @@
+       topPane = gtk_vpaned_new();
+       gtk_widget_show(topPane);
+       gtk_table_attach(GTK_TABLE(theBaseWidget),topPane,0,1,1,2,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+       pane = gtk_vpaned_new();
+       gtk_widget_show(pane);
+--- vacm-2.0.5a/clients/hoover/PropListPanel.C.orig    2000-03-31 12:14:08.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/PropListPanel.C 2013-09-04 21:15:39.693047366 +0200
+@@ -125,8 +125,8 @@
+       assert(scroller != NULL);
+         gtk_table_attach(GTK_TABLE(theBaseWidget),scroller,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+               /*------------------------------*
+                *              CLIST           *
+--- vacm-2.0.5a/clients/hoover/SENSListPanel.C.orig    2000-09-08 17:27:20.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/SENSListPanel.C 2013-09-04 21:25:14.506356576 +0200
+@@ -109,8 +109,8 @@
+       assert(scrollw != NULL);
+         gtk_table_attach(GTK_TABLE(theBaseWidget),scrollw,0,1,0,1,
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
+-                       (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND), 
++                       (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),0,0);
+               /*------------------------------*
+                *              CLIST           *
+--- vacm-2.0.5a/clients/hoover/Auth.C.orig     2000-07-07 20:28:16.000000000 +0200
++++ vacm-2.0.5a/clients/hoover/Auth.C  2013-09-04 21:26:58.293018886 +0200
+@@ -30,18 +30,18 @@
+ #define       ADD_TO_TABLE(a)         \
+       gtk_table_attach(GTK_TABLE(table),a,0,1,vPos,vPos+1,    \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
+ #define       ADD_TO_TABLE2(a,b)      \
+       gtk_table_attach(GTK_TABLE(table),a,b,b+1,vPos,vPos+1,  \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
+ #define       ADD_TO_TABLE3(a,b,c)    \
+       gtk_table_attach(GTK_TABLE(table),a,b,c,vPos,vPos+1,    \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
+-                       (enum GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND), \
++                       (GtkAttachOptions)(GTK_FILL | GTK_EXPAND),0,0)
+ #define       SET_DATA        gtk_object_set_data
+ #define       GET_DATA(a,b)   gtk_object_get_data(GTK_OBJECT(a),b)
+@@ -534,7 +534,7 @@
+         gtk_container_set_border_width (GTK_CONTAINER (hbox1), 0);
+         gtk_widget_show (hbox1);
+         gtk_table_attach(GTK_TABLE(table),hbox1,0,2,vPos,vPos+1,
+-                         (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                         (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                          GTK_SHRINK, 0,0);
+       MK_BUTTON(hbox1,tmp->add_admin,"Add Admin",   doAdminAction,tmp);
+@@ -583,7 +583,7 @@
+         gtk_container_set_border_width (GTK_CONTAINER (hbox2), 0);
+         gtk_widget_show (hbox2);
+         gtk_table_attach(GTK_TABLE(table),hbox2,0,2,vPos,vPos+1,
+-                         (enum GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
++                         (GtkAttachOptions)(GTK_FILL|GTK_EXPAND),
+                          GTK_SHRINK, 0,0);
+       MK_BUTTON(hbox2,tmp->add_addr_rule,"Add Address Rule",doRuleAction,tmp);
diff --git a/vacm-sh.patch b/vacm-sh.patch
new file mode 100644 (file)
index 0000000..110268c
--- /dev/null
@@ -0,0 +1,21 @@
+--- vacm-2.0.5a/configure.in.orig      2001-10-03 15:53:18.000000000 +0200
++++ vacm-2.0.5a/configure.in   2013-09-05 21:19:46.269411152 +0200
+@@ -75,7 +75,8 @@
+ fi
+ if test "x$BUILD_DOCS" = "x1"; then
+-      pushd ${srcdir}/tests
++      oldpwd="$(pwd)"
++      cd ${srcdir}/tests
+       db2dvi docbook-test.sgml 2>&1 | \
+       egrep -q "cannot generate system identifier for public text"
+       if [ test "x$?" = "x0" ]; then
+@@ -84,7 +85,7 @@
+               AC_MSG_WARN(Your stylesheets are probably installed incorrectly.)
+       fi
+       rm -f docbook-test.aux docbook-test.dvi docbook-test.log docbook-test.tex
+-      popd
++      cd "$oldpwd"
+ fi
diff --git a/vacm.spec b/vacm.spec
new file mode 100644 (file)
index 0000000..cac8e0e
--- /dev/null
+++ b/vacm.spec
@@ -0,0 +1,329 @@
+# TODO: PLDify init scripts
+#
+# Conditional build:
+%bcond_with    gnome1  # Hoover GUI client (GTK+ 1.x + GNOME 1.x ZVT based)
+%bcond_without gtk1    # FLIM and Hoover GUI clients (GTK+ 1.x based)
+#
+%if %{without gtk1}
+%undefine      with_gnome1
+%endif
+Summary:       System for monitoring and management of a cluster of nodes
+Summary(pl.UTF-8):     System do monitorowania i zarządzania klastrem węzłów
+Name:          vacm
+Version:       2.0.5a
+Release:       1
+License:       LGPL v2.1+ (library), GPL v2+ (the rest)
+Group:         Applications/System
+Source0:       http://downloads.sourceforge.net/vacm/%{name}-%{version}.tar.gz
+# Source0-md5: 8c68f51bded2a6c268e899013d6420f3
+Patch0:                %{name}-build.patch
+Patch1:                %{name}-sh.patch
+URL:           http://vacm.sourceforge.net/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: docbook-utils
+BuildRequires: gettext-devel
+%{?with_gtk1:BuildRequires:    gtk+-devel >= 1.2.6}
+# libzvt component
+%{?with_gnome1:BuildRequires:  gnome-libs-devel}
+%{?with_gnome1:BuildRequires:  imlib-devel}
+BuildRequires: libstdc++-devel
+BuildRequires: ncurses-devel
+BuildRequires: openjade
+BuildRequires: openssl-devel
+BuildRequires: pam-devel
+BuildRequires: readline-devel
+BuildRequires: texlive-dvips
+Requires:      %{name}-libs = %{version}-%{release}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+VACM (Pronounced VaKuum) is a client/server system allowing monitoring
+and management of a cluster of nodes equipped with Intel(TM)'s
+Intelligent Platform Management Interface (IPMI). Management
+capabilities include device power control, nvram system event log
+download, hardware reset, and remote BIOS console. Monitoring
+capabilities include power system monitoring, chassis intrusion
+monitoring, fan status monitoring, and O/S watchdog monitoring. Since
+the IPMI is implemented in hardware running on separate
+microcontrollers, monitoring a node does *not* impact on the monitored
+node's performance. Furthermore, VACM allows monitoring and management
+of a node from a remote station (via TCP/IP).
+
+%description -l pl.UTF-8
+VACM (wymawiane jak VaKuum) to system klient-serwer umożliwiający
+monitorowanie i zarządzanie klastrem węzłów wyposażonych w interfejs
+Intel(TM) IPMI (Intelligent Platform Management Interface). Możliwości
+zarządzania obejmują sterowanie zasilaniem urządzenia, pobieranie logu
+systemowego z pamięci nvram, sprzętowy reset oraz zdalną konsolę
+BIOS-u. Możliwości monitorowania obejmują monitorowanie zasilania
+systemu, monitorowanie otwarcia obudowy, monitorowanie stanu
+wentylatorów oraz monitorowanie watchdoga systemu operacyjnego. Jako
+że IMPI jest zaimplementowane w sprzęcie działającym na osobnych
+mikrokontrolerach, monitorowanie węzła nie ma wpływu na wydajność
+monitorowanego węzła. Co więcej, VACM pozwala na monitorowanie i
+zarządzanie węzła ze zdalnej maszyny (poprzez TCP/IP).
+
+%package libs
+Summary:       VACM libraries
+Summary(pl.UTF-8):     Biblioteki VACM
+Group:         Libraries
+
+%description libs
+VACM libraries.
+
+%description libs -l pl.UTF
+Biblioteki VACM.
+
+%package devel
+Summary:       Header files for VACM libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek VACM
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description devel
+Header files for VACM libraries.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe bibliotek VACM.
+
+%package static
+Summary:       Static VACM libraries
+Summary(pl.UTF-8):     Statyczne biblioteki VACM
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static VACM libraries.
+
+%description static -l pl.UTF-8
+Statyczne biblioteki VACM.
+
+%package node
+Summary:       VACM client node
+Summary(pl.UTF-8):     Węzeł kliencki VACM
+Group:         Applications/System
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description node
+Package to be installed on VACM client nodes. It contains daemons for
+use with various VACM modules for additional monitoring functionality.
+
+%description node -l pl.UTF-8
+Pakiet do zainstalowania na węzłach klienckich VACM. Zawiera demony
+przeznaczone do użycia z różnymi modułami VACM, dostarczającymi
+dodatkowe funkcje monitorowania.
+
+%package flim
+Summary:       Flim GUI for VACM
+Summary(pl.UTF-8):     Graficzny interfejs Flim do VACM-a
+Group:         X11/Applications
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-sercon = %{version}-%{release}
+Requires:      xterm
+Requires:      gtk+ >= 1.2.6
+
+%description flim
+Flim is a Graphical User Interface (GUI) for VACM which provides
+easy interaction with the nexxus through several plugin modules.
+
+%description flim -l pl.UTF-8
+Flim to graficzny interfejs użytkownika (GUI) do VACM-a, zapewniający
+łatwą interakcję z nexxusem poprzez kilka modułów wtyczek.
+
+%package hoover
+Summary:       Hoover GUI for VACM
+Summary(pl.UTF-8):     Graficzny interfejs Hoover do VACM-a
+Group:         X11/Applications
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description hoover
+Hoover is a Graphical User Interface (GUI) for VACM.
+
+%description hoover -l pl.UTF-8
+Hoover to graficzny interfejs użytkownika (GUI) do VACM-a.
+
+%package sercon
+Summary:       Serial Console Terminal program
+Summary(pl.UTF-8):     Program terminala do konsoli szeregowej
+Group:         Applications/System
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description sercon
+Command-line serial console terminal program to remotely access
+consoles of nodes on a VACM cluster.
+
+%description sercon -l pl.UTF-8
+Działający z linii poleceń program terminala do konsoli szeregowej
+służący do zdalnego dostępu do konsol węzłów w klastrze VACM.
+
+%package vash
+Summary:       VACM command line client
+Summary(pl.UTF-8):     Klient linii poleceń do VACM-a
+Group:         Applications/System
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description vash
+VACM command line client for scripting and low level command-line
+access.
+
+%description vash -l pl.UTF-8
+Klient linii poleceń do wykonywania skryptów oraz niskopoziomowego
+dostępu.
+
+%package doc
+Summary:       VACM documentation
+Summary(pl.UTF-8):     Dokumentacja do VACM-a
+Group:         Documentation
+
+%description doc
+VACM documentation.
+
+%description doc -l pl.UTF-8
+Dokumentacja do VACM-a.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%{__sed} -i -e 's/\r//g' nexxus/nexxus_modules/emp/include/iana_list.h
+
+%build
+cp -f /usr/share/gettext/config.rpath .
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd clients/flim
+%{__gettextize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ../..
+%configure \
+       --enable-pam \
+       --enable-ssl \
+       --enable-static \
+       %{!?with_gnome1:--without-hoover}
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/rc.d/init.d,/etc/logrotate.d,/etc/sysconfig}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       docdir=$RPM_BUILD_ROOT%{_docdir}/vacm-doc-%{version}
+
+install $RPM_BUILD_ROOT%{_libdir}/vacm/exports/* $RPM_BUILD_ROOT%{_sbindir}
+install packaging/RedHat/vacm.init $RPM_BUILD_ROOT/etc/rc.d/init.d/vacm
+install packaging/RedHat/node.init $RPM_BUILD_ROOT/etc/rc.d/init.d/vacm-node
+install packaging/RedHat/vacm-logrotate $RPM_BUILD_ROOT/etc/logrotate.d/vacm
+install packaging/RedHat/vacm.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/vacm
+
+# no external dependencies
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
+
+%find_lang flim
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/sbin/chkconfig --add vacm
+%service vacm restart
+
+%preun
+if [ "$1" = "0" ]; then
+       %service -q vacm stop
+       /sbin/chkconfig --del vacm
+fi
+
+%post node
+/sbin/chkconfig --add vacm-node
+%service vacm-node restart
+
+%preun node
+if [ "$1" = "0" ]; then
+       %service -q vacm-node stop
+       /sbin/chkconfig --del vacm-node
+fi
+
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
+%post  hoover -p /sbin/ldconfig
+%postun        hoover -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc BUGS ChangeLog README_FIRST
+%attr(755,root,root) %{_bindir}/nexxus
+%attr(755,root,root) %{_bindir}/nuptime
+%dir %{_libdir}/vacm
+%dir %{_libdir}/vacm/exports
+%attr(755,root,root) %{_libdir}/vacm/exports/vacm_*
+%dir %{_libdir}/vacm/modules
+%attr(755,root,root) %{_libdir}/vacm/modules/*.loose
+%{_libdir}/vacm/sercon.otp
+%attr(754,root,root) /etc/rc.d/init.d/vacm
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vacm
+%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/vacm
+# FIXME: /etc
+%config(noreplace) %verify(not md5 mtime size) %{_libdir}/vacm/vacm_configuration
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libloose-%{version}.so
+%attr(755,root,root) %{_libdir}/libvacmclient-%{version}.so
+
+%files node
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/vacm_sys_stat_proxy
+%attr(755,root,root) %{_sbindir}/vacm_sys_statd
+%attr(755,root,root) %{_sbindir}/vacm_user_admd
+%attr(754,root,root) /etc/rc.d/init.d/vacm-node
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libloose.so
+%attr(755,root,root) %{_libdir}/libvacmclient.so
+%{_includedir}/libloose.h
+%{_includedir}/vacmclient_api.h
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libloose.a
+%{_libdir}/libvacmclient.a
+
+%if %{with gtk1}
+%files flim -f flim.lang
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/flim
+%dir %{_libdir}/flim
+%attr(755,root,root) %{_libdir}/flim/*.p
+%{_datadir}/flim
+%endif
+
+%if %{with gnome1}
+%files hoover
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/hoover
+%attr(755,root,root) %{_libdir}/libgessie-%{version}.so
+%{_mandir}/man8/hoover.8*
+%endif
+
+%files sercon
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/sercon_terminal
+
+%files vash
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/vash
+
+%files doc
+%defattr(644,root,root,755)
+%{_docdir}/%{name}-doc-%{version}
This page took 0.119308 seconds and 4 git commands to generate.