]> git.pld-linux.org Git - packages/uzbl.git/blob - uzbl.spec
- release 8 (by relup.sh)
[packages/uzbl.git] / uzbl.spec
1 # TODO:
2 # - review python deps
3 #
4 Summary:        A keyboard controlled (modal vim-like bindings, or with modifier keys) browser based on Webkit
5 Summary(hu.UTF-8):      Egy billentyűzettel irányítható (vim-szerű vagy módosító kódok) böngésző Webkit alapokon
6 Summary(pl.UTF-8):      Minimalistyczna przeglądarka w całości obsługiwana przy użyciu klawiatury
7 Name:           uzbl
8 Version:        2013.12.08
9 Release:        8
10 License:        GPL v3
11 Group:          X11/Applications/Networking
12 # git://github.com/Dieterbe/uzbl.git
13 # Source0:      https://github.com/Dieterbe/uzbl/archive/%{version}.tar.gz
14 Source0:        %{name}-%{version}.tar.bz2
15 # Source0-md5:  ff21df4ce77829ec35f3632b5232069d
16 Patch0:         %{name}-build.patch
17 URL:            http://www.uzbl.org/
18 BuildRequires:  gtk+3-devel
19 BuildRequires:  gtk-webkit3-devel >= 1.2.0-4
20 BuildRequires:  libsoup-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  python3-devel
23 BuildRequires:  rpm-pythonprov
24 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
25 Requires:       dmenu
26 Requires:       socat
27 Requires:       xclip
28 Requires:       zenity
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The uzbl browser is a keyboard controlled (modal vim-like bindings, or
33 with modifier keys) browser based on Webkit.
34
35 %description -l hu.UTF-8
36 Egy billentyűzettel irányítható (vim-szerű vagy módosító kódok)
37 böngésző Webkit alapokon.
38
39 %description -l pl.UTF-8
40 uzbl jest przeglądarką, która może być w całości obsługiwana przy
41 użyciu klawiatury. Domyślne ustawienia klawiszy są wzorowane na
42 skrótach klawiszowych programu vim. uzbl wykorzystuje silnik Webkit.
43
44 uzbl sam nie obsługuje zakładek, historii, pobierania plików. Funkcje
45 te są realizowane przez zewnętrzne skrypty. Dzięki temu oraz dzięki
46 ładowanym na życzenie skryptom JavaScript przeglądarka ta jest bardzo
47 elastyczna, konfigurowalna i może być w łatwy sposób rozszerzana.
48
49 %package core
50 Summary:        Uzbl core
51 Summary(pl.UTF-8):      Jądro Uzbl
52 Group:          X11/Applications/Networking
53 Requires:       gtk-webkit >= 1.2.0-4
54 Suggests:       %{name}-event-manager = %{epoch}:%{version}-%{release}
55 Obsoletes:      uzbl-examples
56 Obsoletes:      uzbl-scripts
57
58 %description core
59 Main component of uzbl browser. You also need one of UI components
60 (uzbl or uzbl-tabbed).
61
62 %description core -l pl.UTF-8
63 Jądro przeglądarki uzbl. Aby mieć w pełni funkcjonalną przeglądarkę
64 potrzebujesz jeszcze jeden z interfejsów graficznych: uzbl lub
65 uzbl-tabbed.
66
67 %package event-manager
68 Summary:        Uzbl event manager
69 Summary(pl.UTF-8):      Zarządca zdarzeń dla uzbl
70 Group:          X11/Applications/Networking
71
72 %description event-manager
73 Uzbl event manager.
74
75 %description event-manager -l pl.UTF-8
76 Zarządca zdarzeń dla uzbl.
77
78 %package tabbed
79 Summary:        Tabs for uzbl
80 Summary(hu.UTF-8):      Tabok uzbl-hez
81 Summary(pl.UTF-8):      Taby dla uzbl
82 Group:          X11/Applications/Networking
83 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
84
85 %description tabbed
86 Wrapper for uzbl that provides firefox-style tabs.
87
88 %description tabbed -l hu.UTF-8
89 Egy uzbl-wrapper, amely firefox-stílusú tabok használatát teszi
90 lehetővé.
91
92 %description tabbed -l pl.UTF-8
93 Skrypt, który dodaje do uzbl taby podobne do tych znanych użytkownikom
94 przeglądarki firefox.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
101       bin/uzbl-tabbed \
102       examples/data/scripts/auth.py \
103       examples/data/scripts/per-site-settings.py \
104       examples/data/scripts/scheme.py \
105       examples/data/scripts/uzblcat
106
107 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
108       uzbl/event_manager.py
109
110 %build
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         PREFIX=%{_prefix} \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -r $RPM_BUILD_ROOT%{_datadir}/uzbl/docs
121
122 ln -s %{_bindir}/uzbl-browser $RPM_BUILD_ROOT%{_bindir}/uzbl
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS README docs/*
130 %attr(755,root,root) %{_bindir}/uzbl
131 %attr(755,root,root) %{_bindir}/uzbl-browser
132
133 %files core
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/uzbl-core
136 %dir %{_datadir}/uzbl
137 %dir %{_datadir}/uzbl/examples
138 %{_datadir}/uzbl/examples/config
139 %dir %{_datadir}/uzbl/examples/data
140 %dir %{_datadir}/uzbl/examples/data/scripts
141 #%dir %{_datadir}/uzbl/examples/data/plugins
142 %attr(755,root,root) %{_datadir}/uzbl/examples/data/scripts/*
143 #%attr(755,root,root) %{_datadir}/uzbl/examples/data/plugins/*
144 %{_datadir}/uzbl/examples/data/dforms
145 %{_datadir}/uzbl/examples/data/bookmarks
146 %{_datadir}/uzbl/examples/data/per-site-settings
147 %{_datadir}/uzbl/examples/data/uzbl.png
148
149 %{py3_sitedir}/uzbl*.egg-info
150 %{py3_sitedir}/uzbl
151
152 %files event-manager
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/uzbl-event-manager
155
156 %files tabbed
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/uzbl-tabbed
This page took 0.082692 seconds and 3 git commands to generate.