]> git.pld-linux.org Git - packages/uwsgi.git/commitdiff
fix the 'gevent' plugin auto/th/uwsgi-2.0.1-2
authorJacek Konieczny <jajcus@jajcus.net>
Mon, 24 Feb 2014 16:45:42 +0000 (17:45 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Mon, 24 Feb 2014 16:45:42 +0000 (17:45 +0100)
python plugin would be build second time as 'gevent' due to an error in
spec.

Release: 2

uwsgi.spec

index 40b7a3a81b4978c7de7d1f8fc8b91225e78a67e9..455a01667cffb653c6294daff3206ea9f15eae9c 100644 (file)
 # TODO:
 # - pl desc
 # - apache, module?
+# - 'gevent' plugin depends on python and works only after python plugin is loaded
+#   this can probably be fixed by better linking
+
 Summary:       Fast WSGI server
 Summary(pl.UTF-8):     Szybki serwer WSGI
 Name:          uwsgi
 Version:       2.0.1
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://projects.unbit.it/downloads/%{name}-%{version}.tar.gz
@@ -142,11 +145,11 @@ done
 
 %if %{with python2}
 %{__python} uwsgiconfig.py --plugin plugins/python pld python%{pyver}
-%{__python} uwsgiconfig.py --plugin plugins/python pld gevent_py%{pyver}
+%{__python} uwsgiconfig.py --plugin plugins/gevent pld gevent_py%{pyver}
 %endif
 %if %{with python3}
 %{__python3} uwsgiconfig.py --plugin plugins/python pld python%{py3ver}
-%{__python3} uwsgiconfig.py --plugin plugins/python pld gevent_py%{py3ver}
+%{__python3} uwsgiconfig.py --plugin plugins/gevent pld gevent_py%{py3ver}
 %endif
 
 %install
@@ -165,13 +168,14 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
 
 install *_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 
+# the symlinks must be absolute – otherwise strange things happen in strace
 %if %{with python2}
-ln -s python%{pyver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/python_plugin.so
-ln -s gevent_py%{pyver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/gevent_plugin.so
+ln -s %{_libdir}/%{name}/python%{pyver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/python_plugin.so
+ln -s %{_libdir}/%{name}/gevent_py%{pyver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/gevent_plugin.so
 %endif
 %if %{with python3}
-ln -s python%{py3ver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/python3_plugin.so
-ln -s gevent_py%{py3ver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/gevent_py3_plugin.so
+ln -s %{_libdir}/%{name}/python%{py3ver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/python3_plugin.so
+ln -s %{_libdir}/%{name}/gevent_py%{py3ver}_plugin.so $RPM_BUILD_ROOT%{_libdir}/%{name}/gevent_py3_plugin.so
 %endif
 
 %clean
This page took 0.128809 seconds and 4 git commands to generate.