]> git.pld-linux.org Git - packages/util-vserver.git/blame - util-vserver.spec
- new/raw
[packages/util-vserver.git] / util-vserver.spec
CommitLineData
c4036d6e
AM
1Summary: Linux virtual server utilities
2Name: util-vserver
3Version: 0.24
4Release: 1
5Epoch: 0
6License: GPL
7Group: Base
8URL: http://savannah.nongnu.org/projects/util-vserver/
9Source0: http://savannah.nongnu.org/download/util-vserver/stable.pkg/%version/%name-%version.tar.bz2
10# Source0-md5: 625d6c9bc5a4d2e44eafdf0f619c2153
11BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13%description
14This package provides the components and a framework to setup virtual
15servers. A virtual server runs inside a linux server. It is
16nevertheless highly independent. As such, you can run various services
17with normal configuration. The various vservers can't interact with
18each other and can't interact with services in the main server.
19
20This requires a special kernel supporting the new new_s_context and
21set_ipv4root system call.
22
23%prep
24%setup -q
25
26%build
27%configure \
28 --with-kerneldir=%{_kernelsrcdir}
29%{__make}
30
31
32%install
33rm -rf $RPM_BUILD_ROOT
34
35%{__make} install \
36 DESTDIR=$RPM_BUILD_ROOT
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41%define v_services httpd named portmap sendmail smb sshd xinetd
42%post
43/sbin/chkconfig --add vservers
44/sbin/chkconfig --add rebootmgr
45
46for i in %v_services; do
47 /sbin/chkconfig --add v_$i
48done
49
50
51%preun
52test "$1" != 0 || for i in %v_services; do
53 /sbin/chkconfig --del v_$i
54done
55
56test "$1" != 0 || %{_initrddir}/rebootmgr stop &>/dev/null || :
57test "$1" != 0 || /sbin/chkconfig --del rebootmgr
58test "$1" != 0 || /sbin/chkconfig --del vservers
59
60
61%postun
62test "$1" = 0 || %{_initrddir}/rebootmgr condrestart >/dev/null || :
63
64
65%files
66%defattr(644,root,root,755)
67%doc AUTHORS COPYING ChangeLog NEWS README THANKS
68%doc doc/FAQ.txt
69%{_sbindir}/*
70%{_libdir}/%name
71%{_includedir}/vserver.h
72%{_libdir}/libvserver.a
73%{_mandir}/man8/*
74/etc/rc.d/init.d/*
75%config(noreplace) %{_sysconfdir}/vservers.conf
76%attr(0,root,root) %dir /vservers
77%exclude %_sbindir/newvserver
78%exclude %_mandir/man8/newvserver*
This page took 0.053334 seconds and 4 git commands to generate.