]> git.pld-linux.org Git - packages/util-linux.git/commitdiff
- fix crash on fdisk -l auto/th/util-linux-2_21-2
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 6 Mar 2012 10:22:30 +0000 (10:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fix-crash-on-fdisk-l.patch -> 1.1
    util-linux.spec -> 1.342

fix-crash-on-fdisk-l.patch [new file with mode: 0644]
util-linux.spec

diff --git a/fix-crash-on-fdisk-l.patch b/fix-crash-on-fdisk-l.patch
new file mode 100644 (file)
index 0000000..22316ae
--- /dev/null
@@ -0,0 +1,34 @@
+From b2cfdbb023ad06afec00ad44761e244d74119034 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Elan=20Ruusam=C3=A4e?= <glen@delfi.ee>
+Date: Tue, 6 Mar 2012 12:19:41 +0200
+Subject: [PATCH] fix crash on fdisk -l
+
+---
+ libblkid/src/topology/sysfs.c |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libblkid/src/topology/sysfs.c b/libblkid/src/topology/sysfs.c
+index e62b84c..41be036 100644
+--- a/libblkid/src/topology/sysfs.c
++++ b/libblkid/src/topology/sysfs.c
+@@ -76,7 +76,7 @@ static int probe_sysfs_tp(blkid_probe pr,
+                               }
+                       }
+                       if (!ok)
+-                              continue;       /* attrinute does not exist */
++                              continue;       /* attribute does not exist */
+               }
+               if (val->set_ulong) {
+@@ -102,7 +102,7 @@ static int probe_sysfs_tp(blkid_probe pr,
+ done:
+       sysfs_deinit(&sysfs);
+-      if (disk)
++      if (disk && disk != dev)
+               sysfs_deinit(&parent);
+       if (count)
+               return 0;               /* success */
+-- 
+1.7.9.2
+
index 145c1a27e037b175563c99751acade46f3ef6269..f1b40bb4e611dae095180026e90b415d735e4ade 100644 (file)
@@ -34,7 +34,7 @@ Summary(tr.UTF-8):    Temel sistem araçları
 Summary(uk.UTF-8):     Набір базових системних утиліт для Linux
 Name:          util-linux
 Version:       2.21
-Release:       1
+Release:       2
 License:       GPL
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/utils/util-linux/v2.21/%{name}-%{version}.tar.xz
@@ -57,6 +57,7 @@ Patch10:      %{name}-diet.patch
 Patch11:       no-openat.patch
 Patch12:       https://github.com/karelzak/util-linux/commit/2f595c001b4528b3b9a4aea04d72b6918c434efb.patch
 # Patch12-md5: 6671ea54ea50f49ef56e05a7b3c8bd37
+Patch13:       fix-crash-on-fdisk-l.patch
 URL:           http://userweb.kernel.org/~kzak/util-linux/
 BuildRequires: audit-libs-devel >= 1.0.6
 BuildRequires: autoconf >= 2.60
@@ -641,6 +642,7 @@ etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
 %patch11 -p1
 %endif
 %patch12 -p1
+%patch13 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.040281 seconds and 4 git commands to generate.