]> git.pld-linux.org Git - packages/util-linux.git/commitdiff
- updated to 2.21.2 auto/th/util-linux-2_21_2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 27 May 2012 11:59:53 +0000 (11:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete fix-crash-on-fdisk-l patch

Changed files:
    fix-crash-on-fdisk-l.patch -> 1.3
    util-linux.spec -> 1.347

fix-crash-on-fdisk-l.patch [deleted file]
util-linux.spec

diff --git a/fix-crash-on-fdisk-l.patch b/fix-crash-on-fdisk-l.patch
deleted file mode 100644 (file)
index 1095e37..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-From 4c5bbc5d7e34b16591a1dec1347492e5d10bb1ab Mon Sep 17 00:00:00 2001
-From: Karel Zak <kzak@redhat.com>
-Date: Tue, 6 Mar 2012 11:24:54 +0100
-Subject: [PATCH] libblkid: fix sysfs context usage
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Reported-by: Elan Ruusamäe <glen@delfi.ee>
-Signed-off-by: Karel Zak <kzak@redhat.com>
----
- include/sysfs.h               |    1 +
- lib/sysfs.c                   |    6 +++---
- libblkid/src/devname.c        |    2 +-
- libblkid/src/devno.c          |    2 +-
- libblkid/src/topology/sysfs.c |    9 +++++----
- 5 files changed, 11 insertions(+), 9 deletions(-)
-
-diff --git a/include/sysfs.h b/include/sysfs.h
-index c1e6352..affd2bb 100644
---- a/include/sysfs.h
-+++ b/include/sysfs.h
-@@ -23,6 +23,7 @@ struct sysfs_cxt {
-       struct sysfs_cxt *parent;
- };
-+#define UL_SYSFSCXT_EMPTY { 0, -1, NULL, NULL }
- extern char *sysfs_devno_attribute_path(dev_t devno, char *buf,
-                                  size_t bufsiz, const char *attr);
-diff --git a/lib/sysfs.c b/lib/sysfs.c
-index 89600bf..2340d30 100644
---- a/lib/sysfs.c
-+++ b/lib/sysfs.c
-@@ -137,7 +137,7 @@ dev_t sysfs_devname_to_devno(const char *name, const char *parent)
- int sysfs_init(struct sysfs_cxt *cxt, dev_t devno, struct sysfs_cxt *parent)
- {
-       char path[PATH_MAX];
--      int fd, rc = 0;
-+      int fd, rc;
-       memset(cxt, 0, sizeof(*cxt));
-       cxt->dir_fd = -1;
-@@ -157,7 +157,7 @@ int sysfs_init(struct sysfs_cxt *cxt, dev_t devno, struct sysfs_cxt *parent)
-       cxt->parent = parent;
-       return 0;
- err:
--      rc = -errno;
-+      rc = errno > 0 ? -errno : -1;
-       sysfs_deinit(cxt);
-       return rc;
- }
-@@ -445,7 +445,7 @@ int sysfs_count_partitions(struct sysfs_cxt *cxt, const char *devname)
- int main(int argc, char *argv[])
- {
--      struct sysfs_cxt cxt;
-+      struct sysfs_cxt cxt = UL_SYSFSCXT_EMPTY;
-       char *devname;
-       dev_t devno;
-       char path[PATH_MAX];
-diff --git a/libblkid/src/devname.c b/libblkid/src/devname.c
-index 12cd93a..4a08452 100644
---- a/libblkid/src/devname.c
-+++ b/libblkid/src/devname.c
-@@ -550,7 +550,7 @@ static int probe_all_removable(blkid_cache cache)
-               return -BLKID_ERR_PROC;
-       while((d = readdir(dir))) {
--              struct sysfs_cxt sysfs;
-+              struct sysfs_cxt sysfs = UL_SYSFSCXT_EMPTY;
-               int removable = 0;
-               dev_t devno;
-diff --git a/libblkid/src/devno.c b/libblkid/src/devno.c
-index b2a8be5..59edfd8 100644
---- a/libblkid/src/devno.c
-+++ b/libblkid/src/devno.c
-@@ -346,7 +346,7 @@ static int get_dm_wholedisk(struct sysfs_cxt *cxt, char *diskname,
- int blkid_devno_to_wholedisk(dev_t dev, char *diskname,
-                       size_t len, dev_t *diskdevno)
- {
--      struct sysfs_cxt cxt;
-+      struct sysfs_cxt cxt = UL_SYSFSCXT_EMPTY;
-       int is_part = 0;
-       if (!dev || sysfs_init(&cxt, dev, NULL) != 0)
-diff --git a/libblkid/src/topology/sysfs.c b/libblkid/src/topology/sysfs.c
-index e62b84c..a04b20a 100644
---- a/libblkid/src/topology/sysfs.c
-+++ b/libblkid/src/topology/sysfs.c
-@@ -44,7 +44,8 @@ static int probe_sysfs_tp(blkid_probe pr,
- {
-       dev_t dev, disk = 0;
-       int rc;
--      struct sysfs_cxt sysfs, parent;
-+      struct sysfs_cxt sysfs = UL_SYSFSCXT_EMPTY,
-+                       parent = UL_SYSFSCXT_EMPTY;
-       size_t i, count = 0;
-       dev = blkid_probe_get_devno(pr);
-@@ -76,7 +77,7 @@ static int probe_sysfs_tp(blkid_probe pr,
-                               }
-                       }
-                       if (!ok)
--                              continue;       /* attrinute does not exist */
-+                              continue;       /* attribute does not exist */
-               }
-               if (val->set_ulong) {
-@@ -102,8 +103,8 @@ static int probe_sysfs_tp(blkid_probe pr,
- done:
-       sysfs_deinit(&sysfs);
--      if (disk)
--              sysfs_deinit(&parent);
-+      sysfs_deinit(&parent);
-+
-       if (count)
-               return 0;               /* success */
-       return rc;                      /* error or nothing */
--- 
-1.7.5.4
-
index 37efecb16fc1a6a48d4ae854dfac42a800e943b6..961ac4e837354e0d983655e5cec82499a05e3470 100644 (file)
@@ -32,12 +32,12 @@ Summary(ru.UTF-8):  Набор базовых системных утилит д
 Summary(tr.UTF-8):     Temel sistem araçları
 Summary(uk.UTF-8):     Набір базових системних утиліт для Linux
 Name:          util-linux
-Version:       2.21.1
+Version:       2.21.2
 Release:       1
 License:       GPL
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/utils/util-linux/v2.21/%{name}-%{version}.tar.xz
-# Source0-md5: ad602dcd528f340b1329cfa6200d8f80
+# Source0-md5: 54ba880f1d66782c2287ee2c898520e9
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3c940c7e7fe699eaa2ddb1bffb3de2fe
 Source2:       login.pamd
@@ -54,7 +54,6 @@ Patch8:               %{name}-procpartitions.patch
 Patch9:                %{name}-swaponsymlink.patch
 Patch10:       %{name}-diet.patch
 Patch11:       no-openat.patch
-Patch12:       fix-crash-on-fdisk-l.patch
 URL:           http://userweb.kernel.org/~kzak/util-linux/
 BuildRequires: audit-libs-devel >= 1.0.6
 BuildRequires: autoconf >= 2.60
@@ -640,7 +639,6 @@ etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
 %if %{without partx}
 %patch11 -p1
 %endif
-%patch12 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.303479 seconds and 4 git commands to generate.