]> git.pld-linux.org Git - packages/util-linux.git/blobdiff - util-linux.spec
- use functions
[packages/util-linux.git] / util-linux.spec
index 84058366ad5fade7da083186a833be7f13eed265..503f8cd2f9cc2032209cdcd857831ba030566a78 100644 (file)
@@ -1,10 +1,10 @@
 #
 # Conditional build:
-# _without_dist_kernel - do nothing for now
-# _with_uClibc         - don't build few utilities
+%bcond_with    uClibc  # don't build few utilities
 #
 # TODO:
 # - move raw to /sbin (potentially can be used before mount partitions)??
+# - move logger to separate package (to avoid conflicts with inetutils)
 
 Summary:       Collection of basic system utilities for Linux
 Summary(de):   Sammlung von grundlegenden Systemdienstprogrammen für Linux
@@ -16,25 +16,29 @@ Summary(ru):        
 Summary(tr):   Temel sistem araçlarý
 Summary(uk):   îÁ¦ҠÂÁÚÏ×ÉÈ ÓÉÓÔÅÍÎÉÈ ÕÔÉ̦ԠÄÌÑ Linux
 Name:          util-linux
-Version:       2.12
-%define _rel 4
-Release:       %{_rel}
+Version:       2.12r
+Release:       4
 License:       distributable
 Group:         Applications/System
-Source0:       http://ftp.cwi.nl/aeb/util-linux/%{name}-%{version}.tar.gz
-# Source0-md5: 997adf78b98d9d1c5db4f37ea982acff
-Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
-# Source1-md5: 3c940c7e7fe699eaa2ddb1bffb3de2fe
+# devel versions at ftp://ftp.kernel.org/pub/linux/utils/util-linux/testing
+Source0:       ftp://ftp.kernel.org/pub/linux/utils/util-linux/%{name}-%{version}.tar.gz
+# Source0-md5: c261230b27fc0fbcc287c76884caf2d3
+#Source1:      http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
+Source1:       %{name}-non-english-man-pages.tar.bz2
+# Source1-md5: 81bbcc9a820512ecde87a8f31de0b745
 Source2:       login.pamd
 Source3:       rawdevices.init
 Source4:       rawdevices.sysconfig
+Source5:       %{name}-blockdev.init
+Source6:       %{name}-blockdev.sysconfig
 Patch0:                %{name}-MCONFIG.patch
 Patch1:                %{name}-fdisk.patch
 Patch2:                %{name}-utmpx.patch
 Patch3:                %{name}-fhs.patch
 Patch4:                %{name}-login.patch
 Patch5:                %{name}-info.patch
-Patch6:                ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/%{name}-2.10m-mount-compat.patch
+# from ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/ :
+Patch6:                %{name}-2.10m-mount-compat.patch
 Patch7:                %{name}-syscall.patch
 Patch8:                %{name}-raw.patch
 Patch9:                %{name}-gecos.patch
@@ -42,20 +46,39 @@ Patch10:    %{name}-glibc.patch
 Patch11:       %{name}-posixsh.patch
 Patch12:       %{name}-ppc-hwclock.patch
 Patch13:       %{name}-no_multiline.patch
-Patch14:       http://www.stwing.org/~sluskyb/util-linux/losetup-combined.patch
-Patch15:       http://www.stwing.org/~sluskyb/util-linux/losetup-keygen-prog-mk7.patch
-Patch16:       http://www.stwing.org/~sluskyb/util-linux/losetup-variable-key-size-mk6.patch
+Patch14:       %{name}-amd64.patch
+Patch15:       %{name}-dm_crypt.patch
+Patch16:       %{name}-blk.patch
+Patch17:       %{name}-managed.patch
+Patch18:       %{name}-page.patch
+Patch19:       %{name}-gcc4.patch
+# from http://www.citi.umich.edu/projects/nfsv4/linux/util-linux-patches/2.12-3/ :
+Patch20:       %{name}-2.12-01-nfs.dif
+Patch21:       %{name}-2.12-02-base-nfsv4.dif
+Patch22:       %{name}-2.12-03-krb5.dif
+Patch23:       %{name}-2.12-04-modify_mount_to_support_multiple_security_flavors.dif
+Patch24:       %{name}-2.12-05-mount_sloppy_fix.dif
+Patch25:       %{name}-2.12-06-redhat-nfs-mount.dif
+Patch26:       %{name}-2.12q-update-mtab-when-moving.patch
+Patch27:       %{name}-2.12q-use-update_mtab-for-fake.patch
+Patch28:       %{name}-2.12q-more-fake-checks-v2.patch
+Patch29:       %{name}-2.12q-update_mtab-fixes.patch
+Patch30:       %{name}-as_needed-fix.patch
+BuildRequires: cryptsetup-devel
 BuildRequires: gettext-devel
 BuildRequires: grep
-%{!?_with_uClibc:BuildRequires:        ncurses-devel >= 5.0}
-%{!?_with_uClibc:BuildRequires:        pam-devel >= 0.77.3}
+BuildRequires: libselinux-devel
+%{!?with_uClibc:BuildRequires: ncurses-devel >= 5.0}
+%{!?with_uClibc:BuildRequires: pam-devel >= 0.79.0}
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: texinfo
 BuildRequires: textutils
-%{!?_with_uClibc:BuildRequires:        zlib-devel}
-%{!?_with_uClibc:Requires:     pam >= 0.77.3}
+%{!?with_uClibc:BuildRequires: zlib-devel}
+%{!?with_uClibc:Requires:      pam >= 0.79.0}
 Provides:      fdisk
 Obsoletes:     cramfs
 Obsoletes:     util-linux-suids
+Conflicts:     shadow-extras < 1:4.0.3-6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                debugcflags     -O1 -g
@@ -113,16 +136,33 @@ uygulamalar
 ËÏÎƦÇÕÒÁæÊΦ ¦ÎÓÔÒÕÍÅÎÔÉ (ÔÁ˦ ÑË fdisk) ÔÁ ÓÉÓÔÅÍΦ ÐÒÏÇÒÁÍÉ (ÔÁ˦
 ÑË login).
 
+%package -n blockdev
+Summary:       Support for blockdev
+Summary(pl):   Obs³uga blockdev
+Group:         Applications/System
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
+#Requires:     uname(release) >= 2.6
+
+%description -n blockdev
+The utility blockdev allows one to call block device ioctls from the
+command line. This package also includes initscript to set blockdev
+parameters at system startup.
+
+%description -n blockdev -l pl
+Narzêdzie blockdev pozwala na wywo³ania ioctl dla urz±dzeñ blokowych z
+linii poleceñ. Ten pakiet zawiera tak¿e skrypt inicjalizacyjny do
+ustawiania parametrów blockdev przy starcie systemu.
+
 %package -n losetup
 Summary:       Programs for setting up and configuring loopback devices
 Summary(de):   Programme zum Einrichten und Konfigurieren von Loopback-Geräten
 Summary(fr):   Programmes pour mettre en place et configurer les loopback
 Summary(pl):   Program do konfiguracji urz±dzenia blokowego loopback
-Summary(tr):   Yerel-çevrim aygýtlarýnýn kurulmasý ve ayarlanmasý için programlar
 Summary(ru):   ðÒÏÇÒÁÍÍÙ ÄÌÑ ÎÁÓÔÒÏÊËÉ loopback-ÕÓÔÒÏÊÓÔ×
+Summary(tr):   Yerel-çevrim aygýtlarýnýn kurulmasý ve ayarlanmasý için programlar
 Summary(uk):   ðÒÏÇÒÁÍÉ ÄÌÑ ËÏÎƦÇÕÒÁ槠loopback-ÐÒÉÓÔÒϧ×
 Group:         Applications/System
-Release:      %{_rel}@%{_kernel_ver_str}
 
 %description -n losetup
 Linux supports a special block device called the loopback device,
@@ -187,11 +227,13 @@ Summary:  Programs for mounting and unmounting filesystems
 Summary(de):   Programme zum montieren und abmontieren von Dateisystemen
 Summary(fr):   Programme pour monter et démonter des systèmes de fichiers
 Summary(pl):   Programy do montowania i odmontowywania systemów plików
+Summary(ru):   ðÒÏÇÒÁÍÍÙ ÄÌÑ ÍÏÎÔÉÒÏ×ÁÎÉÑ É ÒÁÚÍÏÎÔÉÒÏ×ÁÎÉÑ ÆÁÊÌÏ×ÙÈ ÓÉÓÔÅÍ
 Summary(tr):   Dosya sistemlerini baðlamak ve çözmek için programlar
 Summary(uk):   ðÒÏÇÒÁÍÉ ÄÌÑ ÍÏÎÔÕ×ÁÎÎÑ ÔÁ ÒÏÚÍÏÎÔÕ×ÁÎÎÑ ÆÁÊÌÏ×ÉÈ ÓÉÓÔÅÍ
-Summary(ru):   ðÒÏÇÒÁÍÍÙ ÄÌÑ ÍÏÎÔÉÒÏ×ÁÎÉÑ É ÒÁÚÍÏÎÔÉÒÏ×ÁÎÉÑ ÆÁÊÌÏ×ÙÈ ÓÉÓÔÅÍ
 Group:         Applications/System
-Release:      %{_rel}@%{_kernel_ver_str}
+Requires:      cryptsetup >= 0.2-1.pre1.4
+Requires:      libgcrypt >= 1.2.0-6
+Requires:      libgpg-error >= 1.0-4
 
 %description -n mount
 mount is used for adding new filesystems, both local and networked, to
@@ -320,8 +362,8 @@ agetty jest prostym linuksowym getty z obs
 Summary:       Support for raw-devices
 Summary(pl):   Obs³uga raw-device'ów
 Group:         Applications/System
-PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
 
 %description -n rawdevices
 Support for raw-devices.
@@ -346,23 +388,38 @@ Obs
 %patch12 -p1
 %patch13 -p0
 %patch14 -p1
-#%patch16 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+%patch23 -p1
+%patch24 -p1
+%patch25 -p1
+%patch26 -p0
+%patch27 -p1
+%patch28 -p0
+%patch29 -p1
+%patch30 -p1
 
 %build
 CC="%{__cc}"
 LDFLAGS="%{rpmldflags}"
-CFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
+CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
 export CC CFLAGS LDFLAGS
 # using %%configure2_13 isn't very wise here, it is not autoconf generated
 # configure and it doesn't take any parameters
 ./configure
 
-%{?_with_uClibc:echo 'char *nl_langinfo (nl_item x){return "";}' >> misc-utils/cal.c}
+%{?with_uClibc:echo 'char *nl_langinfo (nl_item x){return "";}' >> misc-utils/cal.c}
 %{__make} \
        OPT="%{rpmcflags}" \
        MOREHELPDIR=%{_datadir}/misc \
-       %{!?_with_uClibc:ADD_RAW="yes"} \
-       %{?_with_uClibc:HAVE_RAW_H="no" HAVE_PAM="no"}
+       %{!?with_uClibc:ADD_RAW="yes"} \
+       %{?with_uClibc:HAVE_RAW_H="no" HAVE_PAM="no"} \
 
 %ifarch ppc
 %{__cc} %{rpmcflags} %{rpmldflags} clock-ppc.c -o clock-ppc
@@ -385,12 +442,14 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,/etc/{pam.d,logrotate,rc.d/init.d,sysconfi
        GETOPTDIR=$RPM_BUILD_ROOT%{_examplesdir}/getopt \
        USRGAMESDIR=$RPM_BUILD_ROOT%{_bindir} \
        USE_TTY_GROUP=no \
-       %{!?_with_uClibc:ADD_RAW="yes"} \
-       %{?_with_uClibc:HAVE_RAW_H="no" HAVE_PAM="no"}
+       %{!?with_uClibc:ADD_RAW="yes"} \
+       %{?with_uClibc:HAVE_RAW_H="no" HAVE_PAM="no"}
 
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/login
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/rawdevices
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rawdevices
+install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/blockdev
+install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/blockdev
 
 install -d $RPM_BUILD_ROOT{/etc/security,/var/lock}
 
@@ -422,16 +481,20 @@ for d in cs de es fi fr hu id it ja ko nl pl ; do
 done
 
 # cleanup, remove files not included in package
-rm -f $RPM_BUILD_ROOT%{_bindir}/{chfn,chsh,newgrp}
-rm -f $RPM_BUILD_ROOT%{_sbindir}/vipw
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/chfn.1*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/chsh.1*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/newgrp.1*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/sln.8*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/vigr.8*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/vipw.8*
+rm -f $RPM_BUILD_ROOT%{_bindir}/{chfn,chsh,newgrp} \
+       $RPM_BUILD_ROOT%{_sbindir}/{vifr,vipw} \
+       $RPM_BUILD_ROOT%{_mandir}/man1/{chfn,chsh,newgrp,sg}.1 \
+       $RPM_BUILD_ROOT%{_mandir}/man8/{sln,vigr,vipw}.8 \
+       $RPM_BUILD_ROOT%{_mandir}/*/man1/{chfn,chsh,clear,last,mesg,newgrp,od,passwd,reset,sg,wall}.1 \
+       $RPM_BUILD_ROOT%{_mandir}/*/man8/{display-services,fast*,halt,initctl,need,provide,reboot,shutdown,simpleinit,sln,vigr,vipw}.8
+%ifnarch %{ix86}
+rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/{ramsize,rdev,rootflags,vidmode}.8
+%endif
+%ifarch sparc sparc64
+rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/{cfdisk,sfdisk}.8
+%endif
 
-%{!?_with_uClibc:%find_lang %{name}}
+%{!?with_uClibc:%find_lang %{name}}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -442,21 +505,27 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
+%post -n blockdev
+/sbin/chkconfig --add blockdev
+%service blockdev restart
+
+%preun -n blockdev
+if [ "$1" = "0" ]; then
+       %service blockdev stop
+       /sbin/chkconfig --del blockdev
+fi
+
 %post -n rawdevices
 /sbin/chkconfig --add rawdevices
-if [ -f /var/lock/subsys/rawdevices ]; then
-       /etc/rc.d/init.d/rawdevices restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/rawdevices start\" to start rawdevices."
-fi
+%service rawdevices restart
 
 %preun -n rawdevices
-if [ -f /var/lock/subsys/rawdevices ]; then
-       /etc/rc.d/init.d/rawdevices stop 1>&2
+if [ "$1" = "0" ]; then
+       %service rawdevices stop
+       /sbin/chkconfig --del rawdevices
 fi
-/sbin/chkconfig --del rawdevices
 
-%files %{!?_with_uClibc:-f %{name}.lang}
+%files %{!?with_uClibc:-f %{name}.lang}
 %defattr(644,root,root,755)
 %doc */README.* text-utils/LICENSE.pg
 
@@ -476,47 +545,47 @@ fi
 %lang(ja) %{_mandir}/ja/man8/clock.8*
 %lang(ja) %{_mandir}/ja/man8/hwclock.8*
 
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/fdprm
-
-%attr(0755,root,root) /bin/arch
-%attr(0755,root,root) /bin/dmesg
-%attr(0755,root,root) /bin/kill
-%{!?_with_uClibc:%attr(0755,root,root) /bin/more}
-%attr(0755,root,root) /sbin/blockdev
-%attr(0755,root,root) /sbin/mkfs
-%attr(0755,root,root) /sbin/mkswap
-%attr(0755,root,root) /sbin/ctrlaltdel
-%attr(0755,root,root) /sbin/elvtune
-%attr(0755,root,root) %{_bindir}/cal
-%attr(0755,root,root) %{_bindir}/col
-%attr(0755,root,root) %{_bindir}/colcrt
-%attr(0755,root,root) %{_bindir}/colrm
-%attr(0755,root,root) %{_bindir}/column
-%attr(0755,root,root) %{_bindir}/ddate
-%attr(0755,root,root) %{_bindir}/fdformat
-%attr(0755,root,root) %{_bindir}/getopt
-%attr(0755,root,root) %{_bindir}/hexdump
-%attr(0755,root,root) %{_bindir}/ipcrm
-%attr(0755,root,root) %{_bindir}/ipcs
-%attr(0755,root,root) %{_bindir}/isosize
-%attr(0755,root,root) %{_bindir}/logger
-%attr(0755,root,root) %{_bindir}/look
-%attr(0755,root,root) %{_bindir}/mcookie
-%attr(0755,root,root) %{_bindir}/namei
-%attr(0755,root,root) %{_bindir}/renice
-%attr(0755,root,root) %{_bindir}/rev
-%attr(0755,root,root) %{_bindir}/script
-%attr(0755,root,root) %{_bindir}/setsid
-%attr(0755,root,root) %{_bindir}/setfdprm
-%{!?_with_uClibc:%attr(0755,root,root) %{_bindir}/pg}
-%attr(0755,root,root) %{_bindir}/line
-%attr(0755,root,root) %{_bindir}/rename
-%{!?_with_uClibc:%attr(0755,root,root) %{_bindir}/setterm}
-%{!?_with_uClibc:%attr(0755,root,root) %{_bindir}/ul}
-%attr(0755,root,root) %{_bindir}/whereis
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fdprm
+
+%attr(755,root,root) /bin/arch
+%attr(755,root,root) /bin/dmesg
+%attr(755,root,root) /bin/kill
+%{!?with_uClibc:%attr(755,root,root) /bin/more}
+%attr(755,root,root) /sbin/mkfs
+%attr(755,root,root) /sbin/mkswap
+%attr(755,root,root) /sbin/ctrlaltdel
+%attr(755,root,root) /sbin/elvtune
+%attr(755,root,root) %{_bindir}/cal
+%attr(755,root,root) %{_bindir}/col
+%attr(755,root,root) %{_bindir}/colcrt
+%attr(755,root,root) %{_bindir}/colrm
+%attr(755,root,root) %{_bindir}/column
+%attr(755,root,root) %{_bindir}/ddate
+%attr(755,root,root) %{_bindir}/fdformat
+%attr(755,root,root) %{_bindir}/flock
+%attr(755,root,root) %{_bindir}/getopt
+%attr(755,root,root) %{_bindir}/hexdump
+%attr(755,root,root) %{_bindir}/ipcrm
+%attr(755,root,root) %{_bindir}/ipcs
+%attr(755,root,root) %{_bindir}/isosize
+%attr(755,root,root) %{_bindir}/line
+%attr(755,root,root) %{_bindir}/logger
+%attr(755,root,root) %{_bindir}/look
+%attr(755,root,root) %{_bindir}/mcookie
+%attr(755,root,root) %{_bindir}/namei
+%{!?with_uClibc:%attr(755,root,root) %{_bindir}/pg}
+%attr(755,root,root) %{_bindir}/renice
+%attr(755,root,root) %{_bindir}/rev
+%attr(755,root,root) %{_bindir}/script
+%attr(755,root,root) %{_bindir}/setsid
+%attr(755,root,root) %{_bindir}/setfdprm
+%attr(755,root,root) %{_bindir}/rename
+%{!?with_uClibc:%attr(755,root,root) %{_bindir}/setterm}
+%{!?with_uClibc:%attr(755,root,root) %{_bindir}/ul}
+%attr(755,root,root) %{_bindir}/whereis
 %attr(2755,root,tty) %{_bindir}/write
-%attr(0755,root,root) %{_bindir}/tailf
-%attr(0755,root,root) %{_sbindir}/readprofile
+%attr(755,root,root) %{_bindir}/tailf
+%attr(755,root,root) %{_sbindir}/readprofile
 
 %{_mandir}/man1/arch.1*
 %{_mandir}/man1/cal.1*
@@ -525,6 +594,7 @@ fi
 %{_mandir}/man1/colrm.1*
 %{_mandir}/man1/column.1*
 %{_mandir}/man1/ddate.1*
+%{_mandir}/man1/flock.1*
 %{_mandir}/man1/getopt.1*
 %{_mandir}/man1/hexdump.1*
 %{_mandir}/man1/kill.1*
@@ -532,20 +602,19 @@ fi
 %{_mandir}/man1/logger.1*
 %{_mandir}/man1/look.1*
 %{_mandir}/man1/mcookie.1*
-%{!?_with_uClibc:%{_mandir}/man1/more.1*}
+%{!?with_uClibc:%{_mandir}/man1/more.1*}
 %{_mandir}/man1/namei.1*
-%{!?_with_uClibc:%{_mandir}/man1/pg.1*}
+%{!?with_uClibc:%{_mandir}/man1/pg.1*}
 %{_mandir}/man1/readprofile.1*
 %{_mandir}/man1/rev.1*
 %{_mandir}/man1/rename.1*
 %{_mandir}/man1/script.1*
-%{!?_with_uClibc:%{_mandir}/man1/setterm.1*}
-%{!?_with_uClibc:%{_mandir}/man1/ul.1*}
+%{!?with_uClibc:%{_mandir}/man1/setterm.1*}
+%{!?with_uClibc:%{_mandir}/man1/ul.1*}
 %{_mandir}/man1/whereis.1*
 %{_mandir}/man1/write.1*
 %{_mandir}/man1/tailf.1*
 
-%{_mandir}/man8/blockdev.8*
 %{_mandir}/man8/ctrlaltdel.8*
 %{_mandir}/man8/cytune.8*
 %{_mandir}/man8/dmesg.8*
@@ -559,6 +628,8 @@ fi
 %{_mandir}/man8/setfdprm.8*
 %{_mandir}/man8/setsid.8*
 
+%lang(cs) %{_mandir}/cs/man1/write.1*
+
 %lang(de) %{_mandir}/de/man1/kill.1*
 %lang(de) %{_mandir}/de/man1/more.1*
 %lang(de) %{_mandir}/de/man1/write.1*
@@ -603,6 +674,7 @@ fi
 %lang(fr) %{_mandir}/fr/man1/col.1*
 %lang(fr) %{_mandir}/fr/man1/kill.1*
 %lang(fr) %{_mandir}/fr/man1/more.1*
+%lang(fr) %{_mandir}/fr/man1/rev.1*
 %lang(fr) %{_mandir}/fr/man1/whereis.1*
 %lang(fr) %{_mandir}/fr/man1/write.1*
 
@@ -638,8 +710,17 @@ fi
 %lang(id) %{_mandir}/id/man8/fdformat.8*
 
 %lang(it) %{_mandir}/it/man1/arch.1*
+%lang(it) %{_mandir}/it/man1/cal.1*
 %lang(it) %{_mandir}/it/man1/kill.1*
-
+%lang(it) %{_mandir}/it/man1/rename.1*
+%lang(it) %{_mandir}/it/man1/rev.1*
+
+%lang(it) %{_mandir}/it/man8/ctrlaltdel.8*
+%lang(it) %{_mandir}/it/man8/dmesg.8*
+%lang(it) %{_mandir}/it/man8/fdformat.8*
+%lang(it) %{_mandir}/it/man8/ipcrm.8*
+%lang(it) %{_mandir}/it/man8/ipcs.8*
+%lang(it) %{_mandir}/it/man8/mkfs.8*
 %lang(it) %{_mandir}/it/man8/mkswap.8*
 %lang(it) %{_mandir}/it/man8/setsid.8*
 
@@ -661,6 +742,7 @@ fi
 %lang(ja) %{_mandir}/ja/man1/namei.1*
 %lang(ja) %{_mandir}/ja/man1/readprofile.1*
 %lang(ja) %{_mandir}/ja/man1/rename.1*
+%lang(ja) %{_mandir}/ja/man1/replay.1*
 %lang(ja) %{_mandir}/ja/man1/rev.1*
 %lang(ja) %{_mandir}/ja/man1/script.1*
 %lang(ja) %{_mandir}/ja/man1/setterm.1*
@@ -668,7 +750,6 @@ fi
 %lang(ja) %{_mandir}/ja/man1/whereis.1*
 %lang(ja) %{_mandir}/ja/man1/write.1*
 
-%lang(ja) %{_mandir}/ja/man8/blockdev.8*
 %lang(ja) %{_mandir}/ja/man8/ctrlaltdel.8*
 %lang(ja) %{_mandir}/ja/man8/cytune.8*
 %lang(ja) %{_mandir}/ja/man8/dmesg.8*
@@ -751,13 +832,13 @@ fi
 %attr(755,root,root) /sbin/fsck.minix
 %attr(755,root,root) /sbin/mkfs.minix
 %ifnarch sparc sparc64
-%{!?_with_uClibc:%attr(755,root,root) /sbin/cfdisk}
+%{!?with_uClibc:%attr(755,root,root) /sbin/cfdisk}
 %attr(755,root,root) /sbin/sfdisk
 %endif
 
 %{_mandir}/man8/fdisk.8*
 %ifnarch sparc sparc64
-%{!?_with_uClibc:%{_mandir}/man8/cfdisk.8*}
+%{!?with_uClibc:%{_mandir}/man8/cfdisk.8*}
 %{_mandir}/man8/sfdisk.8*
 %endif
 %{_mandir}/man8/fsck.minix.8*
@@ -772,7 +853,7 @@ fi
 
 %lang(fr) %{_mandir}/fr/man8/fdisk.8*
 %ifnarch sparc sparc64
-%{!?_with_uClibc:%lang(fr) %{_mandir}/fr/man8/cfdisk.8*}
+%{!?with_uClibc:%lang(fr) %{_mandir}/fr/man8/cfdisk.8*}
 %lang(fr) %{_mandir}/fr/man8/sfdisk.8*
 %endif
 %lang(fr) %{_mandir}/fr/man8/mkfs.minix.8*
@@ -782,12 +863,12 @@ fi
 
 %lang(it) %{_mandir}/it/man8/fdisk.8*
 %ifnarch sparc sparc64
-%{!?_with_uClibc:%lang(it) %{_mandir}/it/man8/cfdisk.8*}
+%{!?with_uClibc:%lang(it) %{_mandir}/it/man8/cfdisk.8*}
 %endif
 
 %lang(ja) %{_mandir}/ja/man8/fdisk.8*
 %ifnarch sparc sparc64
-%{!?_with_uClibc:%lang(ja) %{_mandir}/ja/man8/cfdisk.8*}
+%{!?with_uClibc:%lang(ja) %{_mandir}/ja/man8/cfdisk.8*}
 %lang(ja) %{_mandir}/ja/man8/sfdisk.8*
 %endif
 %lang(ja) %{_mandir}/ja/man8/fsck.minix.8*
@@ -805,8 +886,8 @@ fi
 %lang(pl) %{_mandir}/pl/man8/mkfs.minix.8*
 %lang(pl) %{_mandir}/pl/man8/mkfs.8*
 
-%{!?_with_uClibc:%attr(755,root,root) /sbin/fsck.cramfs}
-%{!?_with_uClibc:%attr(755,root,root) /sbin/mkfs.cramfs}
+%{!?with_uClibc:%attr(755,root,root) /sbin/fsck.cramfs}
+%{!?with_uClibc:%attr(755,root,root) /sbin/mkfs.cramfs}
 %attr(755,root,root) /sbin/mkfs.bfs
 
 %attr(755,root,root) %{_bindir}/cytune
@@ -852,6 +933,14 @@ fi
 
 %ghost /var/lock/wtmpxlock
 
+%files -n blockdev
+%defattr(644,root,root,755)
+%attr(754,root,root) /etc/rc.d/init.d/blockdev
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blockdev
+%attr(755,root,root) /sbin/blockdev
+%{_mandir}/man8/blockdev.8*
+%lang(ja) %{_mandir}/ja/man8/blockdev.8*
+
 %files -n mount
 %defattr(644,root,root,755)
 
@@ -956,11 +1045,11 @@ fi
 %lang(ja) %{_mandir}/ja/man8/tunelp.8*
 %lang(pl) %{_mandir}/pl/man8/tunelp.8*
 
-%if %{?_with_uClibc:0}%{!?_with_uClibc:1}
+%if %{without uClibc}
 %files -n login
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/login
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.login
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/login
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.login
 %attr(755,root,root) /bin/login
 
 %{_mandir}/man1/login.1*
@@ -968,6 +1057,7 @@ fi
 %lang(es) %{_mandir}/es/man1/login.1*
 %lang(hu) %{_mandir}/hu/man1/login.1*
 %lang(id) %{_mandir}/id/man1/login.1*
+%lang(it) %{_mandir}/it/man1/login.1*
 %lang(ja) %{_mandir}/ja/man1/login.1*
 %lang(ko) %{_mandir}/ko/man1/login.1*
 %lang(pl) %{_mandir}/pl/man1/login.1*
@@ -975,18 +1065,18 @@ fi
 
 %files -n agetty
 %defattr(644,root,root,755)
-%attr(0755,root,root) /sbin/agetty
+%attr(755,root,root) /sbin/agetty
 
 %{_mandir}/man8/agetty.8*
 %lang(es) %{_mandir}/es/man8/agetty.8*
 %lang(ja) %{_mandir}/ja/man8/agetty.8*
 
-%if %{?_with_uClibc:0}%{!?_with_uClibc:1}
+%if %{without uClibc}
 %files -n rawdevices
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/raw
 %attr(754,root,root) /etc/rc.d/init.d/rawdevices
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rawdevices
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rawdevices
 
 %{_mandir}/man8/raw.8*
 %lang(ja) %{_mandir}/ja/man8/raw.8*
This page took 0.387379 seconds and 4 git commands to generate.