]> git.pld-linux.org Git - packages/util-linux.git/blobdiff - util-linux.spec
fix wipefs not understanding -f option
[packages/util-linux.git] / util-linux.spec
index 4085dc477c3c8feefaedc99e1f527f18c6afdf34..2951ae7dc9b2ea35c84e33d98bfe7b4821c53731 100644 (file)
@@ -1,16 +1,22 @@
+# TODO
+# - verify initrd tools set:
+#   - I've taken list from 2.21.3 package, but there was no explicit list, so
+#     there are probably some unneeded tools
+#   - chrt is not built now (because of --disable-schedutils), but it's probably not needed
+#   - fsck is not built now (because of --disable-libmount)
+#   - maybe we want some more now?
 #
 # Conditional build:
 %bcond_with    uClibc          # link initrd version with static glibc instead of uClibc
 %bcond_without dietlibc        # link initrd version with dietlibc instead of uClibc
 %bcond_without selinux         # SELinux support
+%bcond_without su              # su/runuser programs
 %if "%{pld_release}" == "ac"
-%bcond_with            initrd          # don't build initrd version
-%bcond_with            fallocate       # fallocate utility (needs glibc 2.11 to compile)
-%bcond_with            partx           # partx utility (needs glibc 2.10 for openat to compile)
+%bcond_with    initrd          # don't build initrd version
+%bcond_with    fallocate       # fallocate utility (needs glibc 2.11 to compile)
 %else
 %bcond_without initrd          # don't build initrd version
 %bcond_without fallocate       # fallocate utility (needs glibc 2.11 to compile)
-%bcond_without partx           # partx utility (needs glibc 2.10 for openat to compile)
 %endif
 
 %if "%{pld_release}" == "ac"
@@ -29,38 +35,43 @@ Summary(ru.UTF-8):  Набор базовых системных утилит д
 Summary(tr.UTF-8):     Temel sistem araçları
 Summary(uk.UTF-8):     Набір базових системних утиліт для Linux
 Name:          util-linux
-Version:       2.20.1
-Release:       3
+Version:       2.22.2
+Release:       6
 License:       GPL
 Group:         Applications/System
-#Source0:      http://ftp.kernel.org/pub/linux/utils/util-linux/v2.20/%{name}-%{version}.tar.bz2
-Source0:       ftp://ftp.infradead.org/pub/util-linux/v2.20/%{name}-%{version}.tar.bz2
-# Source0-md5: 079b37517fd4e002a2e6e992e8b4e361
+Source0:       https://www.kernel.org/pub/linux/utils/util-linux/v2.22/%{name}-%{version}.tar.xz
+# Source0-md5: eeacbfdd2556acd899a2d0ffdb446185
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3c940c7e7fe699eaa2ddb1bffb3de2fe
 Source2:       login.pamd
 Source3:       %{name}-blockdev.init
 Source4:       %{name}-blockdev.sysconfig
 Source5:       blockdev.upstart
+Source6:       su.pamd
+Source7:       su-l.pamd
+Source8:       runuser.pamd
+Source9:       runuser-l.pamd
+Source10:      nologin.c
+Source11:      nologin.8
 Patch0:                %{name}-pl.po-update.patch
 Patch1:                %{name}-ng-union-mount.patch
-Patch2:                %{name}-ctrlaltdel-man.patch
+Patch2:                %{name}-runuser.patch
 Patch3:                %{name}-fdformat-ide.patch
 Patch4:                %{name}-fhs.patch
 Patch5:                %{name}-hotkeys.patch
-Patch6:                %{name}-pl.po-update.patch
 Patch7:                %{name}-login-lastlog.patch
 Patch8:                %{name}-procpartitions.patch
-Patch9:                %{name}-swaponsymlink.patch
+Patch9:                su-paths.patch
 Patch10:       %{name}-diet.patch
-Patch11:       no-openat.patch
-Patch12:       %{name}-build.patch
+Patch11:       https://github.com/karelzak/util-linux/commit/38db00f17824f41679c99a6c711a11e4585a0484.patch
+# Patch11-md5: 2a37a871117466841edb3e8be692825b
 URL:           http://userweb.kernel.org/~kzak/util-linux/
 BuildRequires: audit-libs-devel >= 1.0.6
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.10
 BuildRequires: gettext-devel >= 0.14.1
 %{?with_fallocate:BuildRequires:       glibc-devel >= 6:2.11}
+BuildRequires: gtk-doc >= 1.10
 BuildRequires: gtk-doc-automake >= 1.10
 %{?with_selinux:BuildRequires: libselinux-devel}
 %{?with_selinux:BuildRequires: libsepol-devel}
@@ -72,6 +83,9 @@ BuildRequires:        pkgconfig
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: udev-devel
+BuildRequires: xz
 BuildRequires: zlib-devel
 %if %{with initrd}
        %if %{with uClibc}
@@ -84,11 +98,14 @@ BuildRequires:      glibc-static
                %endif
        %endif
 %endif
+Requires:      libblkid = %{version}-%{release}
 Requires:      pam >= %{pam_ver}
+Provides:      eject = %{version}-%{release}
 Provides:      fdisk
 Provides:      linux32
 Provides:      sparc32
 Obsoletes:     cramfs
+Obsoletes:     eject
 Obsoletes:     ionice
 Obsoletes:     linux32
 Obsoletes:     rawdevices
@@ -98,9 +115,13 @@ Obsoletes:  sparc32
 Obsoletes:     util-linux-ng < 2.20-1
 Obsoletes:     util-linux-suids
 Conflicts:     SysVinit < 2.86-26
-Conflicts:     upstart-SysVinit < 2.86-28
+Conflicts:     SysVinit-tools < 2.88-9
 Conflicts:     e2fsprogs < 1.41.8-5
 Conflicts:     shadow-extras < 1:4.0.3-6
+Conflicts:     upstart-SysVinit < 2.86-28
+%if %{with su}
+Conflicts:     coreutils < 8.19
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                debugcflags     -O1 -g
@@ -263,8 +284,9 @@ Summary(tr.UTF-8):  Dosya sistemlerini bağlamak ve çözmek için programlar
 Summary(uk.UTF-8):     Програми для монтування та розмонтування файлових систем
 Group:         Applications/System
 Requires:      libmount = %{version}-%{release}
-Conflicts:     nfs-utils-common < 1.1.3-3
 Conflicts:     SysVinit < 2.86-26
+# C: nfs-utils-common is opposite to http://cvs.pld-linux.org/packages/nfs-utils/nfs-utils.spec?r1=1.165&r2=1.166
+Conflicts:     nfs-utils-common < 1.1.3-3
 
 %description -n mount
 mount is used for adding new filesystems, both local and networked, to
@@ -522,7 +544,9 @@ Requires(pre):      /usr/sbin/groupadd
 Requires(pre): /usr/sbin/groupmod
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/sbin/usermod
+Requires(post,preun,postun):    systemd-units >= 38
 Requires:      libuuid = %{version}-%{release}
+Requires:      systemd-units >= 38
 Provides:      group(uuidd)
 Provides:      user(uuidd)
 Conflicts:     libuuid < 1.40.5-0.1
@@ -622,25 +646,19 @@ etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
 
 %prep
 %setup -q -a1
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-#%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%if %{without partx}
 %patch11 -p1
-%endif
-%patch12 -p1
 
-%if "%{pld_release}" != "ac"
-sed -i -e 's/-lncursesw/-lncursesw -ltinfow/' configure.ac
-%endif
+install %{SOURCE10} nologin.c
 
 %{__rm} po/stamp-po
 
@@ -655,46 +673,63 @@ sed -i -e 's/-lncursesw/-lncursesw -ltinfow/' configure.ac
 export CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses -DHAVE_LSEEK64_PROTOTYPE -DHAVE_LLSEEK_PROTOTYPE"
 %if %{with initrd}
 %{?with_uClibc:xCC="%{_target_cpu}-uclibc-gcc"}
-%{?with_dietlibc:xCC="diet %{__cc}"; xCC=${xCC#*ccache }}
+%{?with_dietlibc:xCC="%{__cc}"; xCC="diet ${xCC#*ccache }"}
 %configure \
 %if %{with dietlibc}
-       ac_cv_header_crypt_h="no" \
+       ac_cv_header_crypt_h=no \
+       ac_cv_header_stdio_ext_h=no \
 %endif
        CC="$xCC" \
 %if "%{?configure_cache}" == "1"
        --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
 %endif
+       --exec-prefix= \
+       --bindir=/bin \
+       --sbindir=/sbin \
+       --libdir=/%{_lib} \
        --disable-shared \
        --enable-static \
-       --disable-fsck \
+       --disable-agetty \
+       --disable-chfn-chsh \
+       --disable-cramfs \
+       --disable-kill \
+       --disable-ldattach \
        --disable-libmount \
-       --disable-login-utils \
+       --disable-login \
+       --disable-losetup \
+       --disable-minix \
+       --disable-newgrp \
+       --disable-partx \
+       --disable-raw \
+       --disable-runuser \
        --disable-schedutils \
+       --disable-setarch \
        --disable-silent-rules \
+       --disable-su \
+       --disable-sulogin \
        --disable-use-tty-group \
+       --disable-utmpdump \
+       --disable-uuidd \
+       --disable-vipw \
        --disable-wall \
        --without-audit \
        --without-ncurses \
-       --without-pam \
        --without-selinux
 
 # configure gets it unconditionally wrong
-sed -i -e 's/#define HAVE_WIDECHAR 1//' config.h
+%{__sed} -i -e 's/#define HAVE_WIDECHAR 1//' config.h
 
-sed -i -e 's/ cal\$(EXEEXT) / /; s/ lsblk\$(EXEEXT)//' misc-utils/Makefile
+%{__make} \
+%if %{with uClibc}
+       LDFLAGS="-Wl,-static"
+%endif
+%if %{with dietlibc}
+       CPPFLAGS="$CPPFLAGS -D_BSD_SOURCE" \
+       LDFLAGS="-lcompat"
+%endif
 
-for dir in libblkid libuuid disk-utils misc-utils fsck fdisk schedutils hwclock; do
-       %{__make} -C $dir \
-       %if %{with uClibc}
-               LDFLAGS="-Wl,-static"
-       %endif
-       %if %{with dietlibc}
-               CPPFLAGS="$CPPFLAGS -D_BSD_SOURCE" \
-               LDFLAGS="-lcompat"
-       %endif
-       # empty line required because there is a backslash up there
-       %{__make} -C $dir install DESTDIR=`pwd`/initrd
-done
+%{__make} install \
+       DESTDIR=$(pwd)/initrd
 
 %{__make} clean
 %endif
@@ -706,19 +741,29 @@ done
        --disable-silent-rules \
        --disable-use-tty-group \
        --disable-wall \
+       --enable-chfn-chsh \
+       --enable-chkdupexe \
        --enable-ddate \
-       --enable-line \
        --enable-kill \
+       --enable-libblkid \
+       --enable-line \
+       --enable-login \
        --enable-login-chown-vcs \
-       --enable-login-utils \
+       --enable-newgrp \
        --enable-partx \
+       --enable-runuser%{!?with_su:=no} \
+       --enable-su%{!?with_su:=no} \
+       --enable-sulogin \
+       --enable-utmpdump \
+       --enable-vipw \
        --enable-write \
        --with-audit \
-       --with-pam \
-       --with%{!?with_selinux:out}-selinux
+       --with-selinux%{!?with_selinux:=no}
 
 %{__make}
 
+%{__cc} %{rpmcflags} nologin.c -o nologin
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,init,security} \
@@ -728,16 +773,22 @@ install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,init,security} \
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-sed -i -e 's,/usr/spool/mail,/var/mail,g' $RPM_BUILD_ROOT%{_mandir}/man1/login.1
-
-%if %{with partx}
 mv $RPM_BUILD_ROOT%{_sbindir}/{addpart,delpart,partx} $RPM_BUILD_ROOT/sbin
-%endif
+mv $RPM_BUILD_ROOT/sbin/raw $RPM_BUILD_ROOT%{_bindir}
+
+install nologin $RPM_BUILD_ROOT/sbin
+install %{SOURCE11} $RPM_BUILD_ROOT%{_mandir}/man8
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/login
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/blockdev
 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/blockdev
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/init/blockdev.conf
+%if %{with su}
+cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/su
+cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/su-l
+cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/runuser
+cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/runuser-l
+%endif
 
 :> $RPM_BUILD_ROOT/etc/security/blacklist.login
 :> $RPM_BUILD_ROOT/var/lock/wtmpxlock
@@ -750,7 +801,9 @@ for lib in blkid uuid mount; do
 done
 
 ln -sf hwclock $RPM_BUILD_ROOT/sbin/clock
-echo '.so hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/man8/clock.8
+echo '.so man8/hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/man8/clock.8
+
+ln -s utmpdump $RPM_BUILD_ROOT%{_bindir}/utmpx-dump
 
 for d in cs de es fi fr hu id it ja ko nl pl ; do
        for m in man1 man5 man8 ; do
@@ -760,6 +813,20 @@ for d in cs de es fi fr hu id it ja ko nl pl ; do
                fi
        done
 done
+# it's been moved from man1 to man8
+for d in es ja ko ; do
+       mv -f $RPM_BUILD_ROOT%{_mandir}/$d/man1/readprofile.1 \
+               $RPM_BUILD_ROOT%{_mandir}/$d/man8/readprofile.8
+       %{__sed} -i -e 's/READPROFILE 1/READPROFILE 8/' $RPM_BUILD_ROOT%{_mandir}/$d/man8/readprofile.8
+done
+# fix inconsistent man links
+echo '.so man8/hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/es/man8/clock.8
+echo '.so man8/hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/clock.8
+echo '.so man8/swapon.8' > $RPM_BUILD_ROOT%{_mandir}/es/man8/swapoff.8
+echo '.so man8/swapon.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/swapoff.8
+echo '.so man8/swapon.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/swapoff.8
+echo '.so man8/swapon.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/swapoff.8
+echo '.so man8/swapon.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/swapoff.8
 
 # cleanup, remove files not included in package
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{chfn,chsh,newgrp} \
@@ -770,21 +837,25 @@ done
        $RPM_BUILD_ROOT%{_mandir}/*/man5/nfs.5 \
        $RPM_BUILD_ROOT%{_mandir}/*/man8/{elvtune,setfdprm,sln,ramsize,raw,rdev,rootflags,vidmode}.8
 
-%ifarch sparc sparc64
+%ifarch sparc sparcv9 sparc64
+# programs not built on sparc
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/{cfdisk,sfdisk}.8
 %endif
 
+# examples
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/getopt/getopt-parse.*sh
+
 %if %{with initrd}
 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
-install -p initrd%{_bindir}/* $RPM_BUILD_ROOT%{_libdir}/initrd/
-install -p initrd%{_sbindir}/* $RPM_BUILD_ROOT%{_libdir}/initrd/
+install -p initrd/bin/* $RPM_BUILD_ROOT%{_libdir}/initrd
+install -p initrd/sbin/* $RPM_BUILD_ROOT%{_libdir}/initrd
 ln -s fsck $RPM_BUILD_ROOT%{_libdir}/initrd/e2fsck
 
 # We don't need those
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/initrd/{chkdupexe,uuidd,mcookie,whereis,mkfs*,fsck.minix,isosize,logger}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/initrd/{cal,col,colcrt,colrm,column,ctrlaltdel,cytune,dmesg,flock,fsfreeze,fstrim,getopt,hexdump,ipcmk,ipcrm,ipcs,isosize,logger,lslocks,mcookie,mkfs*,readprofile,renice,rev,rtcwake,script,scriptreplay,setsid,tailf,tunelp,wdctl,whereis}
 
 %if %{with dietlibc}
-cp -a initrd%{_libdir}/lib*.a $RPM_BUILD_ROOT%{dietlibdir}
+cp -a initrd/%{_lib}/lib*.a $RPM_BUILD_ROOT%{dietlibdir}
 %endif
 %endif
 
@@ -830,12 +901,14 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc */README.* text-utils/LICENSE.pg NEWS
+%doc AUTHORS ChangeLog NEWS README README.licensing Documentation misc-utils/getopt-parse.{bash,tcsh}
 
 %attr(755,root,root) /sbin/clock
 %attr(755,root,root) /sbin/hwclock*
+%attr(755,root,root) /sbin/nologin
 %{_mandir}/man8/clock.8*
 %{_mandir}/man8/hwclock.8*
+%{_mandir}/man8/nologin.8*
 %lang(es) %{_mandir}/es/man8/clock.8*
 %lang(es) %{_mandir}/es/man8/hwclock.8*
 %lang(ja) %{_mandir}/ja/man8/clock.8*
@@ -882,17 +955,19 @@ fi
 %attr(755,root,root) /bin/kill
 %attr(755,root,root) /bin/more
 
+%attr(755,root,root) /bin/wdctl
+
+%attr(755,root,root) /sbin/chcpu
 %attr(755,root,root) /sbin/ctrlaltdel
-%if %{with partx}
 %attr(755,root,root) /sbin/addpart
 %attr(755,root,root) /sbin/delpart
 %attr(755,root,root) /sbin/partx
 %attr(755,root,root) /bin/lsblk
-%endif
 %attr(755,root,root) /sbin/fsfreeze
 %attr(755,root,root) /sbin/fstrim
 %attr(755,root,root) /sbin/mkfs
 %attr(755,root,root) /sbin/mkswap
+%attr(755,root,root) /sbin/sulogin
 %attr(755,root,root) /sbin/swaplabel
 %if "%{pld_release}" != "ac"
 %attr(755,root,root) /sbin/switch_root
@@ -906,6 +981,7 @@ fi
 %attr(755,root,root) %{_bindir}/column
 %attr(755,root,root) %{_bindir}/cytune
 %attr(755,root,root) %{_bindir}/ddate
+%attr(755,root,root) %{_bindir}/eject
 %attr(755,root,root) %{_bindir}/flock
 %{?with_fallocate:%attr(755,root,root) %{_bindir}/fallocate}
 %attr(755,root,root) %{_bindir}/getopt
@@ -919,9 +995,12 @@ fi
 %attr(755,root,root) %{_bindir}/logger
 %attr(755,root,root) %{_bindir}/look
 %attr(755,root,root) %{_bindir}/lscpu
+%attr(755,root,root) %{_bindir}/lslocks
 %attr(755,root,root) %{_bindir}/mcookie
 %attr(755,root,root) %{_bindir}/namei
 %attr(755,root,root) %{_bindir}/pg
+%attr(755,root,root) %{_bindir}/prlimit
+%attr(755,root,root) %{_bindir}/raw
 %attr(755,root,root) %{_bindir}/rename
 %attr(755,root,root) %{_bindir}/renice
 %attr(755,root,root) %{_bindir}/rev
@@ -933,11 +1012,14 @@ fi
 %attr(755,root,root) %{_bindir}/taskset
 %attr(755,root,root) %{_bindir}/ul
 %attr(755,root,root) %{_bindir}/unshare
+%attr(755,root,root) %{_bindir}/utmpdump
+%attr(755,root,root) %{_bindir}/utmpx-dump
 %attr(755,root,root) %{_bindir}/whereis
 %attr(2755,root,tty) %{_bindir}/write
 %attr(755,root,root) %{_sbindir}/fdformat
 %attr(755,root,root) %{_sbindir}/ldattach
 %attr(755,root,root) %{_sbindir}/readprofile
+%attr(755,root,root) %{_sbindir}/resizepart
 %attr(755,root,root) %{_sbindir}/rtcwake
 
 %{_mandir}/man1/cal.1*
@@ -948,6 +1030,7 @@ fi
 %{_mandir}/man1/column.1*
 %{_mandir}/man1/ddate.1*
 %{_mandir}/man1/dmesg.1*
+%{_mandir}/man1/eject.1*
 %{?with_fallocate:%{_mandir}/man1/fallocate.1*}
 %{_mandir}/man1/flock.1*
 %{_mandir}/man1/getopt.1*
@@ -964,8 +1047,8 @@ fi
 %{_mandir}/man1/mcookie.1*
 %{_mandir}/man1/more.1*
 %{_mandir}/man1/namei.1*
+%{_mandir}/man1/prlimit.1*
 %{_mandir}/man1/pg.1*
-%{_mandir}/man1/readprofile.1*
 %{_mandir}/man1/renice.1*
 %{_mandir}/man1/rev.1*
 %{_mandir}/man1/rename.1*
@@ -977,14 +1060,14 @@ fi
 %{_mandir}/man1/taskset.1*
 %{_mandir}/man1/ul.1*
 %{_mandir}/man1/unshare.1*
+%{_mandir}/man1/utmpdump.1*
 %{_mandir}/man1/whereis.1*
 %{_mandir}/man1/write.1*
-%if %{with partx}
 %{_mandir}/man8/addpart.8*
 %{_mandir}/man8/delpart.8*
 %{_mandir}/man8/partx.8*
 %{_mandir}/man8/lsblk.8*
-%endif
+%{_mandir}/man8/chcpu.8*
 %{_mandir}/man8/ctrlaltdel.8*
 %{_mandir}/man8/cytune.8*
 %{_mandir}/man8/fdformat.8*
@@ -992,12 +1075,18 @@ fi
 %{_mandir}/man8/fstrim.8*
 %{_mandir}/man8/isosize.8*
 %{_mandir}/man8/ldattach.8*
+%{_mandir}/man8/lslocks.8*
 %{_mandir}/man8/mkswap.8*
+%{_mandir}/man8/raw.8*
+%{_mandir}/man8/readprofile.8*
+%{_mandir}/man8/resizepart.8*
 %{_mandir}/man8/rtcwake.8*
 %{_mandir}/man8/swaplabel.8*
 %if "%{pld_release}" != "ac"
 %{_mandir}/man8/switch_root.8*
 %endif
+%{_mandir}/man8/sulogin.8*
+%{_mandir}/man8/wdctl.8*
 %{_mandir}/man8/wipefs.8*
 
 %lang(de) %{_mandir}/de/man1/kill.1*
@@ -1012,7 +1101,6 @@ fi
 %lang(es) %{_mandir}/es/man1/look.1*
 %lang(es) %{_mandir}/es/man1/more.1*
 %lang(es) %{_mandir}/es/man1/namei.1*
-%lang(es) %{_mandir}/es/man1/readprofile.1*
 %lang(es) %{_mandir}/es/man1/rev.1*
 %lang(es) %{_mandir}/es/man1/script.1*
 %lang(es) %{_mandir}/es/man1/setterm.1*
@@ -1024,6 +1112,7 @@ fi
 %lang(es) %{_mandir}/es/man8/ipcrm.8*
 %lang(es) %{_mandir}/es/man8/ipcs.8*
 %lang(es) %{_mandir}/es/man8/mkswap.8*
+%lang(es) %{_mandir}/es/man8/readprofile.8*
 %lang(es) %{_mandir}/es/man8/renice.8*
 %lang(es) %{_mandir}/es/man8/setsid.8*
 
@@ -1083,12 +1172,10 @@ fi
 %lang(ja) %{_mandir}/ja/man1/kill.1*
 %lang(ja) %{_mandir}/ja/man1/line.1*
 %lang(ja) %{_mandir}/ja/man1/logger.1*
-%lang(ja) %{_mandir}/ja/man1/login.1*
 %lang(ja) %{_mandir}/ja/man1/look.1*
 %lang(ja) %{_mandir}/ja/man1/mcookie.1*
 %lang(ja) %{_mandir}/ja/man1/more.1*
 %lang(ja) %{_mandir}/ja/man1/namei.1*
-%lang(ja) %{_mandir}/ja/man1/readprofile.1*
 %lang(ja) %{_mandir}/ja/man1/rename.1*
 %lang(ja) %{_mandir}/ja/man1/rev.1*
 %lang(ja) %{_mandir}/ja/man1/script.1*
@@ -1104,6 +1191,7 @@ fi
 %lang(ja) %{_mandir}/ja/man8/ipcs.8*
 %lang(ja) %{_mandir}/ja/man8/isosize.8*
 %lang(ja) %{_mandir}/ja/man8/mkswap.8*
+%lang(ja) %{_mandir}/ja/man8/readprofile.8*
 %lang(ja) %{_mandir}/ja/man8/renice.8*
 %lang(ja) %{_mandir}/ja/man8/setsid.8*
 
@@ -1121,7 +1209,6 @@ fi
 %lang(ko) %{_mandir}/ko/man1/mcookie.1*
 %lang(ko) %{_mandir}/ko/man1/more.1*
 %lang(ko) %{_mandir}/ko/man1/namei.1*
-%lang(ko) %{_mandir}/ko/man1/readprofile.1*
 %lang(ko) %{_mandir}/ko/man1/rev.1*
 %lang(ko) %{_mandir}/ko/man1/script.1*
 %lang(ko) %{_mandir}/ko/man1/setterm.1*
@@ -1134,6 +1221,7 @@ fi
 %lang(ko) %{_mandir}/ko/man8/ipcrm.8*
 %lang(ko) %{_mandir}/ko/man8/ipcs.8*
 %lang(ko) %{_mandir}/ko/man8/mkswap.8*
+%lang(ko) %{_mandir}/ko/man8/readprofile.8*
 %lang(ko) %{_mandir}/ko/man8/renice.8*
 %lang(ko) %{_mandir}/ko/man8/setsid.8*
 
@@ -1227,6 +1315,17 @@ fi
 %attr(755,root,root) /sbin/mkfs.cramfs
 %attr(755,root,root) /sbin/mkfs.bfs
 
+%if %{with su}
+%attr(755,root,root) /bin/runuser
+%attr(4755,root,root) /bin/su
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/runuser-l
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/su-l
+%{_mandir}/man1/runuser.1*
+%{_mandir}/man1/su.1*
+%endif
+
 %ghost /var/lock/wtmpxlock
 
 %files -n blockdev
@@ -1398,6 +1497,8 @@ fi
 %attr(6755,uuidd,uuidd) %{_sbindir}/uuidd
 %attr(2775,uuidd,uuidd) /var/lib/libuuid
 %{_mandir}/man8/uuidd.8*
+%{systemdunitdir}/uuidd.service
+%{systemdunitdir}/uuidd.socket
 
 %files -n libmount
 %defattr(644,root,root,755)
@@ -1426,5 +1527,25 @@ fi
 %if %{with initrd}
 %files initrd
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/initrd/*
+%attr(755,root,root) %{_libdir}/initrd/blkid
+%attr(755,root,root) %{_libdir}/initrd/blockdev
+%attr(755,root,root) %{_libdir}/initrd/fdformat
+%attr(755,root,root) %{_libdir}/initrd/fdisk
+%attr(755,root,root) %{_libdir}/initrd/findfs
+%attr(755,root,root) %{_libdir}/initrd/hwclock
+%attr(755,root,root) %{_libdir}/initrd/look
+%attr(755,root,root) %{_libdir}/initrd/mkswap
+%attr(755,root,root) %{_libdir}/initrd/namei
+%attr(755,root,root) %{_libdir}/initrd/rename
+%ifnarch sparc sparcv9 sparc64
+%attr(755,root,root) %{_libdir}/initrd/sfdisk
+%endif
+%attr(755,root,root) %{_libdir}/initrd/swaplabel
+%attr(755,root,root) %{_libdir}/initrd/uuidgen
+%attr(755,root,root) %{_libdir}/initrd/wipefs
+# not needed?
+#%attr(755,root,root) %{_libdir}/initrd/chrt
+# not built because of disabled libmount
+#%attr(755,root,root) %{_libdir}/initrd/e2fsck
+#%attr(755,root,root) %{_libdir}/initrd/fsck
 %endif
This page took 0.077712 seconds and 4 git commands to generate.