]> git.pld-linux.org Git - packages/uhd.git/blame - uhd.spec
utils is a dir, use glob to match all examples
[packages/uhd.git] / uhd.spec
CommitLineData
938948b4
BS
1%define ver_major 3
2%define ver_minor 8
3%define ver_patch 3
4
5%define ver %(printf "%03d.%03d.%03d" %{ver_major} %{ver_minor} %{ver_patch})
938948b4 6Summary: Universal Hardware Driver for Ettus Research products
938948b4
BS
7Name: uhd
8Version: %{ver_major}.%{ver_minor}.%{ver_patch}
9Release: 0.1
10License: GPL v3+
11Group: X11/Libraries
12Source0: http://files.ettus.com/binaries/uhd/uhd_%{ver}-release/%{name}-%{version}.tar.gz
13# Source0-md5: 84928825717678e77ffc400d73bcf412
938948b4
BS
14URL: http://www.qcustomplot.com/
15BuildRequires: QtCore-devel
16BuildRequires: QtGui-devel
24404f1d 17BuildRequires: boost-devel
938948b4
BS
18BuildRequires: cmake >= 2.8.0
19BuildRequires: qt4-build
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
938948b4
BS
21
22%define filterout -flto
23
24%description
25The UHD is the universal hardware driver for Ettus Research products.
26The goal of the UHD is to provide a host driver and API for current
27and future Ettus Research products. It can be used standalone without
28GNU Radio.
29
30%package devel
31Summary: Development files for %{name}
32Group: X11/Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36Header files for Universal Hardware Driver for Ettus Research
37products.
38
24404f1d 39%package doc
938948b4
BS
40Summary: Documentation and examples for uhd
41Group: Documentation
42%if "%{_rpmversion}" >= "5"
43BuildArch: noarch
44%endif
45
46%description doc
47Documentation and examples for Universal Hardware Driver for Ettus
48Research products
49
50%prep
51%setup -q
52
53%build
938948b4
BS
54install -d build
55cd build
56%cmake \
24404f1d 57 ..
938948b4
BS
58%{__make}
59
938948b4
BS
60%install
61rm -rf $RPM_BUILD_ROOT
62%{__make} -C build install/fast \
63 DESTDIR=$RPM_BUILD_ROOT
64
24404f1d
ER
65rm $RPM_BUILD_ROOT%{_libdir}/%{name}/utils/usrp_n2xx_simple_net_burner
66rm $RPM_BUILD_ROOT%{_libdir}/%{name}/utils/usrp_x3xx_fpga_burner
67
68# not packaged
69rm -r $RPM_BUILD_ROOT%{_libdir}/%{name}/tests
938948b4
BS
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
24404f1d
ER
74%post -p /sbin/ldconfig
75%postun -p /sbin/ldconfig
938948b4
BS
76
77%files
78%defattr(644,root,root,755)
79%attr(755,root,root) %{_bindir}/nirio_programmer
80%attr(755,root,root) %{_bindir}/octoclock_firmware_burner
81%attr(755,root,root) %{_bindir}/uhd_cal_rx_iq_balance
82%attr(755,root,root) %{_bindir}/uhd_cal_tx_dc_offset
83%attr(755,root,root) %{_bindir}/uhd_cal_tx_iq_balance
84%attr(755,root,root) %{_bindir}/uhd_find_devices
85%attr(755,root,root) %{_bindir}/uhd_images_downloader
86%attr(755,root,root) %{_bindir}/uhd_usrp_probe
24404f1d
ER
87%attr(755,root,root) %{_bindir}/usrp2_card_burner
88%attr(755,root,root) %{_bindir}/usrp_n2xx_simple_net_burner
89%attr(755,root,root) %{_bindir}/usrp_x3xx_fpga_burner
90%{_mandir}/man1/octoclock_firmware_burner.1*
91%{_mandir}/man1/uhd_cal_rx_iq_balance.1*
92%{_mandir}/man1/uhd_cal_tx_dc_offset.1*
93%{_mandir}/man1/uhd_cal_tx_iq_balance.1*
94%{_mandir}/man1/uhd_find_devices.1*
95%{_mandir}/man1/uhd_images_downloader.1*
96%{_mandir}/man1/uhd_usrp_probe.1*
58254af1
ER
97%{_mandir}/man1%{_prefix}p2_card_burner.1*
98%{_mandir}/man1%{_prefix}p_n2xx_simple_net_burner.1*
99%{_mandir}/man1%{_prefix}p_x3xx_fpga_burner.1*
24404f1d
ER
100%attr(755,root,root) %{_libdir}/libuhd.so.00*.00*
101%attr(755,root,root) %ghost %{_libdir}/libuhd.so.003
102%dir %{_libdir}/%{name}
58254af1
ER
103%dir %{_libdir}/%{name}/utils
104%attr(755,root,root) %{_libdir}/%{name}/utils/*.py
105%{_libdir}/%{name}/utils/uhd-usrp.rules
106%attr(755,root,root) %{_libdir}/%{name}/utils/*_eeprom
107%attr(755,root,root) %{_libdir}/%{name}/utils/*_utils
108%attr(755,root,root) %{_libdir}/%{name}/utils/*_sensors
109%dir %{_libdir}/%{name}/utils/latency
110%attr(755,root,root) %{_libdir}/%{name}/utils/latency/*
938948b4
BS
111
112%files devel
113%defattr(644,root,root,755)
114%{_pkgconfigdir}/uhd.pc
938948b4 115%{_includedir}/uhd
24404f1d
ER
116%{_libdir}/cmake/uhd
117%{_libdir}/libuhd.so
938948b4
BS
118
119%files doc
120%defattr(644,root,root,755)
24404f1d
ER
121%{_docdir}/%{name}
122%dir %dir %{_libdir}/%{name}
123%dir %{_libdir}/%{name}/examples
58254af1 124%attr(755,root,root) %{_libdir}/%{name}/examples/*
This page took 0.097611 seconds and 4 git commands to generate.